Start a new topic

App thinks only 5ghz available

Hi all, Had my 4 channel and th10 switches working last week before upgrading my WiFi to a TP-link Deco mesh system. After quite some time, over night, the 4 channel logged itself on and is now working however the th10 is refusing to connect. Everytime I tap the + sign to add a new device and select my wifi I am presented with "Currently, 5Ghz network is not supported". After checking the deco WiFi units provide both 5 and 2.4 GHz but there is no means of switching the 5ghz off. I'm assuming the problem is in the app not the device, any thoughts folks, don't really want to reinstall as getting the 4 channel working was a right pain. Thanks

1 person has this question

Make sure your phone is connected to the 2.4 GHz radio when you are adding the device so that the device will be sent the MAC address of the 2.4 wifi.

1 person likes this
Thanks for your reply. Don't see how I could do that, there's certainly nothing in WiFi settings to allow connection to 2.4 or 5 only. I have tried installing the app onto an old Sammy tablet that I'm pretty sure is 2.4 only but that made no difference at all, still get the same response when selecting the network.

Hmmmm,  If you have not already done it, completely delete the th-10 from your ewelink account and start over fresh with it.

1 person likes this
Yep tried that a few times as well
Just to be sure I installed a WiFi signal style app and there is a perfectly good 2.4 network in the house just can't get the bloody app to see it

I think I found a solution for you, I had the same issue using a Samsung S8+ connected to my home wifi. I downloaded an app from the App Store called "WIFI Manager"by Kostya Vasilyev. Open the app an look for your wifi network and connect to your network and select the lower channel number. The 5g works on the higher channels (mine was on 48). Once you connect to lower number (mine was Channel 4) network you can connect your devices.

I also has an issue pairing  all my sonoff devices when i got a new Ap.  I had to configure my Ap turning off the 5g signal.  i then connected my galaxy s9 and was able to connect all my devices.  After i turned back on the 5g signal, they still connected.

1 person likes this

I've been struggling with same issues on my Google mesh wifi which uses same ssid for 2.4 and 5, like many today. I've managed to get several devices connected but always hit or miss. The "WIFI Manager"by Kostya Vasilyev app is no longer on Google Play. However, I did find this discussion 

which I found very informative and his process did at least allow ewelink on my phone to see the 2.4 ghz network. He also points out that itead could do some work on their software to make this problem go away and he gives some insight on how to do it. 

From the pocketables link:

The issue here is these badly written apps are using the WiFi mac address you’re connected to to connect. This means if you’re connected to the 5GHz channel, you’re sending a MAC that’s not the 2.4GHz MAC. "

"While 2.4GHz is most likely better for distance (5GHz is speed,) the designers of these apps should be able to pull all MACs assigned to that SSID just by a quick sniff as opposed to making tons of hoops for most dual-band households to have to go through."

Hope itead developers see this. 95% of users would never go through this hassle to get a product working and I probably won't either in the future.

Figured it out! I used another phone to login and was able to add more devices

1 person likes this

I had the same problem. I used and old phone as well and is solved. Thank you very much for your help!

In my router I used different SSIDs for my 2.4GHz and 5GHz radios.  That probably explains why I have never had any of these pairing issues.  That might be an option for some to try.

I had this issue. I just installed an SSE TG589vac V2 router that works on 2.4 & 5GHz but luck ally you can switch off 5GHz  to do the connection. You just have to remember to log off the wifi connection on your phone / tablet that you have e we on then log back on with 5GHz turned off. It should then see the device.

Solved the 5ghz issues by buying for $12 a TP-LINK Tl-wa850re N300 Universal Wireless Range Extender Wi-fi Repeater. Ewelink did not work, but TuyaSmart did the trick for single and for a 3-gang switch. The setup for the Repeater was easy. The router is a Google wifi.

I set up my wife's phone as a hotspot with the same name and password as my 2.4+5G router/repeater, and then unplugged the router/repeater.  I had to "forget" the Wi-Fi info in the phone before it would let me log in to the new hotspot (probably MAC conflict security stuff).  With the 2.4G hotspot, all went as planned and the system is now working.  I'm going to buy a few more of these cheap things (now that I have the initialization method).

Login or Signup to post a comment