Start a new topic

Link to Google Home not working

I added a new switch to my eWeLink app and went to Google home to relink so that the switch was visible.  The link appeared to work and the devices, including the new switch appeared in the list, however, when I attempt to turn the switch on or off from Google Home, I get a response "Sorry there was an error and I am unable to control your home device"


14 people have this problem

Yes, some issues recently, my sonoff devices aren’t working with google home, either in home mini via vox control or the app. I have an Alexa, sonoff devices are working fine. So I would hazard a guess it’s an incompatibility issue rather than server. To be honest, Amazon has updated their app interface, it’s far more flexible now, way better than google home, and you can see the sync’d devices. It’s not just sonoff that doesn’t seem to work efficiently, maybe time for a change.

Is anyone having issues at the moment? For 3 or f4 days none of my SmartWeLink are working. Everything else works fine.
Starting from scratch, re-pairing everything, renaming everything, removing and adding back to Google Home has made no difference.
I use my SmartWeLink stuff in the most used stuff, and having to manually  turn stuff on and off is not what I was expecting to do with "Smart" devices.
I have emailed the company this morning, so will see what they have to offer when/if they get back to me.
I feel for anyone else, as I am sure that I am not alone.

Glad I found this. For me "ok Google, resync my devices" worked for me - the new device showed up after a few minutes.
after having tried everything possible in the past 24 hours I gave up. This morning all the sudden all is fine and functioning. It is definitely a server problem, I can'tell imagine anything else.

Same here. Devices worked only via ewelink app so does anyone know how is that possible? Does the signal from the app go to the devices without going through Sonoff servers, simply straight from app to device via home wifi?

Working again but they really must get their act together with this or I’ll be ditching the devices
Checked this morning and all is now working with Google home. Looking at the threads it looks like another European server has been down... come on guys stability is key to smart home technology, you need more resilient solutions in place.

1 person likes this
anyway thank you very much for your help 

1 person likes this
Don't know. :-(

1 person likes this
Yes Mirko, now it works... but... what caused this problem ??
Use command "Resync my devices" on Google Assistant. That solved my problems after 2 hours of tring everything.

1 person likes this
The same also in Italy... ☹️
I also have this problem. I have two switches that work good in the welink app. But Google home / assistant says there is an error.
same problem here too (Germany), eWlink works fine,  google home responds that there is an error.....

 

also i same problem,ewelink work only on app on my iphone,dont work with google home
Login or Signup to post a comment