Start a new topic

Link to Google Home not working

I added a new switch to my eWeLink app and went to Google home to relink so that the switch was visible.  The link appeared to work and the devices, including the new switch appeared in the list, however, when I attempt to turn the switch on or off from Google Home, I get a response "Sorry there was an error and I am unable to control your home device"


14 people have this problem

I'm having trouble connecting my google home account to Smart We Link, I login and it just flashes the screen or says "Accounts now linked" and just sits on that screen doesn't go any further.  Tried about 50 times now and still the same.  I know the account is correct as when i put in incorrect details it says.  So annoying stopping me buying any more devices.


Note have you tried telling google to Sync devices as that updates the device list of linked accounts.


1 person likes this
Use command "Resync my devices" on Google Assistant. That solved my problems after 2 hours of tring everything.

1 person likes this
Don't know. :-(

1 person likes this
anyway thank you very much for your help 

1 person likes this
Checked this morning and all is now working with Google home. Looking at the threads it looks like another European server has been down... come on guys stability is key to smart home technology, you need more resilient solutions in place.

1 person likes this
It seems Itead and EWeLink have problems with their servers in the way they handle accounts, as I posted last week I had problems linking my devices after adding new ones, I raised a ticket and the problem was solved, all working perfectly so far. It’s dissapointing as these devices are excellent when they work as they should and it puts me off buying more if I’m going to have problems every time I try to add a new one.

1 person likes this
Just tried to relink and still not working. Raised a ticket so we'll see.

1 person likes this
I am not on google home but I can confirm nothing is working on Amazon Alexa. I have raised a ticket regarding my voice assistants as soon as I get a response, I will let you know.

1 person likes this
What do you mean by completely reset your Google account? I'm not able to get the smart we link to register with Google home control. Put in my login info click login and it just blink and come back to the same login page. It is very frustrating.

1 person likes this

You can also say to Google: "Resync my devices".  That should get it to see the devices again.  You can use this instead of re-linking your account.


1 person likes this
Same here in UK, Abnormal network error when I try to pair with Google Home

I am in the UK.  My system was not working last night but this morning it is working again.  When I tried to turn lights on or off using Google Home, I got "I am unable to control your device".  I was able to switch the lights from the eWelink app though.  Over the weekend control from Google was mainly not working in the evenings but seemed to be ok in the mornings.  

I think all of Europe is using the same servers.   These servers should have been upgraded by now from what we were told (due mid-January), so, unless that upgrade has been delayed, these issues must be from the new servers. 

Yes same for me, I’m in the UK, I managed to pair my Sonoff devices again this morning, after spending hours trying to link my devices with Google Home at the Weekend. I have raised a ticket, it’s not good enough. These are good (if cheap) devices when they work but the company will suffer if they don’t rectify the the problem. I won’t be buying anymore until I know they are reliable.
hi,i have try also create a new account on ewelink and add devices,but link with google home dont work..i’m very sad :( i have other device one Bulb and one led strips a different brand with different but similar app,i have try add the different device in singolar app (Smart Life) and all work good,now my question is : is possible add sonoff device in other app similar at ewelink??
Login or Signup to post a comment