Start a new topic

Link to Google Home not working

I added a new switch to my eWeLink app and went to Google home to relink so that the switch was visible.  The link appeared to work and the devices, including the new switch appeared in the list, however, when I attempt to turn the switch on or off from Google Home, I get a response "Sorry there was an error and I am unable to control your home device"


14 people have this problem

Same here. Devices worked only via ewelink app so does anyone know how is that possible? Does the signal from the app go to the devices without going through Sonoff servers, simply straight from app to device via home wifi?

after having tried everything possible in the past 24 hours I gave up. This morning all the sudden all is fine and functioning. It is definitely a server problem, I can'tell imagine anything else.
Same problem here today, Google home speaker reports: "Sorry there was an error and I am unable to control your home device"

I also tried to unlink and tried to relink, but then the website times out when I try to sign in from there. With the ewelink app everything still works but no access from google home.

 

i am having the same issue. i can control through ewelink app, nut not google home. trying to relink and getting "nerwork abnormal"
Now this is very strange. I wanted to add a new sonoff device (6 existing devices were already added) to my Google Home. Hence I unlinked my Smart We Link account and went ahead to Link it again. I add my credentials and I'm back to Google Home app and it says Linked Successfully however it does not show the Assign Rooms page which it is immediately supposed to show nor it shows my devices. Also, if I go to Add Device on Google Home, I again find Smart We Link not added, I try to re-add, it again says Linked Successfully and I again find it not added. Been trying since 2 days. No luck so far. Can someone please help me?

Change name of devices in ewelink app and relink


Worked like charm! Thanks a lot!!

Yes. For me fortunately it works perfectly locally (control by ewelink with the phone connected by wifi network) but it almost never work if on the phone I close wifi and switch my data connection to 4G).

I know it is not an issue with the wifi router since I have seen it working once a few days ago.

Do you have the same symptom ?

Having the same trouble, if I unlink and relink my account it will work for 1 day then have to relink again

Server is down
I have the same issue. When I disconnected and reconnect I can control it through Google Home, but only for a short period. I get the message "Sorry there was an error and I am unable to control your home device" after a few minutes and then I have to reconnect all over again. It's really annoying.

At least you guy can relink.  Mine wont even do that and i dont know what else to do.  Any suggestions?

Have you raised a ticket? I had all sorts of problems last week but from what I can gather the servers were down and the message I got when logging in suggested that. Only thing I would try is to start again from scratch, delete all devices etc, try registering EWeLink with a new address or phone.

Same here, My sonoff G1 works great on ewelink. But when i link my sonoff on Google assistant on my Iphone, the app backs to first screen with blue plus.  I can´t choose the device model. 

Yes raised a ticket a little earlier.

I thought of that so created a new account on a new phone and linked it with a different Google account, worked for about 10 mins then got the same error as before.

Login or Signup to post a comment