Start a new topic

Link to Google Home not working

I added a new switch to my eWeLink app and went to Google home to relink so that the switch was visible.  The link appeared to work and the devices, including the new switch appeared in the list, however, when I attempt to turn the switch on or off from Google Home, I get a response "Sorry there was an error and I am unable to control your home device"


14 people have this problem

Having the same trouble, if I unlink and relink my account it will work for 1 day then have to relink again

At least you guy can relink.  Mine wont even do that and i dont know what else to do.  Any suggestions?

Have you raised a ticket? I had all sorts of problems last week but from what I can gather the servers were down and the message I got when logging in suggested that. Only thing I would try is to start again from scratch, delete all devices etc, try registering EWeLink with a new address or phone.

Yes raised a ticket a little earlier.

I thought of that so created a new account on a new phone and linked it with a different Google account, worked for about 10 mins then got the same error as before.

hi,i have buy two switch sonoff,i have add one device with app eWelink and after i have connect my account with google home and all work perfect..when i have add the second device in the app eWelink all ok,after i enter in google home for add new device and necessary unlink ewelink,but when i try the login in my ewelink account by google home dont connect. please help me,my account is keo_78@yahoo.it thanks for support

I'm having trouble connecting my google home account to Smart We Link, I login and it just flashes the screen or says "Accounts now linked" and just sits on that screen doesn't go any further.  Tried about 50 times now and still the same.  I know the account is correct as when i put in incorrect details it says.  So annoying stopping me buying any more devices.


Note have you tried telling google to Sync devices as that updates the device list of linked accounts.


1 person likes this
hi,i have try also create a new account on ewelink and add devices,but link with google home dont work..i’m very sad :( i have other device one Bulb and one led strips a different brand with different but similar app,i have try add the different device in singolar app (Smart Life) and all work good,now my question is : is possible add sonoff device in other app similar at ewelink??
I have SOLVED!!!! with app IFTTT is possible create a new applet with google assistant and ewelink app,one applet for on the switch and one applet for off the switch,and work perfectly!!! i attach the screenshot

Tech support came back this morning, they have re linked with Google and the say should now be ok.

Relinked both my phone's and are working at present.

Fingers crossed.

It seems Itead and EWeLink have problems with their servers in the way they handle accounts, as I posted last week I had problems linking my devices after adding new ones, I raised a ticket and the problem was solved, all working perfectly so far. It’s dissapointing as these devices are excellent when they work as they should and it puts me off buying more if I’m going to have problems every time I try to add a new one.

1 person likes this
Just tried to relink and still not working. Raised a ticket so we'll see.

1 person likes this

Same here, My sonoff G1 works great on ewelink. But when i link my sonoff on Google assistant on my Iphone, the app backs to first screen with blue plus.  I can´t choose the device model. 

Now this is very strange. I wanted to add a new sonoff device (6 existing devices were already added) to my Google Home. Hence I unlinked my Smart We Link account and went ahead to Link it again. I add my credentials and I'm back to Google Home app and it says Linked Successfully however it does not show the Assign Rooms page which it is immediately supposed to show nor it shows my devices. Also, if I go to Add Device on Google Home, I again find Smart We Link not added, I try to re-add, it again says Linked Successfully and I again find it not added. Been trying since 2 days. No luck so far. Can someone please help me?

Change name of devices in ewelink app and relink


Worked like charm! Thanks a lot!!
Login or Signup to post a comment