Start a new topic

Link to Google Home not working

I added a new switch to my eWeLink app and went to Google home to relink so that the switch was visible.  The link appeared to work and the devices, including the new switch appeared in the list, however, when I attempt to turn the switch on or off from Google Home, I get a response "Sorry there was an error and I am unable to control your home device"


14 people have this problem

I have SOLVED!!!! with app IFTTT is possible create a new applet with google assistant and ewelink app,one applet for on the switch and one applet for off the switch,and work perfectly!!! i attach the screenshot
It finally works now with google home. I tried many times. I had to completely reset my google account, register again google home and then it worked/ google home accepted the new switches.  Dont know if it works from outside my wifi network but it works now  with google home voice commands.

 

I'm now getting this problem again here in the UK. It started today 24hrs after the app was updated on my phone now none of my sonoff devices work via Google home they only work via the app. What's happened and what can I do to resolve this issue?
Glad I found this. For me "ok Google, resync my devices" worked for me - the new device showed up after a few minutes.

i have the same issue  works with ewelink app but not google assistant, my last update was 31st October for the ewelink app on android

I have the same issue too. it works with ewelink app but not with google assistant. Last update was today for ewelink app

also i same problem,ewelink work only on app on my iphone,dont work with google home
same problem here too (Germany), eWlink works fine,  google home responds that there is an error.....

 

I also have this problem. I have two switches that work good in the welink app. But Google home / assistant says there is an error.
The same also in Italy... ☹️
Yes Mirko, now it works... but... what caused this problem ??

Is anyone having issues at the moment? For 3 or f4 days none of my SmartWeLink are working. Everything else works fine.
Starting from scratch, re-pairing everything, renaming everything, removing and adding back to Google Home has made no difference.
I use my SmartWeLink stuff in the most used stuff, and having to manually  turn stuff on and off is not what I was expecting to do with "Smart" devices.
I have emailed the company this morning, so will see what they have to offer when/if they get back to me.
I feel for anyone else, as I am sure that I am not alone.

Yes, some issues recently, my sonoff devices aren’t working with google home, either in home mini via vox control or the app. I have an Alexa, sonoff devices are working fine. So I would hazard a guess it’s an incompatibility issue rather than server. To be honest, Amazon has updated their app interface, it’s far more flexible now, way better than google home, and you can see the sync’d devices. It’s not just sonoff that doesn’t seem to work efficiently, maybe time for a change.
Working again but they really must get their act together with this or I’ll be ditching the devices

Tech support came back this morning, they have re linked with Google and the say should now be ok.

Relinked both my phone's and are working at present.

Fingers crossed.

Login or Signup to post a comment