Start a new topic

Smart Switches S20/22 pairs with google home but functionality inactive

I've successfully added the smart power plugs S20/22 as devices into my google home, it shows up after linking into the eWeLink account with no issue.

However after trying to tell google home to turn off light (what i name the switches), google home responds by saying sorry that device is not yet setup. 

Basically it shows up as a linked devices in google home but functionality to control it is not there, can't turn on or off.

Anyone with experience can direct me here?

You should add room to every your device for switching. Did you do that?

Yes, it was added to living room. 

And what do you say to switch it on?

I called it lighs at first and tried "hey google turn on living room light", google home would respond with it looks like your device is not yet set up please go to the home app etc etc.

After I tried renaming it to fan and same issues, unlink, relink devices same thing. 

The device appears on the google home control panel but doesn't seem to be able to command the smart switches

i experience the same issue. When i had just one smart  switch it worked perfectly, but when i added 3 more - it stopped. Unlink adding different rooms is not helping. Please resovle!

I have a number of the Sonoff TH10 devices to control my lights. I found the easiest way to control them all with my Google Home was to set them up through IFTTT. I then could connect them to the google assistant and set my own commands for each device and what they would do for each command. A little more work, than just asking Google, but everything works perfectly.

En España se puede vincular ewelink a Google Assistant?
Login or Signup to post a comment