Start a new topic

S20 LED brightness

 Have been switching over my sockets and switches to Sonoff (previously using Energenie). However, one thing I found aggravating is the unnecessarily bright LED status indicator. In a night-time bedroom environment it illuminates the room with a radioactive glow you could almost read by.

Is there any way devs can implement a firmware fix for it? A toggle in the app to deactivate it would be good.

A couple of strips of electrical tape has dimmed it but it's not ideal.


4 people like this idea

I agree, I've just fitted one of these to assist my wife with mobility issues but she couldn't sleep with the brightness of the LED shining out across the room.

I've taped a flap of card across the push button to block the light. As Mark I says - not ideal.

If there's one thing worse than a bright LED in the bedroom.... A bright flashing LED when the server goes down (even if the LED is shaded!) The reduced light really does need to be done.

Has anyone found a solution to this?   I can't invest in this sytem if the light switch is illuminating the bedroom at night!

I desperately need a solution to this, Im installing T1 switches and sonof basics all over my house and the bedroom looks like a disco at night! driving me MAD.

a simple toggle to turn off the devices status LED in the app would make the WORLD of difference! Pretty please Sonoff...

1 person likes this
I used my S26's for the first time last night. I agree, "so much blue". Arduino can easily adjust the brightness of an led on a pwm pin. I haven't checked the schematics but hopefully they could even create a brightness slider for the blue led.

I don't own one of these but reading the comments makes me wonder if one could disassemble the unit and disable, shade, or block the LED at the board level.

Agreed I have 2 of these in the bedroom and the bright light from the led is really annoying when trying to get to sleep. A simple switch in the app could surely be used to turn these off
WAY WAY TOO BRIGHT, as are the leds on the Basic switches and the rest of the lineup. At least the Basic's led can be disabled in the most recent firmware, please add this feature to the S20 ASAP

I use Light Dims on ALL my leds, HiFi, phones, light switches, modems etc 

Come in diff shades etc

Great news. With firmware 2.1.6 which I upgraded to yesterday they have added the option to disable the green led. Blue led still shows when device is on but is a huge improvement well done to iTead for listening to feedback and rectifying this issue
I agree - it's great to see a company being responsive to user requests. Well done iTead!
Can Sonoff please implement a similar option in the next release of the App to turn off the LEDs for the T0 Light Switches. Better yet, link it to the schedule options. On during the day off at night.

Does this still work on the latest firmware ?

I can't see anything in my settings to turn off the LED - but I swear that I've seen the option in the past (or somewhere else)

It's changed its name and now appears as a "switch off network indicator" option. HTH, Pete
Login or Signup to post a comment