Start a new topic

Sonoff POW firmware has NO power on state

I have a few Sonoff basic and just bought a new Sonof POW. There is no power on state select for Sonoff POW as there is for Sonoff basic. I want to make sure that my Sonoff POW is always on when it is powered again after a power cut. Any idea what should I do?

13 people like this idea

Minh Nguyen: there is this functionality - look in the device setting menu. Check you have firmware 2.0.4

the firmware 2.0.4 has been closed
What does it mean "the firmware 2.0.4 has been closed"?
My firmware version is 2.0.2 but there is no button to update to version 2.0.4.
Can I update it manually? How to do that ?


This is the snapshot of Ewelink App.

There is no "cloud button" to update to newer version (2.0.4).

I have been reinstalled the application, remove device then add device again, change the smartphone, but it seems that firmware version 2.0.2 is the latest version.

Is there any way to update to newest version?

Odd. I'm on 2.0.4
firmware 2.0.4 closed at july. there is no new firmware so you can't upgrade it before they release it.

Why closed? I updated one device on 2018 march.

I need more device to upgrade from 2.0.2 to 2.0.4, because the most feature is keep power state.


2 people like this

I own many Sonoff PoW and they all were updated to 2.0.4.

But now 2 devices with fw 2.0.2 I bought this month can't get an update to 2.0.4. 

Any suggestions will be appreciated.

1 person likes this
I own several Sonoff POWs and all have 2.0.4. The two last ones I bought saying 2.0.2 is the latest and greatest. They are missing the power state feature now which sucks. I hope this is just a glitch on their update server and will be fixed soon.


5 people like this

Hi all, We have successfully installed and updated around 60 units from 2.0.2 to 2.0.4 in beginning of April 2018 (mostly pow's and a few basic versions). Then we needed to start a new project 4 days ago, and all of a sudden none of the POW device can update the firmware anymore,they are all stuck on v2.0.2 (tested 19 new units). The sonoff basic version has no problem,can still update the firmware fine. We tried different accounts, different wi-fi networks.deleting the units, reinstalling the units, reinstalling the ewelink app, tried with IOS devices and Androids. We do require the power on state and loop functions of 2.0.4 and beside having wasted a lot of time in testing the pow units, I find it quite annoying, cause besides the inability to update from 2.0.2 (latest software according to the app) the units perfectly perform all the functions of 2.0.2.

Can anyone give us any ideas of what the problem is.
Is it a Sonoff issue or a Ewelink issue?

And how can it can be solved fast?

Many thanks

6 people like this

I think it's not a random issue. I think SONOFF wants to buy the newer POW R2 device to use this feature.


this is not an elegant move from SONOFF team. Why not reply admin or support to clear this situation?

3 people like this
The last ones I bought have V2 printed on the electronic board. Still 2.0.2 is the latest they get...

3 people like this
Yeah, without power on state I think a bad bad bad things will come.... I don't have a option beside except cut off my 3 POW and stop recommend this thing to other.

1 person likes this
Please solve the update issue. I need power on state.

7 people like this
Login or Signup to post a comment