Start a new topic

SONOFF connection to range extender

I have a very weak wifi signal in my garage. I installed a range extender to boost the wifi, so I can use itching/self-locking switch to control my garage door. But it turned out that smart switch cannot connect to the router through the range extender. I also tried other SONOFF devices which worked the same way. But all the devices can connect directly to the router without a problem. Have anyone had the same problem and  is there a solution? 

3 people have this question

UPDATE: I contacted Itead Tech Support and they said that their devices cannot work with range extender. That's really bad. Any ideas how to solve this problem?

Just a guess but worth a try.  Make sure your cell phone is connected to the range extender when you set up the Sonoff.  The Sonoff gets the wifi router information from the phone and it may need to get the MAC address of the extender instead of the main router.

Another idea, if it is capable, is to give the range extender a different SSID than the main router.  Some devices will allow this.  Then make sure the phone is connected to the range extender when you set up the Sonoff.

Hi.  I have 4 separate Sonoff devices connected to a single range extender without a problem.  The range extender has a different SSID to the primary WiFi router so the suggestion by E W is a good one. 

1 person likes this

Thank you, guys, for replies. So, it looks like Sonoff devices can connect to the range extender. And it is partially true. I have three types of Smart Home devices: Sonoff Basic, TH16 and Inching/Self-Locking Switch. It turned out that Sonoff Basic connects to my range extender without any problem, but other two cannot connect.

I tried two range extenders - Tenda A9 N300 and TP-LINK TL-WA850RE - with the same results. My router is TL-WR841N. My range extender has different SSID  than router. I can try another router but it seems to me that the problem is rather related to Itead's devices than router. Sonoff Basic is the one of the oldest devices and, probably, it's firmware is different from the later models. 

The Itead support is of no help. Any ideas how to solve the problem?

Hmmm, I don't have anything but basics so I can't test this.  My gut says that wifi is wifi and it shouldn't matter if the device is connected to the main router or a repeater as long as the router and repeater are configured properly.  Make sure the main router is the only one issuing DHCP addresses and they are both on the same subnet.   One other thing you could try is connect the device to your main router then associate its MAC with a static IP address.  Once this is done, the try to connect it to the repeater.

Assigning static IP address doesn't work either.   

What happens if you turn off the wifi security and run it wide open?  Not suggesting you leave it that way but it might give you some insight into the problem.  There have been some changes in the WPA2 security protocols lately.  It might be something to do with different versions of it in the firmware of the devices.


I wish ITEAD would give you some feedback.  I am out of ideas.  I have 5 Basics running off a Ubiquity Bullet outdoor AP that is being fed with a cable from a router that is wirelessly bridged to my main router in the house.  So they are on the network essentially through 3 routers and work just fine.  Of course they are just the Basics which are also working for you.

Interesting, I just received two new Inching/Self-Locking Switches and both connect to my range extender but the old one doesn't. I didn't even try to connect them to the router. I afraid of experimenting. All three switches have the same newest firmware version.

Makes no sense to me.  If you have not done it already a few times, completely delete the old one from your ewelink account, hold the button down twice until you get it in rapid flash mode, then add it back to your network while the phone is connected to the extender.


I have now bought 10 basics.  I have one of them with fairly weak wifi connectivity.  It works but has about half the range of the other nine and shows a much lower signal level at the same distance.  So, there is some variation in the quality of these things.  Maybe you just got a bad one somehow.

My other three TH16 are not connecting to the range extender too. I tried many times deleting devices and pairing again, but no luck. 

I encountered an interesting issue which is somewhat connected to the topic.

I use Sonoff Basic, Dual, CH4 and TH16.  Since my devices are always live and internet issues may freeze the switches in its state, I switched off my wireless router and turned on a hotspot device (Uses the mobile 4G network to create a WiFi zone) which has the same SSID and password.  The Sonoff Basic and the TH16 connected to the internet and could be controlled with the EWelink App, but the Dual and CH4 switches remained offline.

Perhaps the Basic and TH16 connect based on the SSIDs whereas the CH4 and Dual also matches the MAC address of the router.

Based on this, some switches should also connect to the WiFi Extenders (may be).  Hope this helps.

I confirm that I suffer the same problem. I own a sonoff switch connected to my main router/access point which is the only one that works as dhcp server. It works great. 4 floors underground, connected via cable, I have another SAME model router, that I configured as access point. It work with all my devices except my sonoff 433 bridge. This access point has same ssid, same password, same WiFi channel and width. Same everything (except it doesn’t act as dhcp server ofc) of my main router where I configured at first this sonoff successfully. So it works just with my main router. Deleted, resetted, nothing changed. It connects just on my living room router. The only thing I haven’t tried is changing the ssid name of the second access point BUT it has two ssid (the second one is different and used for guest network), and my bridge doesn’t connect to that one too. IMHO it is something related to MAC address then. But it’s just supposed. I haven’t connected yet to web interface of it because idk if it actually have... I’ll do some tests in the future maybe. Hope that someone would help facing this problem.

Just a random thought.  I have not experienced this issue so I cannot test it.  Since the Sonoff is getting the wi-fi configuration from the phone what if you first totally delete (forget) the wi-fi connection in the phone.  Then connect the phone to your extension access point.  Then add the Sonoff back.  It may be possible that the phone, using a stored profile from the original router with the same SSID, is passing to the Sonoff switch the old MAC address from the original and not the new MAC from the extension.

Login or Signup to post a comment