Start a new topic

TH16 stopped working wont connect to server

Hi, I am using TH16 for few weeks now. Today I noticed I cant connect to it. I checked device its working, on off button works, but in ewelink application it says its offline. I tried pairing it again, tried also pairing it on another router with second internet connection, but its still offline. It was working fine until now and I didnt changed anything. Can someone help, its constantly blinking twice fast in sequience like it cant connect to server. V

16 people have this problem

Same problem here. After a few months my SonoffTH16 stopped answering to ping and now i can't get it into flash mode anymore.

1 person likes this
I also tried connecting to the devices own wifi, and configuring that way but same result. Pairs successfully but shows offline. The forums show many people have had this problem, but I can't find any successful resolutions. Does itead monitor this site ? can't believe there are thousands of these things sitting out there blinking offline
Same with me, my sonoff stoped working yesterday. Tried to restart it, removed from app and added again but result is the same device is offline, connected to router but not to the sonoff server. I guess that company made some changes in there servers and th16 can not connect it anymore or thay released faulty update and devices are now bricked. It would be nice if some official from company could give us explanation!

Thats interesting as I just got 2 new TH16's and the EWELINK registration works but they won't connect

to my WIFI ( blue light stays on ) and are listed as offline in my EWELINK app.

All my other Sonoff devices ( I have about 25 of them ) all work without problems, just this TH16 seems

to have some issue.

I hope this is resolved soon as otherwise they are useless and I wanted to buy more of them.

Somewhat dissappointed.

I have looked at a diagnostic help

and my light blinks 2 times quickly then repeats. According to the information this means my

TH16 does connect to my local wifi but cannot connection to the ITLEAD server so this would

seem to be a Server side problem they need to fix.

Something has changed causing this problem only with the TH16 but no other sonoff devices

 I have the same problem, all my sonoff devices are online except the TH16 which does not connect via the Zyxel VMG8825 router. If I use a Fritz 3272 router the TH16 connects to the server and works properly.

solution ?

Today all my POW can't connect to ewelink (continuous double blink blue led). From FAQ seems it can't connect to server correct? My Internet is working fine

I have since added another sonoff device ( RF Bridge ) after my failed attempts to connect the TH16 and

this worked so clearly the issue is with the TH16 devices and nothing else.

david, how you solved the "offline problem"?

Have the same problem with both a POW and a TH16.    Managed to connect a DIY without a problem.

Hi , Same pb here , (iphone &ipad) I think this started with the last EWlink upgrade , Is this still working for android users ? Thanks for feedback Johan

I'm an Android user.

Thanks Ivan , I am afraid we will have to wait on an update from itead . Johan

Hi guys :-) Nope no solution yet. I have gotten a response from ITEAD and will try that, 

but they want to know the firmware version but in ewelink this is stated as "unknown"

at the moment. I suspect because its the ITEAD server that sets this value.

I also have a POW which works. I've got almost everything from them.

I'm enjoying the DIY Smart home Project I'm doing with the sonoff products and am looking forward to

them developing even more options/devices. They don't support scenarios in Alexa yet but that will come 

I suspect.

They only problem I have is that my wife is harassing me for turning our house into a Smart Home Laboratory, she thinks its creepy. 

I'm very happy that ITEAD has create all these products at a reasonable price, it will drive the Smart Home industry and world because I wouldn't spend thousands on overpriced hardware from the

name vendors when they don't offer anything more than the ITEAD Solutions.

That was the answer from ITEAD :


Dear david rogers,

Did you ever update TH  firmware before offline?

Where are you come from?

The device firmware version?

Try to Make a smart phone as hotspot connect to Internet,use another smart phone connect device to this hotspot_can it work? if can't,how the device led blinking?

Please connect device to your server,even if device is offline.

And tell me your  device ID, like ITEAD-10000xxxxx,you can see on the top of relay or pairing process or in Wlan

Also please submit this issue on ewlink feedback.

Login or Signup to post a comment