Start a new topic

TH16 stopped working wont connect to server

Hi, I am using TH16 for few weeks now. Today I noticed I cant connect to it. I checked device its working, on off button works, but in ewelink application it says its offline. I tried pairing it again, tried also pairing it on another router with second internet connection, but its still offline. It was working fine until now and I didnt changed anything. Can someone help, its constantly blinking twice fast in sequience like it cant connect to server. V

15 people have this problem

I've had a very similar response from Itead .... http://support.iteadstudio.com/support/tickets/62813


Sounds like I'm undertaking a very similar automation project to yourself - I have 20 sonoff products working at the moment and am looking to add a few more (perhaps at discounted Black Friday prices tomorrow).  


I'm mainly using them for lighting but also powering off devices I would normally leave on standby to save power as well as being able to shutdown my central heating and hot water if I'm not at home by interrupting the thermostat circuits - so basically have the functionality for a Nest/Hive for just £10.


I also have all these linked to a few Amazon Echo devices.


Like you everything else have have set up continues to work (including POW and TH16 units) as well as being able to set up a DIY unit this week - so I suspect it should be a simple fix once the cause is identified.


I've had just one failure of a sonoff device - a POW unit stopped working after a few days - a capacitor failed I think but other than that everything has worked perfectly (Banggood replaced the item - it is this I'm trying to set up now).  I have watched some of John Ward's videos on youtube (https://www.youtube.com/watch?v=SLK84ZJ291k) where he has tested some devices to destruction so give confidence in their quality.

+

The same problem with TH10 and TH16.

Sounds Familiar :-)


I have about 20 lights hooked up and the IR Bridge now to a PIR ( Motion sensor ) so my lights go on and off based on movement, am adding a second one today.


I use the POW for my Oven / Microwave and will be adding a couple for the washing machine and 

the 3 Heating pumps I have which I suspect are using way too much eletricity ( the modern pumps use about 10% - 20% of that ).


I'm just starting the Heating, have the 4 CH to turn on and off the pumps, but I want to connect up at least

4 TH16's, 1 outside, 1 in the living room, 1 on the Circulation Pipe In and 1 on the Pipe out.


We have radiators and floor heating on the Zentral Heater so actually I'd like 4 TH16's to monitor the

heat disapation and adding a POW to the Heating itself so I can see when its active or not.


All lots of fun and better than any proprietary Smart Home system and for a couple of hundred 

Euros in the end ( it does add up ! ).


Then I suspect I'll have bragging rights for at least 5 - 10 years till everyone gets this sort of environment

as standard :-)





Good to know, it does seem to be restricted to these sensors. 


I'd love for them to add a PIR Sensor so I don't have to use the RF Bridge / Wireless PIR solution.


Then a Light Sensor ( dark or daylight )


Then a sound sensor


Then a Camera .... ( with motion detection of course ) 


Then a ....



I also have a RF Bridge and just got a couple of compatible PIRs last week - my original one's would not pair with the Bridge.   Got them working together but not yet set up in any useful capacity.


Using the POW as a mobile device at the moment to understand the usage of various appliances.   Still a little cautious before I hard wire them into high powered devices - but had it on the 2.5kW tumble drier for the past few weeks and it has worked without issue - no temperature rise noticeable during use.  The failure of the first unit has just made me a little wary.   


I use one TH16 to monitor temperature and to control a fan I have directed to blow air across a radiator behind a couch - just to improve the convection heat transfer.   Likewise want more TH devices to monitor conditions around the house (and one in the loft).   


Also enjoying the technical challenge to get all this working and to identify the opportunities.



I also have other devices like wifi socket from sonoff here on the same router and they work. Only th16 is a problem. But there are two th16 in other city that work. It confuses me so much

Firmware and a server compatibility issue I suspect

Hi Tim , Just leave the power on the working devices Here the problems started after a power cycle Johan
what do you mean by "power cycle", Johan? I left the power on and sent IDs to the support. Will pray that they help :)
As long as the input power is on the TH10 you are fine ( i think) Firmware 2.0.1 is giving problems here. Johan

When TH16 was working, it wanted to upgrade firmware. However I do not know now, which version I had and to which version it wanted to upgrade. I did not upgrade, because earlier it stopped working. :-(

I even made hotspot from another device (smart phone), which had other provider of internet (Not my local network, but mobile data). TH16 connected with that hotspot, but it still blinked twice per sec.

That smart phone, making hotspot, tells me that there are two devices connected (My phone with application Ewelink and TH16). It means TH16 IS NOT ABLE TO CONNECT TO ITEAD SERVER, ITEAD has a problem. Please solve it!


Same problem with my Sonoff TH16 which I just received today. Connected perfectly to my eWeLink app on my android phone but then it just shows as offline? firmware is saying Unknown. My Sonoff Dual is working perfectly with the same phone. This must be a server side problem with just the TH16 so I hope they fix this soon.

Also the eWeLink app is draining my battery like crazy. eWelink app is using almost 50% of my battery in one day.

Come on guys, fix these problems asap.

A TH16 turned up Monday from Amazon and after pairing the blue light blinks twice quickly and the device is shown as off line in the app. So returned to Amazon believing the TH16 faulty, next one arrived and same problem. Learning about these devices, but am I right in saying this is a server problem?  

I think they are having a MAJOR problem as the POW's I just ordered (2 different ones) also doing the same thing.  I am pairing with IOS and once complete, get the blue light blinking twice issue with both units.  They need to fix this soon.

Graeme - that's what it appears to be, so many of us have the same problem on two different types of switches.

Login or Signup to post a comment