Start a new topic

Sonoff 4CH pro offline after a while

My sonoff 4CH pro (240V) goes offline after a while. I did some troubleshooting myself, i work in the IT wireless and networking business but i can't get it fixed.

Firmware 2.0.1 (latest)

Pairing was succesfull. Device is online in the E-welink app. But for some reason after a couple of hours, or one day, it is showing offline. Tried multiple devices, all showing offline.

Cutting the power and put it back on, solves the issue, again for a couple of hours. Then offline again.

The led blinking is saying, it has connection but no connection to the router. That's seems to be correct.

I can ping the device over the Wifi. I have ubiquity wifi. The AP the device is on is not busy, almost no other wifi devices. I have other Always online devices which do not have problems at all.

- I tried already to disable the firewall at the router (switched from low to off). It did not help.

- Also tried reconnecting the Sonoff device at the wifi. After a while it is pingable again. Still showing offline.

- Changed DNS servers. All the servers in the troubleshooting guide are pingable from my network.

So i'm stuck right now. What can i do to make it work without going offline? Can i access the device with telnet or SSH, or get some kind of logging out of it?

1 person has this problem

I justed paired the device again, now on my internet provider router. It is paired again. Lets see what happens in a couple of days.

Connection seems to be ok and stable now. So there seems to be something wrong with my ubiquity wifi or network switch allthough i disabled all firewalling completely.

I wil investigate the ubiquity asap. If i find something interesting i will post it on this forum.

Hi did you ever get this resolved? I have the exact same problem with 4ch pro and Unifi AC lite APs. Device connects ok then few hours later just goes offline. Power cycle fixes for a while then dies again. Having device right next to my AP helps but is far from ideal.
Still no Solution. Updated the WiFi a couple off times but no effect. I did not have time to investigate. I have bought a power plug model also (Sonoff s20) This is running a lot better. It does disconnected sometimes but it recoveres itselfs. So don’t have to disconnect.
seems to be itead server problems. DNS is ping able but asia servers are all offline.
But it does connect. Offline servers don’t have to be a problem if there are multiple configured (with Some offline) i’m located in Europe by The way
it does matter because when its offline i can't control my switches (4ch) with ewelink application via mobile phone or any other service like IFTTT
there may be also some software problem/bug, or time out etc because once its oflline it doesn't re-connect itself. There is no option to reset the device without unpluggin it !. until disconnected from the power source it doesn't reconnect to the servers.
Login or Signup to post a comment