Start a new topic

SonOff RF bridge always ofline

Hi I received yesterday a SonOff RF Bridge.

I succesfully installed it with the latest (3.0.0) eWeLink Android app. The device came with the 1.0.0 firmware. I saw that firmware 1.0.1 was available and I tried to upgrade it. Once upgraded it appeared online on the eWeLink Android app. I rebooted it again and from that point it always appears offline on the eWeLink Android app.

The device gets an IP address and I can ping it from my computer on the same network. The blue led is flashing twice which according to the trouble shooting manual it seems that it cannot connect to the server. The server for my region is pingable from my location (

I have tried many things:

- remove the device from the eWeLink Android app and follow again the 'pairing' procedure. The app discovers the device but it alwasys appears offline. I tried this many times.

- tried different wifis with different routers

The problem remains the same: It pairs with the app and then it shows up as offline. The blue light is always blinking twice which translates that it cannot connect to the server.

Question: Since I have a '3.3V FTDI USB-to-Serial Converter/Programmer' can I restore the orginal firmaware? Can I download it from someplace and flash it on the device? Thanks!

5 people have this problem

Version 3.4.1 firmware is available I am busy upgrading and I hope it fixes the issue 


1 person likes this

Same, I upgrade from 3.3 to 3.4. Sonoff RF bridge get in offline mode (2 different, in different WIFI conections, same issue). If I reset power connect well for some minutes, but, after some minutes, they get offline again, and turn online automatically , and so on. Any solution?

1 person likes this
Same, I upgrade from 3.3 to 3.4. Sonoff bridge get in offline mode, blinking 2 time per second. If I reset power connect well for some minutes. What is wrong with thiese updates?

2 people like this
Hello, I have just updated my sonoff RF bring from 3.3 to 3.4 update. The sonoff bridge will get off line after some time like 15 ; 20 minutes , I have also assign the static IP the problem is not solved. Regards Ashish Malviya India

3 people like this

I had many connection problems with the RF Bridge version 1: appears to be always ofline and could not be solved by the Itead engineers. (second problem: after sales service = very slow in answering!)

The main cause in my opinion is mostly assigned to router problems: for instance a hidden SSID and the router may only broadcast 2,4 ghz and not 5 ghz if you connect for the first time.

After many testing and trying without succes, I decided to flash my sonoff RF bridge with the espurna software (first link Jafterdark) and all the connection problems were gone. Now I have a working bridge that reports to mqtt. Also the tasmota software (second link dr Zzs) is very good to consider. Success !!

I bought A SECOND BRIDGE. the first one is excellent but the second one is always offline. Please help

My device is at last ONLINE !!!


1 person likes this

I can confirm, my device is online too. Thanks!

I just received a reply on my ticket that they had some issue and it should be ok now.

I rebooted the device and I am connected again!!!

Thanks ITead for your help!

I think it had to do with an issue with the 1.0.1 firmware. I am located in Europe and use most likely the server.

1 person likes this
I have same problem after upgrade. I have try everything. Regret updating.

1 person likes this

Exactly the same here: Since the firmware update, the bridge is always offline and seems to be dead.

Have spent several hours to examine the problem, but nothing helps: disable/enable MAC filtering does not affect, removing the device from the eWeLink Android app and renew the pairing procedure does not help. Enabeling SSID does not help. The app discovers the device but it stays offline. I tried this annoying nightmare many many times, also with different routers and with different wifi network (friends), but nothing helps and apparently Itead does not respond to opened tickets...

3 people like this

they replied the same thing to me, to disable MAC filtering. However I do not have MAC filtering enabled on my router. I do not think that this is the issue.

Has anyone solved the problem ? my device is Always offline

they replid saying to make sure it is disabled the mac filter on the router , but the device is Always offline

1 person likes this

I have the same problem. Since the update, the bridge is alway offline. No way to interact with the bridge.

1 person likes this
Login or Signup to post a comment