Start a new topic

SonOff RF bridge always ofline

Hi I received yesterday a SonOff RF Bridge.

I succesfully installed it with the latest (3.0.0) eWeLink Android app. The device came with the 1.0.0 firmware. I saw that firmware 1.0.1 was available and I tried to upgrade it. Once upgraded it appeared online on the eWeLink Android app. I rebooted it again and from that point it always appears offline on the eWeLink Android app.

The device gets an IP address and I can ping it from my computer on the same network. The blue led is flashing twice which according to the trouble shooting manual it seems that it cannot connect to the server. The server for my region is pingable from my location (

I have tried many things:

- remove the device from the eWeLink Android app and follow again the 'pairing' procedure. The app discovers the device but it alwasys appears offline. I tried this many times.

- tried different wifis with different routers

The problem remains the same: It pairs with the app and then it shows up as offline. The blue light is always blinking twice which translates that it cannot connect to the server.

Question: Since I have a '3.3V FTDI USB-to-Serial Converter/Programmer' can I restore the orginal firmaware? Can I download it from someplace and flash it on the device? Thanks!

5 people have this problem

I had many connection problems with the RF Bridge version 1: appears to be always ofline and could not be solved by the Itead engineers. (second problem: after sales service = very slow in answering!)

The main cause in my opinion is mostly assigned to router problems: for instance a hidden SSID and the router may only broadcast 2,4 ghz and not 5 ghz if you connect for the first time.

After many testing and trying without succes, I decided to flash my sonoff RF bridge with the espurna software (first link Jafterdark) and all the connection problems were gone. Now I have a working bridge that reports to mqtt. Also the tasmota software (second link dr Zzs) is very good to consider. Success !!

Hello, I have just updated my sonoff RF bring from 3.3 to 3.4 update. The sonoff bridge will get off line after some time like 15 ; 20 minutes , I have also assign the static IP the problem is not solved. Regards Ashish Malviya India

3 people like this
Same, I upgrade from 3.3 to 3.4. Sonoff bridge get in offline mode, blinking 2 time per second. If I reset power connect well for some minutes. What is wrong with thiese updates?

2 people like this

Same, I upgrade from 3.3 to 3.4. Sonoff RF bridge get in offline mode (2 different, in different WIFI conections, same issue). If I reset power connect well for some minutes, but, after some minutes, they get offline again, and turn online automatically , and so on. Any solution?

1 person likes this

1 person likes this

Version 3.4.1 firmware is available I am busy upgrading and I hope it fixes the issue 

Login or Signup to post a comment