Start a new topic

Sonoff Switch Stopped working after 3 days! Please Help


I bought one of these off amazon about 3 days ago:

WIFI Smart Sonoff Touch Switch Wireless Smart Phone Remote Control Touch Via APP eWeLink for Home Automation (EU standard) Need Neutral and Live Wire


Downloaded the App on my iphone, installed the switch, paired using my network wifi with no issues installing it. It has worked for 3 days and simply stopped. The switch operates normally if using it manually, it also connects just fine with my router as I can see it listed on my device list (see attached screenshot).


I have tried removing the device from my network list of devices to no end, I have also tried to give a fixed ip address ( on my network) as this was the original ip DHCP assigned to it.


When I open the eWeelink app, it shows the proper status of the switch (when it is ON or OFF) but when I click on the button to either turn it on or off, nothing happens and I get a popup :


"Operation Failed, please check network connectivity" But the device is online on my router device list!!! Phone is also connected to same network, but yesterday I did manage to turn on the lights remotely, this started to act up this morning!



Firmware version is 1.6.2 (Latest) 




4 people have this problem

Not sure what happened but thank you support team and The problem is solved by itself. 

Login or Signup to post a comment