Start a new topic

Sonoff Switch Stopped working after 3 days! Please Help


I bought one of these off amazon about 3 days ago:

WIFI Smart Sonoff Touch Switch Wireless Smart Phone Remote Control Touch Via APP eWeLink for Home Automation (EU standard) Need Neutral and Live Wire


Downloaded the App on my iphone, installed the switch, paired using my network wifi with no issues installing it. It has worked for 3 days and simply stopped. The switch operates normally if using it manually, it also connects just fine with my router as I can see it listed on my device list (see attached screenshot).


I have tried removing the device from my network list of devices to no end, I have also tried to give a fixed ip address ( on my network) as this was the original ip DHCP assigned to it.


When I open the eWeelink app, it shows the proper status of the switch (when it is ON or OFF) but when I click on the button to either turn it on or off, nothing happens and I get a popup :


"Operation Failed, please check network connectivity" But the device is online on my router device list!!! Phone is also connected to same network, but yesterday I did manage to turn on the lights remotely, this started to act up this morning!



Firmware version is 1.6.2 (Latest) 




4 people have this problem

Sorry if it don't work guys but it did for me im on a Iphone 
I don't know why but I'm happy to say that now it works. Now I'm trying the second one. Registered but still waiting to see it on line. I'm crossing my fingers.
Hello, unfortunately an update by me. The second equipment paired is still not working and even worst the first one once shouted down was not able to be reconnected again. I made some analysis and it seems to be a problem with the router connection. I suppose that the equipment is presenting itself always with a different MAC and this is also preventing the possibility to assign a fixed IP. BTW when correctly connected the blue led is fixed and now is blinking. At this moment again nothing is working. Sigh. I'm afraid that it is not a good purchase and I also bought others equipment by eBay. May someone from itead help me? It seems really a SW issue and not a internet one. Many thanks for the support. Fabrizio

HI Fabrizio,

Strange about the MAC address, that should not be a behaviour by the device!

Please try to turn off power on your mains to the lights the switch is connected to then reconnect and try to pair again.

There is definitely something odd abut getting diff MAC addresses 

Occassionally i have to reboot my wifi router to improve its connectivity but I've never set a fixed ip for the sonoff devices. I would delete the devices from the ewelink app, and relaunch the device installation process from the start. Like most IT products they can be temperamental sometimes.
Thanks Herick, I agree with you that is very strange even forbidden. Btw I'm still not able to use anymore my equipment. The pairing works fine and the message as feedback is good. Then they are not working. Only yesterday was working until I rebooted it. Is there any official support where I can write?

1 person likes this

Comment on "I won't go more deep into this, but keep in mind ...
    - SonOff and other related products are based on an infrastructure, which is called internet
    - internet is nothing under Iteads control" :

Gerry Kropf needs to be made aware that my "other related products" work fine - the issue is with SonOff. Clearly there is something flakey with this company independent of the 'infrastructure'. I am running D-Link & WeMo smart switches on the same network and they all work fine all of the time.

Hi, I am pretty fed up with these devices now. I have bought 10 switches of all different types, and they all loose server connectivity alltogether every other day for a couple of hours now. The first few weeks all was fine, then this behaviour started happening. 

My internet, my WLAN, all is stable and my other IOT devices are workin fine, just the .... sonoff devices loose contact to their home. Then, after a few hours, they connect fine again and all is back to normal. 

I am pretty sure this company is having a severe server issue. OK, they are still a bargin and I will probably re-flash them and use them otherwise, but my impression is, they just dont care about customers.

There is nothing more annoying than a smart home device not working reliable. 

Please fix the issue anyways, SONNOF, ITEAD or whatever.

I can only state my 100% agreement with the commenator before and have started to create negative reports on amazon and other platforms. Anybody who reads this: Do not buy unflashed sonoff switches if you want to do yourselves a favour, their software integration and cloud service makes the product unusable. This is NOT an intermet infrastructure problem but a shitty server and software integration one which ITEAD do not care to solve. But they for sure sell goods on false promises which is close to be fraudolent.
After my devices keeping going offline a few times in the last few weeks I’m convinced that the the problem is with Itead, as the leds are double flashing and I can see them on my network. So it must be at their AWS server, either they are updating software or it’s a Firewall problem out of China. If it is a software update just tell us then at least we know, if it’s the China firewall restriction then I appreciate it’s beyond their control so I would suggest using servers outside of China.
This company is a joke, all I keep reading are passive aggressive excuses as to why it's not their fault and insinuating that it's everyone else's fault but their own. Your product has one job, ONE! And can't even do that. you blame the internet where Siri, google, Alexa and the other most simplest of internet devices work flawlessly, consistently. Don't represent trash products if you don't like being blamed. Simple Trash products, trash company Don't buy.
@ Gerry the statement from sonoff... "SonOff and other related products are based on an infrastructure, which is called internet - internet is nothing under Iteads control" With regards to this issue it is utter mince. Sonoff and related products are based on what servers sonoff use for this cloud based service. An example my internet is fine in every other way until I use a sonoff product which is the only cloud service in my infrastructure that doesnt work. My hive system is fine, my alexa goods are fine, my broadlink RM pro is fine, my smart doorbell and security IP cameras are fine. All are cloud based like sonoff. Sadly its only my sonoff equipment that has issues out with all of the above. Newyear outage was bad enough now it looks like we are facing the same issues. With regards to excuses used previously such as DDOS attacks etc... Again is all mince. Every server in the world gets DDOS attacked by kids yet its only sonoff that goes down intermittently. Most hosting providers including AWS provide protection from such childish attacks. So what all this tells me is sonoff have servers that are over utilized. Such services should be on Managed dedicated servers in a data centre. I wreckon sonoff are probably using a small shared server or a dedicated server that simply isnt good enough for such services. YET AGAIN DOWN TIME IN THE UK.
There is a Facebook page, Ewelink, which seems to have some info on the problem, it appears AWS Germany has a server overload, just be patient it will come back on line. Spending £30 per switch with Hive is no more reliable, at least Sonoff switches are cheap and they do work quite well.... most of the time.

1 person likes this
I have had my hive bulbs, sockets etc since October and I havent had any downtime at all and thats the gods honest truth. I want sonoff to work as they are cheap as chips compared to hive. Sonoff are just proving that you get what you pay for.
Agree you get what you pay for, anyway I rebooted my WiFi router and all working again.
Login or Signup to post a comment