Start a new topic

Sonoff Switch Stopped working after 3 days! Please Help


I bought one of these off amazon about 3 days ago:

WIFI Smart Sonoff Touch Switch Wireless Smart Phone Remote Control Touch Via APP eWeLink for Home Automation (EU standard) Need Neutral and Live Wire


Downloaded the App on my iphone, installed the switch, paired using my network wifi with no issues installing it. It has worked for 3 days and simply stopped. The switch operates normally if using it manually, it also connects just fine with my router as I can see it listed on my device list (see attached screenshot).


I have tried removing the device from my network list of devices to no end, I have also tried to give a fixed ip address ( on my network) as this was the original ip DHCP assigned to it.


When I open the eWeelink app, it shows the proper status of the switch (when it is ON or OFF) but when I click on the button to either turn it on or off, nothing happens and I get a popup :


"Operation Failed, please check network connectivity" But the device is online on my router device list!!! Phone is also connected to same network, but yesterday I did manage to turn on the lights remotely, this started to act up this morning!



Firmware version is 1.6.2 (Latest) 




4 people have this problem

I have the exact same problem: installed 2x devices 1d ago which worked fine during that day, associated them to Amazon echo end today they stopped working from the App and Echo (tried removing and adding again, and no luck). I can't update to latest version also

Thanks for your reply!

I do hope this is something on their end that can be easily fixed!! Im planning to travel in 10 days, bought these lights to set timers so my house is illuminated during the night while Im not  here

Can someone please look into it!!!

I got the same problem, works with Alexa okay just not through the ewelink app on iphone. Last time it took a few days to fix itself.
Is their cloud system maybe offline or giving issues right now? I just woke up to find 6 offline and not working
I have the same issue too. Is it possible to know if this is a server problem and when should be fixed? Many thanks.
Just had an ios app update, installed it but first time it ran it failed, closed it down then started working okay again.

This morning my switches have both started working as normal through the App. I guess this relates with AWS availability, as I didn't do anything.

Tried this morning.....when I try to switch either on/off, I now get the message "Device is offline, no operation allowed, please check network connectivity"


However it is online!!!!! Please can someone from Sonoff fix this??? Frustrating to say the least

@BertieSamfire I just had the iOS updated installed too, but device still shows offline :-(

as Vasco Diogo already stated, internet is out of Iteads control ...

Well this does not make much sense, if you create a product that is dependant on a certain service, you need to make sure your infra is properly setup and designed.... so things really should be under their control or thought of, I would expect them to provide at least some proper uptime, 3 days after purchase  and already a 2 day outage for me is not really good service....

1 person likes this
Hi, I can confirm. Same behavior. Checking my router the equipment is correctly connected to the network.

One hopes that this has something to do with the iOS app update released today?

I won't go more deep into this, but keep in mind ...

    - SonOff and other related products are based on an infrastructure, which is called internet
    - internet is nothing under Iteads control

When you buy a car, would you also like to blame your car manufacturer for the bad street conditions in your town ... ?

For the same reason you can argue, the car manufacturer and car seller need to make sure needed infra is properly setup and designed ...

sorry, but isn't this a bit away from life ...


Login or Signup to post a comment