Start a new topic

No wifi autoreconnection in case wifi signal lost

when the wifi signal of home lan is lost for some reason and then re-established... the sonoff cannot automatically reconnect to the wifi! the only way to reconnect is to reset the sonoff. Is it a problem with my sonoff only or is it a general problem that should be addressed by a firmware upgrade (eg enhancement the sonoff firmware with an autosearch for wifi feature in case wifi connection is lost)?

3 people have this problem

Hi, We have same problem. Some Sonoff basic (1 channel) lost wi fi connections, and only solutions is go to the site and resete Sonoff and inmediately works ok. Is there any solutions for this issue ?. Thanks.

We are recieving reports from customers of no reconnect after loss of wifi. I need an explanation to give to our customers.

I also have the same problem, all devices areff disconnect when WiFi is missing and do not reconnect when WiFi returns. Is a solution possible?
Same problem here but also if internet goes down the wifi stays up ie is exchange problem dose not log back onto server have to reset every sonoff device

They are silent, do not answer. Do not do anything about it! All of them have a problem with this! At least in Russia, everyone swears at it.

I use sonoff TH and sonoff basic in the same network. From time to time internet connection is lost but wifi intranet works fine. If I am at the same wifi network I can manage sonoff basic in "offline mode", but no way to manage TH devices. After internet connection is back again - only sonoff basic is accessible via ewelink, they automatically reconnect themselves to the cloud server. But sonoff TH never reconnects back until I switch their power off and on. I see that TH devices obtain their IP normally, even after router reboot, they get same IP, I can also see their wifi strength of signal, however none of TH devices are not even trying to reconnect to ewelink server. I think it is not included in current firmware version and I (and many other users) will appreciate if Itead team will fix it.

I've been having this issue for months now and of course, the folks at ITEAD are of no help.  Anyway, I spent the last few days experimenting and noticed something that leads me to believe that there are a bad batch of these switches.  I am referring to the T1 series of switches - which I have deployed extensively at home.  When I turn off my wifi AP and turn it back on, it seems the same few switches do not reconnect.  What I have to do is to either delete and re-pair the switch or open the front panel and force a reset.  So, there seems to be a bug but when I approached ITEAD, they of course conveniently blamed by network / router.  

I have the same problem with some of my switches. If I loose the internet connection for a long period of time, only half of my Sonoff devices will reconnect. The other half will sit doing the double LED flash indefinitely, until I turn the power off, then back on to the SonOff.

It would make sense to me that the Sonoff devices should continue looking for the wifi connection to be restored permanently, and should not stop trying to re-connect after a few minutes



1 person likes this

From another post, but probably the same issue?

This is a DHCP issue, and therefore an IP implementation issue in the Sonoff devices. This should be followed up by the manufacturer, but maybe could be worked around. After my reconfiguration, I tried several power resets and the Sonoff devices always rejoin the WiFi


My observations from today - without any network sniffing - that should be for the manufacturer to follow up on. Just a few hours of testing, so I will respond with any further observations, if any. My last problem was after a thunderstorm, so I can’t predict if I will get any issues in the future.


Symptoms: Sonoff RF relay and Sonoff RF Bridge were successfully added to eWeLink and worked OK until a power outage, then they would not reconnect to WiFi. Checking the MAC addresses of all my devices in the DHCP table of the router, the Sonoff devices were not there


Assumption (intelligent guess): During the registration process, the Sonoff devices successfully use DHCP to gain their IP addresses, but then are unsuccessful following a network disconnect (or fail to attempt DHCP). If the router is reset, devices will reconnect using DHCP and a different device will be allocated the IP address that the Sonoff was using. If the Sonoff continues to use the old IP address, it will not be able to reconnect to the server.


Tests and my solution:

- Set the address range of the DHCP server in the router to (perhaps) 10 to 100 (typically I reserve some lower addresses for important PCs and servers)

- Reboot the router to clear all tables

- Identify the MAC address and IP address of the Sonoff device. To achieve this I had to delete the device in eWeLink, then add the device again (using Compatible Pairing Mode – directly connecting using WiFi). Once correctly registered, I could see the MAC address appear in the DHCP table of the router (make a list of existing devices so that you can see the new one appear).

- Add a fixed entry to the router DHCP table for the MAC address and IP address of the Sonoff device

- Change the address range of the DHCP server to (perhaps) 20 to 100 (assuming the Sonoff device is appearing between 10 and 20)

- NOTE: one weird observation is that I had entries in the DHCP table for a MAC address of “all zero” for the same number of devices as Sonoff devices, each reserving an IP address. So I had 2 Sonoff, plus 2 “all zero”, so I would leave a gap in the DHCP table of at least 4, in case these “all zero” entries have some significance


Hope this helps someone, and add feedback if it did / did not. The only way to fix things is to add feedback

1 person likes this

I have been having this issue since I installed 3.0.0 firmware to my Sonoff T1 EU 1C switch.

If I plug off my Wi-Fi on the outlet and plug in again then T1 switch cannot reconnect to my Wi-Fi. I have to delete T1 switch from the ewelink app and pair it again. It is very frustrating.

Could you help someone how can I solve this problem?

I have the same problem with the instalation firmware 3.0.0.

the problem is not in the firmware but in the new version of eWelink. The last one is 3.5.8

Good morning, The problem is not in eWelink software, as I have two sonoff Touch US one with firmware 3.0.0 that loses the connection and crashes and the other with firmware 2.6.1 and works great. Is it possible to revert the firmware update?

As far as I know, the firmware cannot be to downgrade.


Login or Signup to post a comment