Start a new topic

Sonoff RF bridge doesn't learn remote buttons, always times out

I'm trying to get the Sonoff Bridge to learn remote codes from this remote APA3-1500R. This remote is operating at 433.92MHz


The bridge goes into learning mode, I hear a beep and the red led is flashing. However, I try many times to learn different buttons, but it always fails after one minute with a timeout error.


This way the bridge is useless to me. I'm following the instructions closely. Is there a way to fix this? Can you release a firmware update?


Thanks,

Johan


37 people have this problem

 I have the same problem.  I have tried 7 diferents remotes controls

Hmmm..... I've got the same problem. Had high hopes but have tried four different 433 remotes, and not one of them works. Cracked open the case, and the switch was in the 'on' (or learning) position. Symptom is it beeps when going into learning mode, the red light flashes away, but nothing happens so it eventually times out. Moving the switch to off means it doesn't go into learning mode at all.


Have tried sliding the switch up & down a number of times (as Andrew C did) but sadly have not had a win. Have tried different power sources (in case perhaps it was a power quality thing). The thing is a desk ornament for now.... sigh.

Seems like there is a very limited range of controls that this gadget will learn. 


I did succeed in making it learn the "keyfob" remote that came with one of my other Sonoff devices, but that's the only one that's worked so far. My RFXCom transceiver tells me that the keyfob is using "Lighting4" protocol, so I have succeeded in setting up my HomeSeer system (and therefore Alexa) able to control the Sonoff 4CH Pro relays that way. A single RF protocol does not a complete system make!


The RF Bridge would be brilliant for smaller Alexa control situations where people are using the very popular HomeEasy (Byron) RF kit.


Hopefully there will be OTA od downloadable firmware updates at some point soon, or the RF Bridge is going to be a bit of a dud, at least here in the UK. 

Same issue for me, trying to control a DIO / Chacon switch, based on the HomeEasy fixed 433 Mhz code : https://blog.domadoo.fr/guides/principe-du-protocole-homeeasy/
It's a shame, the fixed code where supposed to be learnable by this RF bridge. A firmware update would be more than welcome ! Did someone found a (cheap) alternative please ?

 

So I think that the issue here is the device is designed to learn the RF codes used on sonoff kit. If it also can learn some of your other non-sonoff remotes then great, but you need to be lucky. Maybe the firmware can be updated in the future to support a wider range of 433 devices, but for now I'll have to find a Plan B. Ah well.


1 person likes this
And who knows a plan B please ?

 

Tenho o mesmo problema dos amigos acima! Existe alguma solução atual?

Plan B  :)


Well you can add unsupported 433mhz button controllers as alarms which means you can use a scene to trigger turning on or off a number of devices.

it seems that pairing an alarm is not as conditional as adding a 1-4 button controller,  btw ive added buttons off 8x button controllers OK 

you cannot toggle however so you need to assign 2 buttons to turning on and off devices.


and each button takes up 1 whole device slot meaning you can only use 4 buttons per bridge. 

 and you cannot trigger a button press as the execution of a scene



1 person likes this
Thank you FIl, but unfortunately, I couldn't make it work even in alarm mode :-/ I'm not considering either tellstick net or broadlink RM2 PRO to control my chacon (homeeasy protocol) devices.

 

Hi Fil, upgrading the firmware seems a bit complicated for me, as some wiring needs to be done :-/ Without an official update from Itead to support homeeasy I'm afraid that this RF bridge is useless for me ( update asked here : : http://support.iteadstudio.com/support/discussions/topics/11000016521/page/last#post-11000069622 )

Since the bridge is rather cheap (a comparable device in the Netherlands from 'Klikaan Klikuit' costs 10-fold) I also tried to learn the codes. No problems in adding the device in the app, but a Silvercrest 433 MHz 4 button on/off system wouldn't learn and neither did a 2-gang 'Klikaan Klikuit'. 

Problem is that the vendors of these home systems also give very scarce info about devices, it's not just Sonoff...

I will probably use the bridge with 1 or 2 other Sonoff items such as the door switch and the PIR sensor, or I'll leave it on the shelf....

Alguém ai já conseguiu parear algum controle remoto 433 com Sonoff RF Bridge? já tentei 4 modelos e nada! Como saber se o meu veio com defeito?


I had high hopes that the bridge would work with my DSC alarm system so I could use Alexa to arm/disarm it. But the Sonoff bridge does not recognize the commands from the alarm's 433.92MHz key fob.

Unfortunately the key fob encoding scheme is not mentioned in the FCC registration, which is the only technical document I could find on it. Here are the details: https://fccid.io/F5300NB919

I also tried a few other 433MHz key fobs I had lying around; Garage door openers, remote car keys, etc. None were recognized (learning phase times out). I also checked the bridge's internal S2 slide switch and confirmed it was on. I also cycled the switch on/off many times.

So it appears that the encoding compatibility of the RF bridge is too limited. Hopefully there is a solution for this soon.

Login or Signup to post a comment