Start a new topic

Sonoff RF bridge doesn't learn remote buttons, always times out

I'm trying to get the Sonoff Bridge to learn remote codes from this remote APA3-1500R. This remote is operating at 433.92MHz

The bridge goes into learning mode, I hear a beep and the red led is flashing. However, I try many times to learn different buttons, but it always fails after one minute with a timeout error.

This way the bridge is useless to me. I'm following the instructions closely. Is there a way to fix this? Can you release a firmware update?



57 people have this problem

Johan you should see what kind of codification the remote has not just the freq

2 people like this

I have the same problem as Johan with my Rf bridge. Does anyone have any solutions for this? What should I do to get the app to learn the remotes?

3 people like this

Rf bridge not pairing

RF bridge not pairing I got pairing problem. RF bridge is on learning mode with red led blinking, then I am pressing button 1 on my remote control and nothing happen. After a minute I got message saying: "request timeout". All set-up has been done correctly with my router, communication is OK between phone and RF Bridge. I tested all possibilities by pressing remote button for long time, several times long time... but it is still not pairing. I am using other Sonoff devices and I am used to set those. But RF bridge can not pair with my remote control. This is a 4 buttons NICE FLO 4 with fixed code. Reference of the chip inside the remote control is XM19AF COPC 912 DRA NICE 001B. This will perhaps help you to confirm me if protocol is compatible with your RF bridge. I also tested with other remote controls with fixed code but still not pairing. I am frustrated as this small RF bridge was very promising. Hope you will be able to help me.

2 people like this
Same problem here. And the support was not able to help

2 people like this

 I have the same problem.  I try with 4 diferents remotes controlsm

2 people like this

I have the same problem. Link to demo video:


I cannot get device to learn code as well. Is there any solution to this problem? This product is useless without this


All problem about the device you can submit to our ticket system:

1 person likes this

The receiving supports fixed code 433 frequency, like PT2260, PT2262, PT2264, EV1527, etc.

3 people like this

Same problem - not learning RF. Have tried 2 x HomeEasy controls and the 4 button RF "key-fob"control that works with my 4CH Pro device. The bridge just won't learn any of them.

try to open the RF and move the internal switch to the Learning position

Thanks for the suggestion, Mauro. I opened the case and checked the switch - it was already at "on". I tried switching it off and on (both with and without power applied) and performed several more tests. Sadly, still no go. I've raised a ticket, so let's see what comes of that. 

Tried sliding the switch on and off a few times again today and the unit now learns the keyfob codes, so I know it's able to learn. 

Sadly, it won't seem to learn the protocol that would make it very useful, at least in the UK - Home Easy UK. 

Is there a definitive list of the protocols it will learn? I saw the support team's comment above, but that is not a full list (I hope!).

Otherwise a firmware flash, I suppose, if I can work out how to do that.

Login or Signup to post a comment