Start a new topic

Cant Register on eWelink

I'm trying to register on ewelink app but i don't receive the verification code. There's another way to get me registered?

56 people have this problem

Can't register on Ewelink. OTP not received... Tried multiple times. Email option for OTP not available. Please guide.

2 people like this
pls help i am also not getting the code

2 people like this
for registering in Asia no email option only mobile number ... tried several times says you will get verification code by sms but no code
please help not able to register


I too am not getting the verification code.

Not getting registered, logged a ticket using feedback option. Does anyone work in this company support or maybe it's sold off? Still waiting and hope I didn't waste my money
Write in feedback on eWelink app ...about your problem and your cell number they will send you code by mail


1 person likes this
Trying to register ewelink, i get the codes in email, but program says it is not valid registration code.


1 person likes this

I also cannot register to Ewelink.
First screen ask only country and phone number, then click Next and I obtain an error message 'Failed to send e-mail', but thera are no way to specify e-mail!
Apparently, entering e-mail step is missing.

Thanks for your help


Doesn't give me a option for a email just phone number to register and when I put my cell phone# in it says can't send email.can someone advise I'm in the United States, Florida.

I cant seem to get beyond my email. Have tried to send a feedback several times already.

try to register and the screen freezes. try to log in (registered an account at itead) and it says account does not exist. tried on windows, android and apple. 

i can register for long time i was tring but is impossible

downlaod the app on your phone. not the skill on alexa. register on the app and then open the alexa skill and log in with the details you have already registered/ 

Login or Signup to post a comment