Start a new topic

Sonoff touch eu wall not working

Hello, I've successfully installed the device, it does everything except turning on and off the lights neither with the physical button or the WiFi via the app. I can ear the sound of the click when I try it both physically and via the app, but the light doesn't turn on. I red the FAQS and it said that if this happens to weld the q1 relay. But I don't know where that is. I've got two of these and none of them works. Help please

2 people like this idea

I have the exact same problem,  

Can someone please help us out ? 
Any recommendation will be much appreciated 

2 people like this

 i have the same problem. have provided videos for them, since 4 units went bad... the sent replacements... now i have 4 more bad units... and they wont believe me!!!

bad customer service... bad products!

1 person likes this
Like Yara Brando & Ricardo Ramos, Same problem here with 3 channel tx models. Installed these switches all over the home they are stopping to work suddenly (no response to touch but only sounds come for long press) I have EU & UK variants, please help me out with the issue

1 person likes this

tech support doesnt do anything! i have opened a ticket since the aliexpress rep wasnt helping much.

i need a second opinion!

they think i lie... because i had 4 units going bad... then sent 4 replacements and then after 5 units went bad!

i proved with video but they rep doesnt believe me!!!

very bad customer service!


How many devices do you have in your home connected to eWelink? It is strange that so many devices would not work at once.

hello sir. thank you for the reply. are you a tech? supervisor? can you PLEASE, I BEG help me???

i have a total of 13 sir. all purchased at the same time. i was redesigning my apartment bought brand new from building company. everything brand new installed.

4 went bad. i made video. tried all the steps that i was told with rep on aliexpress. i checked the wires, turned off electric board, turned back on, tried resetting the switches, was told to remove the glass and insert thin placing in the middle to make better connection... nothing works!

i made video breaking them in half and sent images of their serials.

all was fine with the others. in the meantime, while they were being sent, on my way, it told them more went bad. made videos.

the virus crap started going on, no response from rep, i understand because many were not working.

i waited, me, my little kid and husband. still today, now we are quarantined and we have no lights on certain rooms of our apartment. very difficult :(

we called my certified electrician friend to install the replacements, spent money on this, every time he comes over there is fee of course, i have receipt.

i dont like messing with electricity nor gas, so i call him. my husband doesnt deal with any of this, he hates these smart things, so he is really pissed at me for all this. but i love smart stuff, my whole apartment has smart xiaomi motor curtains, lights, sonoff pow2 on air conditioners, xiaomi gas, fire, movement sensors, cameras... anyhow... i am just telling you a bit about me and what i have!

i made videos and more videos... showing the replacements installed and the others that went bad. so now i have 4 of the replacements so far working, 3 of the others i purchased working and now 4 more bad units.

rep thinks i lie, that i have not installed the new units and that i said the others were fine! yes i did say they were fine at first, then they went bad! the touch doesnt work, i can press and hear beep for pairing but it wont pair. the wifi light is totally dead or somethings blinks or stay solid on. the touch then doesnt respond touch to turn on an off.

or rep thinks i lie to get new models! not true! i told rep to send older versions, i dont care, i just want working units!

i can make more videos, i can show EVERY SINGLE ONE SWITCH i have!

rep wants me to send units back, but how??? we are quarantined and shipping to china is almost the same price as me just buying new ones and pay for them all! i sent screen print of shipping prices... rep says to choose small shipping company! in Brazil, you can google, shipping is owned by government, there is only Correios post office. there are shipping partners, like dhl, sedex... but they all go through Correios, which is the main shipping method!

excuse my language but i a in a screwed situation... all is against me... and i am desperate... no one is helping me or giving me other options then the one above... shipping them back.

i offered to ship back to their wharehouse here in Brazil, i know they have one, because sometimes when we buy we can choose to shipp from Brazil.

i then offered to make another video and take pictures of the serials and break again and pay half of the purchase so this way we would split loss in half...

i purchased these items and they are still all under warranty... company should give me options to help me since products are at fault!

again, i can make videos of every single one... all of them... in every single room!!!

I'm just a user, and I can't do that remotely. I would rather contact the manufacturer directly.
eWeLink This is the official eWeLink group for all eWeLink users to communicate about eWeLink app or products in eWeLink ecosystem. This is Telegram App
Check out the Telegram Application and eWelink Group. There, maybe someone will advise you more.

hi robert. sorry for the delay. thanks for the link. i am already there.

i have been trying tech support here, my ticket is opened. but no response.

the rep asnwering me on aliexpress, is not helping me at all, as i wrote above, he wants me to send the units back... there is no way

he doesnt want to give me another option...

all items still under warranty

he thinks i am lying...


Hello. Yes, I can see you there.

I have bought 19 switches for my home renovation. All were working fine with sonoff app. After 2 months, 9 of them failed in sequence. There is light around the switches, but they aren't responding to touch. Only the pairing beep on long press, but doesnt giveout own wifi to come into pairing mode. 

Sonoff CC sent me an excel sheet asking me to fill all the Model No., S/N, Order details, etc with videos. I did. But they give only give standard answers, like, try AP mode or update the firmware. They are so dumb that even after seeing my videos where am not able to pair, they are asking me to update the firmware from the app.


I finally, flashed my sonoffs with Tasmota firmware and I was surprised to see all my switches started working (including 6 old switches which were having same issue and lying aside since 2 years). You can get youtube videos of how to do it. Am a novice, but managed to do it. It appears complicated, but if you spare some time, you can do it too. You needn't even disconnect the power cables, just turn off your individual rooms power, pop out the superficial PCB from the switch, flash it, place it back.  Its far better than sending them back to Sonoff and waiting for getting them fixed. One glitch is, the flashed switches can't be accessed from sonoff app, but can be used normally with Alexa (right away) and with Google Home(with some tweaks).

I'll be glad if anyone needs any help about flashing.

All my 25 switches are working fine now.
Good luck.

Login or Signup to post a comment