Start a new topic

RF pairing to remote

I have my device connected and working but can not get it to link to any RF remote. I double tap the little switch as directed in the instructions but the led does not flash red. Any help appreciated.

10 people have this problem


Any update on this problem, i can get the red light to flash once, you have to watch carefully to see it, but it does not learn the code of any remote.

The above video does not work either??


1 person likes this

Have problem with pairing RF remote. When I touch the Sonoff T1 there is no beep sound. Seems like the T1 is not going into pairing mode. Any suggestions?

1 person likes this

I believe we know all the procedure now.

Receivers do not work.

I tried with 5 different remote controls but nothing.

And iteadstudio continues to not respond.

It does not seem to me to behave correctly.

1 person likes this


I found the solution in this video: SONOFF RF SWITCH INSTALLATION, WIFI, 433MHz Remote, Alexa Voice Control Setup

But the steps are easy (once you know):

  1. Press the Sonoff button 10 seconds (until it starts blinking).
  2. Press the Sonoff button twice quickly.
  3. Press remote RF button and hold until a red/green blink is seen.
  4. The Sonoff will return to working state (repeat for additional remotes).

You can erase all configured RF remotes by pressing the Sonoff button three times (after the long 10 seconds press).

You can exit from pairing state pressing once.

Note: Make sure the remote is 433 mhz (It can happen).

same problem.  Order # 100115356


Same problem, no solution :(

I've been told by developers that normal pairing should work or I can open the shell and press the 433MHz module for more than 2s to enter pairing mode. If this doesn't work it's a faulty device. Neither worker for mine so I got a refund. I'm now using the new Alexa skill so no need for the RF.
I buy 7 unit and i was To buy more like 50 to 75 unit but the 7 unit not working with 433 mhz Press fast 3 time and it work érase press 2 time flash 1send signal nothing. ONe or 2 time record signal flash 3 or 4 time work on off 2 to 5 time and AFTER nothing TO BAD
I've opened the device and can confirm the RF module is present. There is a switch on the RF module, anyone know what this does?

I have the same problems with 2 sonoff RF, Its nor pair at all,  with the original remote that sale in Itead

Sonoff 4CH Pro not registering 433.92 MHz remote(s) 

Reading through all the other comments here, there are many with the same problem of their 4CH Pro not registering when following instructions to learn remote codes.  My 4CH Pro also doesn't register codes from any 433.92 MHz remotes I use.   My Pro didn't come with a remote controller and there is a learning mode so I expect that the intent was for the Pro to learn any 433.92 remote.  This feature apparently doesn't work, however we have paid for that feature to work.   There also no feedback from ITEAD about how to get it to work.  I have tried all instructions from other who have tried to get theirs to work. 

There is an undocumented trigger that activates learning mode when pressing a button for 10 sec not fast pressing twice.  But after it falls into (what ever mode is causing the LED to flash) and then pressing twice fast while holding the remote button, - it still does not work. There are no green lights or red lights indicating success. 

 I've bought several Sonoff RF units. All devices are connect to WiFi and working fine via eWeLink app, but just SOME of then I succeed to add a RF remote.   


       I have tried to pair with 433MHz remote using instructions provided -  ie. press button twice rapidly to place in pairing mode -  and the red LED goes ON but no pairing success. I also tried pressing button on RF board for 2 sec but still no result.  Relevant info:  SOME of the units I could update the firmware version from 1.6.0 to 1.8.1 and SOME other I could' t do it - However, all devices (1.6.0 and 1.8.1 versions) are showing the message "latest version" on eWeLink software.

   Someone could help with this?  Thanks.

 Hi, I have the same problem.

I bought Sonoff 4CH Pro and connected it to wifi properly.

I then bought a remote control 433 mhz and it has no codes stored in the 4 channels. I can not connect this remote to the receiver

I also have another remote control (same as the first one) that has two stored codes of two home automated gates. These channels (with stored code) I can associate them with the Sonoff 4ch pro without any problems. The remote control works and I can turn off the two connected channels

In my opinion the problem is this:
if the remote control is new and does not have associated codes does not send them and therefore the receiver on the Sonoff receives nothing and does not program corretly.

Does anyone know how to generate random codes to associate them with the remote control and then send them to the Sonoff?

Now if you press the button on the active remote the channel Sonoff (kitchen light), but also opens the gate of the house !!!!!!

Thank you all

Login or Signup to post a comment