Start a new topic

sonoff does not powering up

hey, I need some help.

the device worked for about a week .

the its shut off and not powering up any more. my sonoff device not powering up . in program mode using FDTI usb connection i can make a connection to the Arduino IDE and even to the EWeLink app, and the relay works Ok when i press on/off. only when i connecting the High Volt input there is no responsed. any suggestion how can i find the problem. thanks in advance.


original firmware still installed. didn't change anything.

9 people have this problem

Maybe it can be do a faulty capacitor? I think one of them a bit puffy .

Hey Asaf. I have the same issue on 2 of my devices. Sonoff Basic and Sonoff TH. My capacitors seems to be fine though. Did you ever find a solution to your problem?

Hello I am also having this problem. Any suggestions
When I power up my sonoff basic the first time it does on but only for about 2minutes then suddenly the led stop blinking at all. Then I unplug and replug to power source it didnt on anymore. After I left for a rest about 5-10mins then plug the source in again suddenly led blink again but only for a while then it dead again. What should I do? Its a brand new sonoff basic that i just bought
(2.32 MB)
(2.28 MB)
(1.97 MB)
(2.35 MB)
(2.3 MB)

1 person likes this
Same problem here on an S20. Worked for two weeks now no leds at all and switch does nothing.

I wish ITEAD can give us some guidance of how to test the module. I believe its the power supply circuit got problem.

I've had a similar issue where my 4ch pro goes on, relays return to the previous state and after a few seconds everything dies, opened up the device and could smell some burnt electronics, nothing looks out of the ordinary but device does not work on AC or DC. disconnected the yellow wire of T1 and device now works on DC. Not sure what could be wrong on the AC side, suspect something is pulling the supply down...

From the schematic, surely the circuit on the right hand side should be fine since this is also used when powering from DC, my understanding is this is where 5V is stepped down to 3.3V\

I assume the pads are where the transformer is connected, but being a transformer there should be no connection to the other side of the trf, unless D3 is busted causing an overload when the DC is applied... don't know... TRF in circuit no voltage is measured on 5V or 3.3V when powered from DC, yellow wire disconnected all OK


@Chaun Bosyen from the circuit diagram you shared, and you mentioned "unless D3 is busted" what component is "D3"?

its a diode

I tried to direct inject / source 5vdc to pin 3 and gnd of U3, the result my sonoff basic is on and working. I assumed the power supply part is must be damaged bu im not sure of which part or component is broken. how to check? 

1 person likes this

my sonoff is back to work normally after i injected 5 volt and 3.3 volt

Has anyone else been able to fix it? My Sonoff S20 died after 1 week. Everything (wifi, relay) works but there is no power coming out. 

Same issue here.

Is there any solution?

That a shame! So many problems for a new device!

Login or Signup to post a comment