Start a new topic

Sonoff keeps dropping Wifi connection after 1.5.4 -> 1.5.5 firmware update

hi people of the earth :-)
I have 3 sonoffs operating for 6 months or so and have lately updated all three from firmware 1.5.4 to 1.5.5. They have worked without any hickups until now (well, almost..) After updating to 1.5.5 all my 3 sonoffs' started repeatedly dropping the wifi connection every minute or so, until they eventually are not able  to connect anymore.

Then i need to power them off, "cold boot" - then they behave ok for a while but eventually, after about an hour, starts dropping the wifi again, more and more frequently until it eventually is not able to connect to the router at all.

My wifi router is a Draytek 2820Vn, ive tested with or without firewall, qos, DOS detection,  Bandwith managements etc etc, the router has the latest firmware installed. ... but - still no go".

I've logged the problem with the routers syslog software, the reported insidents

"WLAN_DBG - MLME Disassoc" means that the SONOFF takes the initiative to the disconnects. Disconnects triggered by the router would've given a different log message.

extract from router log:

1502017-04-16 12:24:38Apr 16 12:24:11SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:25:38Apr 16 12:25:11SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:25:38Apr 16 12:25:11SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:25:38Apr 16 12:25:11SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:26:59Apr 16 12:26:32SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:26:59Apr 16 12:26:32SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:28:02Apr 16 12:27:35SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:29:02Apr 16 12:28:35SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:29:02Apr 16 12:28:35SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:29:02Apr 16 12:28:35SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:29:51Apr 16 12:29:24SHWLAN_DBG - MLME Disassoc MAC d4:85:64:34:e0:a7
1502017-04-16 12:29:51Apr 16 12:29:24SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:30:21Apr 16 12:29:54SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:30:21Apr 16 12:29:54SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:31:24Apr 16 12:30:57SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:32:24Apr 16 12:31:57SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:32:24Apr 16 12:31:57SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:32:24Apr 16 12:31:57SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:33:44Apr 16 12:33:17SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:33:44Apr 16 12:33:17SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:34:47Apr 16 12:34:20SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:35:47Apr 16 12:35:20SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:35:47Apr 16 12:35:20SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:35:47Apr 16 12:35:20SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:36:47Apr 16 12:36:19SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:36:47Apr 16 12:36:19SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:36:47Apr 16 12:36:19SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6
1502017-04-16 12:38:34Apr 16 12:38:06SHWLAN_DBG - MLME Disassoc MAC 60:01:94:07:ea:a6
1502017-04-16 12:38:34Apr 16 12:38:06SHWLAN_DBG - Dot1x_session_stop
1502017-04-16 12:39:36Apr 16 12:39:08SHWLAN_DBG - MLME Associate MAC 60:01:94:07:ea:a6

they did NOT behave like this when running fw 1.5.4.
I have, hand on hearth, changed nothing else on my netwrok, only the sonoff firmware..
therefore, to my understanding it must be a mproblem with the latest wifi related changes is in firmware 1.5.5.  anyone else wiht the same issue? .. itead..? .. any ideas?
thanks in advance. SH / Barcelona

NB. Moderator, if youre awake:-)
aplologies for first posting in the wrong (nextion) forum, could you please remove this post

2 people have this question

hi again, im continuing my monolog: after a lot of trial and error, it seems the sonoff fw 1.5.5 has developed a sensitivity to the setting of Short Guard Interval SGI. SGI ON = behaving better, SGI OFF = ... wifi trouble itead: is this something you are aware of? please advice. i remeber reading "wifi performance" was one of the issues adressed in firmware update 1.5.5 well, somrhing is not quite right. and for the record. ive had theae sonoffs working beautifuøly for months without problems. the havoc startes when upgrading from 1.5.4 to 1.5.5 ive tried with other routers to check if my draytek is faulty, but same result regardless of router brand. ive tried any combination of mixed mode b/g/n, green field, channel width, ... any comments wouls be apprwchiated, and i cant Believe im the only one experiencing diffi ulties with firmware 1.5.5 !?

i understand I'm the only one experiencing this issue, which i find extremely odd,  so i believe i wont get any further with this. 
my conclusive comment, if any, if anyone bump into a similar problem: The sonoffs with firmware 1.5.5 fell out of love with my draytek (2820Vn with latest fw 3.8.0) after updating the sonoff from 1.5.4.

i've tried _all_ imagnable combinations of wifi settings on the draytek to no avail. After being let down by the draytek i moved over to a ZTE router provided by the phone company, .. and im sorry to say that it works - but _only_ with SGI is enabled. _without_ SGI (short guard interval) enabled the sonoffs behvaes just the same connected to the ZTE router as with the draytek. I tried enabling sgi on the draytek but it had no effect.

So, all in all, itead may''ve attempted to optimize wifi perfornance with the sonoff firmware 1.5.5 , as stated in the change log, .. but.. to my experience, .. nothng but trouble... Itead, i'd reverse the 1.5.5 code changes that has to do with wifi functionality back to as it was in version 1.5.4 .. 

Itead, all in all, it has been a waste of time using your forum. 
You could've easily dropped a short "we Are aware of the problem and will fix it in release 1.5.6" or "we are Not aware of this problem and good luck to you"

regards from barcelona

I'm having a similar experience with S20. Now I've tried enabling SGI after reading your post.

Ping! nice to hear your voice. keep me posted? i still havent resolved this. I'm now experiencing the same behaviour with a Sonoff TH16 with the latest firmware, still on the bog standard router ZTE ZXHN H108N V2.3 ... the difference is, with the sgi enabled they are more online than -off...... but still annoying.
Im afraid i dont have more useful input - I'm about to solder headers on to flash them with 3rd party firmware...


I've waited since my last posting and the widget didn't work after 3 hours... :


It used to give this "Network unavailable" warning before I switched SGI from "default" to "enabled":


but this time it didn't give that warning. I opened the app and used the switch and only then the widget in the first picture started to work again. Feels like it's going to deep sleep and having hard time waking up. I too might try third party stuff since this "device offline" thing gets annoying and fails the whole point of "instant" control. Having to open the app each and every time isn't ideal.

BTW I'm using S20 to power on and off my secondary monitor since it emits a high frequency noise when I attempt to shut it down from the button on it's panel so whenever I need to use S20's switch I'm in front of my computer. I'm quite new to this stuff. I've received my S20 from Aliexpress a few days ago. Do you know a software which I can control my S20 from my windows pc? I thought about installing the EWeLink android app into Remix OS Player but it felt stupid to run a whole emulation for just a button switch. I thought connecting S20 to Alexa and using the web interface but I don't want to use voice commands either.

hi mate, it def. sounds like you're having the same issue as myslf. and yes, i think you are absolutely right, that the sonoffs after the latest fw update go to deep sleep in such a way that they somehow need to renegotiate the wifi connection "from scratch" every time, .. i think this also leads to exhausting the router as eventually my other devices will have trouble connecting to wifi.(this happens only when the sonoffs are 'live) I then need to restart the router every once or twice a week.
the draytek didnt suffer as it is set to reboot every night, but its noticable with my crap ZTE "alternative/testing router".
i think itead implemented som strict (and maybe-not-so-standard) energy saving policy that may not work with all (older?) routers. my draytek 2820vn is 8-9 years old, and i believe the broadband providers ZTE router I'm using for "double-testing" isnt state of the art either. .. so i dont know really, my sonoffs now works exactly like yours, they are online, or they are offline, after a few minutes they are back online again.. then offline again etc .. not exactly dependently available for instantly switching stuff on/off.... annoying indeed.
"my plan", if any, is to wait it out for the next firmware update to see if they resolve the mess they made, and if not - to flash an alternative firmware. I rather Not start mocking about with soldering and MQTT servers to make this a full blown DIY home automation project, but .. "if I must" .. I'm with you on this one, to install an android emulator, on a PC, to control a switch seems really dumb.... So I refuse to do that too. Also, if you login with ewelink from two different devices, the first device will log you out on the second device, so you will have to constantly retype your username AND password to  log back in... so .. what can i say... its a great device.. but the latest firmware is .. questionable.. and the ewelink software could be far better. .. and, its a shame we cant send commands to it over standard http(s), the sonoffs really lack a Web API or similar - . 
my experience with this sort of stuff is that the problem may be gone just as quickly as it arrived, so wait it out for the next fw update before you give it up, or away, or like me, tear it apart for alternative use.

in re to the like... I like to share as little information as possible with these global information companies. so my voice profile they're not ganna get, and i wont tell facebook when i go to bed by letting them know when i switch my tv off in the evening. In fact, as far as im concerned, eWelink is really pushing it for me, .. i'd much rather control it myself locally... so .. hmm it really sounds like its gonna be soldering and mqtt. i wish i had more Time ............ :-)


just out of curiosity. would you try plugging your s20 near your router, in the same room, say within a meter or two, to see if that helps. The new firmware may turn down wifi power to skimp on idle watts, .. maybe they tweaked it a wee too hard .. maybe it works in a lab but not in all domestic environments, maybe there is more than usual wifi and other 2.4ghz interferrence around where you and I live. ..?
I will try today to see if it helps. I've done this test several times already, but, 1. the sonoffs work better for a few hours after they been powered off/on, so in retrosepct, I'm not sure if i allowed enough time and 2. i dont remember if i tried this after I swapped router (and enabled SGI) as It logically was one of the first tests i did. so here we go again. i'll post the outcome. :-] ..

i could've measured idle wattage with a multimeter but since I didnt also measure before the fw update I won't know if the updated firmware draws less mA'mps.. so.. that wont help indicating..

 haha you really got me going again. so would like to add, keep an eye out for
if it blinks once, repeatedly, then it cant connect to WIFI.

if it blinks twice, repeatedly, then it cant connect to the server.
steady green means everything is aOK.

the problem im describing throughout is when it blinks Once, repeatedly. ie - wifi problems.
i've also seen the "double blink" on many occations, but thats down to other issues, like the broadband providers DNS server was acting up, .. or .. the chinese may've been messing with national infostructure. or god knows what. Itead says the server is Amazon AWS backed, .. problem is, its probably located in China .. .. i dont know, im Not saying it's crap because its Chinese, im just saying that Distance and Culture may cause the extra odd interruption...

(another reason why to flash 3rd party firmware im afraid........)

update: the sonoff I just now moved next to the router for testing, was online for about 30 minutes before it dropped connection - coming up light grey in eWelink. it was gone for a little while and came back online again. An other sonoffs I got going (th16) did not lose connection, was online all along, so its not related to the eWelink app 'side of things. So, i dont think its down to interference or skimping on wifi idle power. Mysery remains.......

In it's usual operation my S20 is around 4 meters away from my relatively new Castlenet CBW383G4S/CBW3843G4S I tried it in a wall socket that's around 1 meter away and encountered with the same problem.

the widget is unresponsive, then I open the app and it's like the "network unavailable":


Then when i try to operate it from within the app It says "Control by LAN":


and it operates just fine. When i close and reopen the app, voila! No warnings! :


Did the network problem get fixed just because I restarted the app, or were there a network problem to begin with even? I don't know. While these things happening there's no blinking on the device's led. It's either in closed (just steady green) or open (steady green-blue) state. I agree on waiting the new firmware version. Yes it's a shame Sonoffs lack an API.

How's the problem going?
My Castlenet CBW383G4S/CBW3843G4S got 2 channels of 2.4 GHz and 5 GHz. I've realised that when sonoff and my phone are on the shame 2.4 GHz channel I don't encounter the network unavailable problem. But whenever I switch my phone's connection to the 5 GHz channel that's when the problem starts, so I guess I kinda solved my problem by keeping my phone in 2.4 GHz channel too. It's still annoying and you shouldn't need to keep them in the same channel for sonoff to function properly but it's a workaround until they hopefully fix it with the new firmware.

Are your phone and sonoffs in the same 2.4 GHz channel too?

Hi Aykut, I tried to reply to you but it was stopped by a moderator. god knows why. maybe it was to long and unconclusive. as if that would be a reason good enough not to let my post through. I'm giving up on Sonoff firmware and forum and will load a third party fw. Hope you work something out too. tada' all the best from Barcelona. STIAN

Aykut :-) if you're still there. its still early days but I think i nailed it. .. I swapped to OpenDNS free dns service a couple of days ago - and voilla - the sonoffs are all happy/stable (Opendns free service and ... I've used googles up until now as my ISP's dns always been sluggish, if working at all (so using googles and probably wont help for some strange reason)  .. i've made the change on my router, not per device - so its LAN wide, i suggest anyone having a similar problem doing the same. tada from barcelona. STIAN


I compared performances of opendns, google dns and my ISP's, my ISP's was slightly faster so I ended up not changing my DNS in router level.
Actually my problem got fixed itself somehow, for some reason. I ended up using the physical button anyways since It's right near of me and it's more practical/faster using physical button for me but I haven't had problems using app widget aso (tried now, worked)

Now I'm annoyed that the onboard leds are always on. It's annoying and unnecessary. It should switch to a power saving mode and switch off the leds in my opinion. At least that should be an option.

Login or Signup to post a comment