Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 


63 people have this problem

I would love to know if there is a fix for this problem. I have the exact problem, it seems once the device has been paired to an access point it refuses to be paired to a new access point. When I tried pairing it back to the original router it works first time! It would be great if there was a factory reset option. Any help with this issue would be greatly appreciated. Regards, Jon.

4 people like this

I have connection to device problem after pairing also. I think its time that Itead give us a working solution or simply tell us the that switches with this problem are now scrap!


3 people like this

I've logged a Feature Request to introduce a 'Factory Reset' process:


(https://support.itead.cc/support/discussions/topics/new?forum_id=1000228728)


If everyone votes for it, it may get some traction and then get fixed.


2 people like this
Steve, trust me. Everything you've suggested I've tried. It just doesn't work whether they've been used with Alexa or not.

1 person likes this
I have the same issue, I have nearly 20 Sonoff devices and after changing my WiFi network setup have had a lot of trouble getting my devices to reconnect. I am now down to the last 3 devices, all of these are the 4 ch New Smart / G4 devices. I have 4 of these, and 1 of them connected without issue. On the last 3 I have tried everything suggested above and more. I can connect them to my old WiFi first go every time, I delete them from the app while working, but no matter what I try they won’t connect to my new WiFi network. I have now ordered new ones to replace them, even though they are fully serviceable when used with my old network, the time I have wasted far out weighs the cost.

1 person likes this

Pradip Shah

I have no problem with the internet connection in the house, the problem was how many items could be connect to the router at a time. Most normal ac1200 type routers can only connect about a dozen devices at a time. My android tablets would connect, but they are a bit slow to change networks when they lose a network. The switches don't seem to tell them to revert back to the main network once the settings have been updated. So the tablets (my ones at least) didn't immediately notice that the local network the switch had been broadcasting was gone. 

Much like a laptop, if you watch the network indicator on your laptop and turn your router off, it could be over a min before the network indicator shows the network missing. Phones seem to notice that quicker, probably because they are mobile and more used to changing networks.

I've also had the switches take 10 mins to work after they have been programmed. Normally they get programmed and work fine in a few seconds whilst you have the app open. But i have had occasions when they don't seem to connect, only to suddenly start working 10 mins later.  


1 person likes this
Steve Christie: Firstly huge thanks to you mate, if I didn't read your posts I think I would not be able to resolve this issue. I hail from Australia and use Optus for my internet, I have been using the sagemcom router provided but noticed coverage issues around my home so decided to get Netgear d7000v2 router and I have setup the new Netgear router with similar ssid and passwords I had before on the old router thinking and also being lazy so I don't have to re-repair my Sonoff switch. Issue : All other devices got connected except the 5x Sonoff smart switches Solution: after trying everything I came across Steve's post and I have followed his advice. What I have done : 1. I reconnected my old router and through my ewelink app I deleted all my Sonoff switches while connected to network with old router. 2. I then reconnected my new router ,then on my smartphone with android 10, I selected forget network option to all other networks except my 2.4ghz network and also switch off mobile data reason being when pairing the switch if multiple networks are available the ewelink app will get confused will come up with timeout error. Once you follow the above steps it really doesn't matter what brand router it is all you need is 2.4ghz network and it will work. Again all this credit goes to Steve Christie for his valuable information and persistent advice. Thanks

1 person likes this

I have tried everything you guys have tried and found the solution that worked for me. From what i saw on the wireless network when you added a new device through the app, ITEAD-***** would appear on the network as connecting which means the device was communicting during pairing. What happened to me was during that time the device was registering, i noticed that my network would auto reconnect like it was supposed too. but what was really happening was the registration process was not completed.So as many of you out there ,device said it was offline and i would try over and over deleting device and starting over.What you have to do is when you see the device network connecting , keep your network from auto connecting by tapping on the device network and keep it online just for a brief ammount of time.When you see your device turn full green ,you know its connected now and is a good time to update the firmware. I am not a very tech savy person but hope this will help out.


1 person likes this
i have the same trouble with several devices... indeed one of them (sonoff 4ch) it worked well, (testing), but when i place into final position (diferent wifi router)... it doesnt work, i can succesful pair, but after it... green light keeps blinking

 


1 person likes this
Exact same problem as Abel shows in his YouTube clip, unbelievably frustrating! Any gurus found a fix?

1 person likes this

I have exactly the same issue. I saw on YouTube a video from a guy, who shows nicely what the problem looks like: pairing problem.


1 person likes this
I finally managed to get mine working... I decided to have one last attempt at trying to pair it. I first tried connecting it to another access point (which didn't work) and then reconnected it to the original AP which worked! I have no idea why I'm afraid as I had tried numerous different access points in the past with no luck. It had been powered down for a fews day prior to me trying again so maybe that helped? It might be worth leaving them powered down for a few days and then trying again... if all else fails I'm liking Ian's idea!

1 person likes this

Still no reply from support on this issue. Anybody there?


1 person likes this

Tengo el mismo problema, el video explica claramente el error : 

I have the same problem, the video clearly explains the anomaly

https://www.youtube.com/watch?v=w_NHpFR_KqE


1 person likes this
I have the same problem. Pair but not connect to router. Try and another router, nothing. Try and another phone, nothing. Try to delete and add again, nothing. Try to let it off for a day, nothing.....

1 person likes this
Login or Signup to post a comment