Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

74 people have this problem

i see. on my app all i can do is delete probly the same?

duuuuuuuuuuude your a genious. thank you so much 

Could be, it used to be forget on the old app.

But you have to be connected to it so that you can switch it on and off before you delete it. Just deleting it from the app wont reprogram the switch if it's not connected at the time. 

henry kidman

Your welcome

It took me a while to figure it our. 

Glad it's worked out. 

Guys I extensively tested the sonoff and the issues are most certainly related to IP allocation and ARP tables. Collect the MAC address of your sonoff (specially if you have more than one) then register the MAC in your DHCP allocation list on your router and assign an IP, then connect your sonoff to the router and it will work... I tested it on several router and AP. It is not perfect you still get disconnections from time to time and update failures, but at least you can manage to use them. I hope this helps...
If you turn of your cellular connection to the internet. It will work. At least that's what happened with my pairing.

Hidde Moens

Well if you get it to work like that, delete it in the app whilst your phone is connected to it and you should be able to then re connect it via the internet. You have to delete it in the app whilst you are connected to it to clear the old settings in the itead. 

Hey Raffaele!,

How do you find the MAC address for them? When I go into the App, all that I can find is the Device ID (for the one's which I need to fix that is). The working one's show the MAC address, but they work, so that's useless.

I've logged a ticket with Itead to delete any logged history for the Device ID's (hopefully that works)

I've logged a Feature Request to introduce a 'Factory Reset' process:


If everyone votes for it, it may get some traction and then get fixed.

2 people like this
Easiest way is to connect your son off to the mobile phone via tethering, even better if you configure your mobile with the same SSID, password and encryption as your current WiFi, so you don't need to reconfigure afterwards, then go through the procedure to put the sonoff online, on your mobile (and in the app) once connected you will get the MAC. setup the reservation on your router, turn off your tethering on the mobile and give a restart to your sonoff which should automatically connect to your router.

Tristan Waller

A lack of ability to reset the things is the whole crux of the problem. All my posts above are about a way round that worked. I had about a dozen dead switches after changing my router without deleting the switches in the app first. The solution i have set out above got them all working again. No maybe's or should do's they just work. 

Having the same problem. Tried all the solutions above. No luck. Please Itead we need a solution for this issue.
Ok here is solution for this problem : 1. Create on phone no 1 hotspot with tethering. 2. Use phone no 2 to pair with sonoff basic via ewelink and new hotspot wifi . 3. Press button on sonoff for 5 sec (led inks 3 times and wait), than press button again for 7 sec until led flash continously. 4. Pair device 5. After successful pairing go to device settings to update firmware. 6. After update completed, switch hotspot off, remove device from ewelink and pair it again with normal wifi 7. Job Done!
I had a similar problem. It would never connect to my WIFI. But eventually got it working. I’m not sure, but I think it was related to my setup having a double NAT. To fix the problem, I put the device in AP mode, connected and set it up to use a wireless network that did not have double nat, in my case my LTE dongle. Connected seamlessly. Made sure my phone was connected to same network. App then determined device needed firmware update. Performed firmware update. After that I deleted device from app, re-paired but this time I used my normal household WiFi, and it connected fine.

I have two sonoff basic2 devices. I was having problems to connect to wifi with quick paring, can conect it to ewelink app with Compatibile Paring Mode(AP) but device stay offline... I have try everithing suggested on forum but with no luck...


1) I use second phone (iPhone SE) to create WIFI Hotspot and connect my Android phone to that WIFI than I pair sonoff device with ewelink app successfully (to Hotspot WIFI)

2) Then i try ON/OFF sonoff switch and when i was sure that it work I UPDATE Firmware (go to device; than to ... in top right corner; then to settings; then update firmware )

3) When  Firmware succesfully update delete device from ewlink app

4) tourn off WIFI Hotspot

5) connect to your home WIFI with main phone (android in my case)

6) Quick pair sonoff device normaly :D

Login or Signup to post a comment