Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

74 people have this problem

I had the same problem.

I changed router and could not reconnect six sonoff switches.

The solution for me was by trial and error, here’s what I found out and how I sorted it.

Switches connected to a network have to be deleted from that network before they can be connected to a new one. It is no good just deleting them from the app, they have to be connected to the app when deleted. If not they are constantly trying to reconnect when they are repowered and will not recognise a new router trying to connect them. They have to be told to forget the old network.

Let me give you a quick rundown of how these things connect.

You have your phone with ewelink connected to your wifi. When you try to pair, the phone with ewelink disconnects from your wifi and goes off looking for a new switch, it then connects to that switch directly over the switches own wifi link, not the one you were on, and you will see device found and registering in the app. It then reconnects the phone with ewelink back to your wifi. The switch should then follow and connect as well.

The problem is that if the switch has not previously been deleted, it will try to connect to the network it was previously on that no longer exists, not the one you are on. And it will show on your phone as offline. But the app will show it as a new device because they talked to each other directly, not via your wifi network. (Watch the wifi symbol on your phone when you do it, it will go on and off three times) The switch has never connected to your wifi network, it has only talked to the phone with the app on direct.

Trying to delete the switches old network cannot be done by trying to over right it with a new one. The old network has to be deleted via the app first, whilst connected to it. The switch has to be network free before it can be connected.

The other problem is that the new app hates 5G, even though the switches only use 2.4G.

My solution was as follows.

1, deactivate the 5G wifi transmittion on your router.

2, enable the guest network with a password and  WPA-PSK [TKIP]  security, yes I know TKIP is not as good but it is only temporary.

3, go to your phones wifi settings and forget all the networks in range, especially any 5G ones and the normal 2.4G ones that you have been using. (This is to stop your phone reconnecting to them with a saved password halfway through the pairing process, because your phone will prefer them over a guest network)

4, connect to the guest network and tick save the password.

5, open the ewelink app and hit the + button.

6, on the switch, press the pair button for 7 seconds twice to get it to flash at a constant fast rate, Blink blink bink, not blink blink bliiiiiink.

7, pair using the normal quick pair mode. If this doesn’t work do it again with AP mode, but the switch needs to be flashing fast for both types.

8, if all is well you should have a connected online switch. Give it a test.

9, If it’s working you need to delete it from the app to get it to connect with your normal 2.4G network. So it’s best to get all your switches working on the guest network first and test them.

10, Delete all the switches from the app whilst they are connected, and you should see the steady light on the switches start to flash.

11, Now go to your router and disable the guest network, and reconnect your phone to the normal network and tick save the password. This should be the only network in range with a saved password.

12, now re pair all your switches again to the app on your normal network. If it won’t connect to them temporarily set the security on your normal network to TKIP. Once they have paired you can return your security to how you normally have it and re enable your 5G network as well.  

I have written this whilst I have been doing it myself, it does work. It may also help if you check and update the switches firmware whilst they are connected to your guest network, as the latest app version is a bit finicky about that as well.  

All of my switches are in my barn, and I have managed to get them working on a Netgear router connected to my barn by three Netgear wifi extenders in a line. So my phone in the house is connected to network name Netgear, and my switches are connected to network Netgear EXT<EXT<EXT. and they all work with Alexa as well. So I know this solution works.

Hope it help you.    

I forgot to add it to my post above or below. But a copy of the old app can be found here.

This is the one with the bar progress indicator instead of the numerical timer. It works better with old software switches and lets you update them for better connection to the new app.

They call it a fix tool but it's just the old app.   

I have a ASUS RT-AC88U  The solution was pretty simple:

Never use  same password in 5GHZ and 2.4GHZ band 

use different passwords for the two bands

I don't understand this behavior, but for me this solution was very well

after change this i try connect devices with success, I has using the same encryption type for both bands




I hope that ITEAD  fix this problem in the next firmware update if its is possible.

thank you

I was having same problem with my Sonoff basic switch. First I checked my router the sonoff switch was visible there under connect users but the green light was blinking continuously on switch. Then in ewelink app I turned on the enabled the LAN mode and tried to turn on the light, it worked. I disabled the LAN mode and suddenly the green light on switch became stable. Now the switch was working normally.


1) Set your Wifi to WPA ... Not WPA2..

2) Remove all PUNCTUATION from your password!

After much trial and error I got the Sunoff basic working only after doing BOTH of the above changes.. Stinks!

Hi all,

today I configured, not without problems, my first SONOFF Basic.

I had a lot of problems with the WIFI connection and I noted that the SONOFF can use the 2.4 WIFI only if the password don't have special characters like ! _ and so on. You have to configure the WIF password just with numbers or letters.

How is it possible today a similar security weakness?

I think this behavior could be easy to correct by a firmware update...


@Antonio What kind of router are you using. I had issues with netgear Orbi due to the mesh style that only use the 5. I had to use an old phone to push in on 2.4..

I have still the same problem.....2019-03-15

I've spent two days on this, as I have my whole house installed with these devices...

(Was forced to change my Router due to installation of NBN - Australia)

 Highly frustrating...

What I can report thus far (for me), is:

1/ It is not a WPA Security setting issue (set it to no security, and still had the same problem);

2/ It is not a 5.0GHz issue (turned off 5.0GHz for all );

3/ It is not an Ewelink App issue (deleted and reloaded on old 'fix' version)

4/ It is not a SSID/password issue (all lower case, no special characters)

This leads me to believe it must be something to do with assigned IP's.


 I have the same router with the same settings you provided and I can't connect.

Could you please provide a screenshot of all settings (general and professional tabs, of course without pass :)


My findings are little bit more strange

I have house on three levels where I have separate router for each level. At each level I have several sonoff th10 devices. The router on first floor started to make some issues and I needed to replaced as it was very old device and now I can't connect this sonoff that was connected to it. Again the same issue like all others above, but the strangeiest thing is that I can't connect it also to routers located on second and third floor where all other sonoff devices are working. So at the first floor I have new modern router where I tried every possible solution like stoping 5ghz, changing 2,4Ghz parameters, changing pass and even configure ssid without authentication. Nothing is helping - this particular device pairs but not connects to any of my old routers  (where nothing changed in config and all other devices are connected) or new router. When I power up the old router it immediately connects to it. I also deleted app and setup it from scratch with the same user so no cached settings it.

This leads me to the point where I believe I need somehow to reset the device - I found in internet that holding button for 20 sec will factory reset it and did it but I don't believe something happens. 

Do you know how I can do factory reset ?

Thanks in advance!

ok so im having the same problem only when i change from wpa2-psk to open then it connects. but after re-enabling that it disconnects

any ideas?

henry kidman

When you get it connected without security, forget it in the app whilst you are connected to it and then re=enable your security and search for it again.

You can't "Reprogram" the itead to new network settings without forgetting the old ones first. 

Most peoples problems have been because they have changed their router but the iteads are still programmed with the old settings. The old settings have to be removed before any new ones can replace them.   

so i just click on the device and then press delete?

henry kidman

Pretty much yes. But it's called forget.

What is happening is you are trying to reprogrammed the itead by over righting the settings already in it.

It wont allow that. You have to forget it first, so it is empty and then let the app programme your new setting and security into an empty itead. 

Login or Signup to post a comment