Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

78 people have this problem

After changing my router and causing many hours of problems with my Sonoff devices. My solution to accessing my previously registered Sonoff devices was: Keep the old wifi network name (SSID). This is changed in the router. This old SSID is what is stored in the App.

I had the same problem that I solved in the following way (I'll tell you step by step in case it has a meaning):
after trying all the way at first i disabled the 5ghz wi-fi: nothing happened;
then i forced the wi-fi to use ch7: nothing happened;
then i forced the wi-fi to use the TKIP cipher type mode only: i can pair my sonoff pow!!
I followed back step by step
enabling both TKIP and AES
then enabling auto Ch
then enabling  5Ghz band;
Now it seems to work again

Device pairs and is registered then fails to connect to server. 

Tried to delete and pair again but same problem.

Update to my issues with Netgear orbi router trying to connect sonoff devices. I couldn't connect my devices using newer cell phones/ iPads /tablets. I tried using an old iphone 3g and was able to get my devices connected to ewelink. This seems like a crazy fix, but is worth the try before throwing the devices out the window. Hope this helps for the Orbi peeps. P.S.... 狼Netgear was useless in trying to help troubleshoot their problem unless I paid additional tech support.. Garbage support if you ask me
I tried to pair it many hours with android phones. Nothing. Then i paired it with one old iPhone 4s.

I found problem seem everyone.But I unplug it a few day.Today i plug and try to connect it work.I don't know what happen about its.

I posted this a few days ago but dont see it so here is what I've found. I've tried to connect with different devices to my orbi router with no luck. They would connect but not pair. Netgear tech. Support will try to help IF I pay additional,(NOT HAPPENING). I tried connecting using an old 3g iphone and it worked and can add multiple sonoff devices flawlessly now. Seems like these new 5g or mesh systems don't like to goto 2.4 so they have to be fooled with an old device that favors 2.4... hope this helps.

Also experiencing this issue with First Gen Sonoff Basic's.

I have more info to add. I upgraded our router, and none of my sonoff basic's would connect to the new wifi.

I tried every combo of settings with no luck...

I set  my router back to the right settings, and pulled out a new sonoff basic and it connected with no issues.

My first thought was a Firmware bug. The installed units are upgraded to v2.6, and the new one was still on v1.6.

I upgraded the new one to matching firmware v2.6. Deleted, and was able to resync with no issues.

The existing units still will not connect.

I think it has something to do with the ewelink/itead network caching the device id's ?

I don't think, i try to sniff the traffic and the sonoff device don't respond correctly when it have to connect.

They start to communicate but at a certain point the sonoff don't respond.

I try with 2 wifi one working the other not.

I changed the router of my internet connection.
Connection works well at 2.4GHz only.
SSID of the WIFI is still the same with the same PW but 2xS20 and an T1 wont come online any more.
I tried to delete them in the APP an re-pair but they are only blinking shortly every 2 second.
The pairing via AP is ok and the devices are shown in the app (i checked the connection settings every time twice i was trying)
Also tried to connect the S20s in an other WIFI where are S20 and T1 currently work well, they get no connection to the server.

I also opened a ticket at customes care center - no response since 11 days :(

After some more digging, I've noticed the ONLY different think I can find is the encryption type.

My old wifi was AES, the new one only has TKIP 

Now.I found firmware update 2.8.0.I will try firmware version work or not
Not work.

I was able to make a connection with a basic and Tenda Router...

My Settings:

  •     Network Mode: 11b/g/n mixed
  •     WiFi Channel: Find a clean channel
  •     WiFi Bandwidth: 40
  •     Encryption Mode: WPA/WPA2-PSK(recommended)


  1.     Enable WPS
  2.     Hold button on sonoff basic ~5 sec  (Quick Pair mode)
  3.     Hold button again on basic ~5 sec (Compatability mode)
  4.     Enter Wi-Fi password.
  5.     Jump for joy!

When WPS is enabled, you have 2 minutes to get to the sonoff switch and get it connected.

I have a just swapped from bt home hub to sky q hub and can only connect one of my 8 sonoffs.

I have split the 2.4 and 5 ghz without any luck and also tried to connect onto a mesh system which also doesn't work.

The units connect via Itead but pairing to wifi they just blink every second

Has anyone successfully connected to sky q ?

Login or Signup to post a comment