Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

78 people have this problem

I have used a number of the WiFi (not Z Wave) products from  I notice that these do roam happily between by UniFi APs and were fine when I reconfigured my network.  I have some light switches on order too now.

Just for clarity I have no connection to the company 

I have exactly the same problem connecting to the wifi. I have 10 devices installed and just 1 with the error. In Addition it is turning on and off the lights every 5 -10 minutes.

Please help!!!!!!!!

I'm using sonoff t1 uk devices... 

Hi guys... no solution?

If you can remove the devices from the app using your original WAP it is easy to move them. If not try a different WAP, SSID and channel. Eventually it should work. If not weigh up your time against purchase price

1. Delete all sonoff  devices from ewelink application.

2. Uninstall ewelink.

3. re-install ewelink from google play

4. register new account and new password

5. add sonoff devices

I think I found a solution for this issue. I had the same issue. Although my Sonoff switch paired initially I found its offline always thereafter. I did everything possible to pair it later after deleting the paired switch. Later I found that touch mode paring doesn’t work anymore and I went for compatible paring mode (AP) as shown in the picture attached. For that you need to follow the following steps. First, hold the physical paring button in the device for 5 seconds. Then light blinking is match with the the (touch) pairing mode. Do it twice or thrice (holding of the button) as the light blinking match with the (AP) paring mode; that is continuous light blinking. Then at the lowest, as shown in the attached photo you can go to the compatible pairing mode (AP). Then follow the instructions thereafter. This worked for me for two devices. I’m sure that will work for you too.

Same problem,

I have many devices to configure, distributed in an apartment,

2 sonoffpow already configured and well working on destination networks named jknet4,

1 sonoff 16th already configured and well working with temp and humidity sensor on jknet4,

some days ago i try to add another sonoff 16 th and it doesn't connect to the wifi jknet4.

This night the app make an update and i try again, i try an old sonoff 16th that was connected on another network, same problem, now i try to move the old one to other network jknet3, same problem it can't connect to the wifi.

I have 3 wifi named jknet3 directly connected to internet, jknet2 and jknet4 connected to jknet3, all these wifi are tenda N301 (versions??)

i try with Dilan D procedure same results.

The strange is that the 3 devices 2xSONOFFPOW and 1xSONOFF16TH was working and then SONOFF16TH stop to works and i can't connect others devices, the night there was a blackout but then i check with new one (SONOFF 16th) but nothing.

I have find a solution on one of the AP tomorrow i'll try the other...

look to:

SONOFF is made with esp8266 so i think mai be they have some informations... So...

In my Tenda N301 i change security mode: WPA2-PSK ; AES

Now it works, i have to test others devices.


I solved my problem. Sonoff is incompatible with some APs that works with 2.4 Ghz and 5 Ghz on same SSID. I have been created a new SSID only 2.4 GHz and now it's works fine.

After Switch pairing in my phone, the wifi is not connected and I am using Asus Phone and then  I connected to the Asus repair center and they helped me a lot to get rid of this problem.

I have several switches and relays connected to my Orbi Router. Recently I started adding more devices and worked around the pairing issues, but now the issue is they stay offline.. please help of you can. These types of issues make one think why they started these type of projects. What happened to "simply connect your switch", mind you this issue has been going on for weeks....

Hi guys,

I am having the same issue with all my sonoff devices after replacing my router to Connect Box (Unitymedia). Before that, everything was working fine. What I've already done:

- trying to reset devices firmware

- deleting devices

- deleting my ewlink account and setting a new one

- changing wifi SSID

- disabling 5Ghz router's mode 

- changing router's channel, changing chanel width to 20/40 Mhz

Unfortunately still with no luck. I am out of ideas... Please help...

Hey dude, I just registered an account just to tell you all this. I've been having trouble connecting my Sonoff T1 switch with my Wifi lately. I think it disconnected about a month ago and have never been connected again since. After I've messed with it today for a couple of hours I found out that it has something to do with the previously connected wifi. Because I tried to connect my switch with a new SSID and it would work every time. But it won't connect to my previous wifi. So in the end I turn off the house switch to make the switch powered off then after that I tried to repair my device again with the current wifi and it works!!


1. Turn off your device somehow. (I turn off my house power switch)

2. Wait a bit, then turn it back on

3. Remove the device from your account

4. pair device using compatibility mode.

5. the devices connect to the router and the internet successfully.

Hope this helps

Hi Kelvin! Many thanks for the effort you made. Unfortunately, I think it's not the issue I am struggle with. I followed your advice and did everything you wrote many times with no luck. 

I really think that the problem is related to my router which seems to be incompatible somehow with Sonoffs I have. The worst thing is that I don't even have any logs to analyse.

Login or Signup to post a comment