Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

78 people have this problem


Check that your router has the 5GHz signal turned off when setting up.  Your Phone/Mobile is probably trying to connect to the 5GHz and the Sonoff connects only to the 2.4GHz. This might help some people.

I have a Sky Broadband dual band router and i had this issue.

Good luck

(16.3 KB)

No, 5Ghz band has different SSID. This is not the case. The problem is due to Sonoff is reporting to router  "localhost" as a host name. Router firmware does not like it.

I am facing the same problem. Paired on one wifi and connected and when i changed router its pairing but not connecting. Not a solution yet? How do i fix this?
Hi everyone. I had the same problem with not connecting / pairing sonoff switches (T1, S20, basic, B1) with newly purchased linksys ea7500. My previous router was tp link c1200. I tried so many things already (whatever i can find in this forum & internet) and spent countless hours fixing but no luck. I did manage to get 2 S20 and 2 T1 (1 gang) paired by using 802.11b only mode but not others. I dont know why only this mode able to pair. But still the pairing process is not seamless as i had to try pairing so many times. Other modes won't pair at all. Then I decided to change the linksys router to tp link c3150 as i figured my previous router was tp link and it should work. Still the same. Switches not pairing and i thought it's the end. Then i tried guest network and voila all switches paired! Easily. Just make sure devices can communicate with each under guest network settings. Once the switches are all connected, i turned off the SSID detection, disabled access to my local network and disabled communication with each other as these are all under separate guest network settings. Just to make them a bit more secure. Hope this helps.
Finally it worked. Changed my wifi mode from aes to tkip and it just connected!

That's no good as tkip security is not as strong as AES.

Same problem

I agree with an earlier post from Chansim Lim, this is a DHCP issue, and therefore an IP implementation issue in the Sonoff devices. This should be followed up by the manufacturer, but maybe could be worked around. After my reconfiguration, I tried several power resets and the Sonoff devices always rejoin the WiFi


My observations from today - without any network sniffing - that should be for the manufacturer to follow up on. Just a few hours of testing, so I will respond with any further observations, if any. My last problem was after a thunderstorm, so I can’t predict if I will get any issues in the future.


Symptoms: Sonoff RF relay and Sonoff RF Bridge were successfully added to eWeLink and worked OK until a power outage, then they would not reconnect to WiFi. Checking the MAC addresses of all my devices in the DHCP table of the router, the Sonoff devices were not there


Assumption (intelligent guess): During the registration process, the Sonoff devices successfully use DHCP to gain their IP addresses, but then are unsuccessful following a network disconnect (or fail to attempt DHCP). If the router is reset, devices will reconnect using DHCP and a different device will be allocated the IP address that the Sonoff was using. If the Sonoff continues to use the old IP address, it will not be able to reconnect to the server.


Tests and my solution:

- Set the address range of the DHCP server in the router to (perhaps) 10 to 100 (typically I reserve some lower addresses for important PCs and servers)

- Reboot the router to clear all tables

- Identify the MAC address and IP address of the Sonoff device. To achieve this I had to delete the device in eWeLink, then add the device again (using Compatible Pairing Mode – directly connecting using WiFi). Once correctly registered, I could see the MAC address appear in the DHCP table of the router (make a list of existing devices so that you can see the new one appear).

- Add a fixed entry to the router DHCP table for the MAC address and IP address of the Sonoff device

- Change the address range of the DHCP server to (perhaps) 20 to 100 (assuming the Sonoff device is appearing between 10 and 20)

- NOTE: one weird observation is that I had entries in the DHCP table for a MAC address of “all zero” for the same number of devices as Sonoff devices, each reserving an IP address. So I had 2 Sonoff, plus 2 “all zero”, so I would leave a gap in the DHCP table of at least 4, in case these “all zero” entries have some significance


Hope this helps someone, and add feedback if it did / did not. The only way to fix things is to add feedback

Good info. My router happen to set DHCP range from 2-127.

Did tried the method you mention, but without luck.

Strange enough, if I use a repeater. It get connected without problem via repeater.(I use different SSID name for repeater so I can know if the device is connected to router or repeater).

the thing is the router won't recognize even after adding it in compatibility mode

Resolved. I had the same issue with a new router. I go the switches registered but would then not connect. I was asked by support to clear the data and cache in the app and try again. This worked and all 3 switches now register and connect to the new hub.
The main problem seems to come from using the same password on a different access point or SSID. What worked for me was to temporarily pair and connect the sonoff to something with a different password. After that I could go back to the original SSID and access point and use the original password to pair and connect.

This is definitely a strange issue, and I can’t offer any definite solution. In this instance, I had a different access point, with the same SSID and Password

My latest update:

- My original router was an ADSL access point router provided by the ISP. It was maybe 5 years old. With this router, the Sonoff switches would obtain an IP address through DHCP, but seemed to hold onto that IP address even if the router was reset. After a router reset, other devices could get the IP addresses used by the Sonoff switches, so most of the switches would become “blocked” since their IP address was in use. I could resolve this by identifying the IP address that had been allocated to each switch, and assigning a fixed IP address in the router DHCP table and moving the DHCP range so that all the switches were outside the DHCP range. So it seemed to me that the Sonoff switches were either unsuccessful during a second DHCP process, or they never tried DHCP after a router reset.

- Yay....they just installed fiber in our street, so the ISP router has been changed to a new model. I expected big problems with the Sonoff switches, but they all reconnected on their own. The new router did not provide the same IP subnet as the old one, but I changed the SSID and Password to be the same as the old one. All the Sonoff switches connected with new IP addresses in the new IP subnet

- BUT, I suspect the issue still exists. Maybe I will get an IP address clash in the future

- In the old router, if the DHCP range started at 20, after a reset the IP addresses would be allocated sequentially to each device in turn, so the first device to connect would get 20, the next device 21 etc. If a Sonoff switch had already “captured” address 20 when it was first initialized and my iPhone was given 20 after a reset, then the Sonoff switch would not work after the router reset

- In the new router, the address allocation by DHCP seems to be much more random. The address range starts at 20, but the Sonoff switches now have addresses 32, 57, 92 etc. If I reset the router, all the Sonoff switches reconnect with the SAME addresses as before the reset

- EITHER: This is working because it is very unlikely that a device that requests an address after a router reset will be given one that has been “captured” by the Sonoff

- OR: The router remembers MAC addresses .......

- Just tested this theory. After a router reset, all devices have the same IP address as they had before the router reset (iPhones, Amazon Echo etc) and all those addresses are (seemingly) random. This is very different to the old router, where IP addresses were simply allocated sequentially.

What is interesting is that the Sonoff switches restarted DHCP when the IP subnet changed. My guess is that the Default Gateway became unreachable so they initiated DHCP, whereas, if the DG was reachable, they retain the same IP address and do not bother with DHCP – just a guess.


Hope this helps someone

Had a very similar issue but like others not really sure what in the four hours of frustration actually worked.

I have UniFi network system which needed a bit of updating.  After that bam 50% of the Sonoff devices would not connect.  I think some of the access points swapped channels in the upgrade.  Interestingly it was the older EU switch devices and TH10s that positively refused to connect.  The Dual would reconnect when I re-identified them in the app.  My most recent UK Switches made the transition on their own.

I certainly see that these devices will not hop between access points based on signal strength.  They absolutely lock on like limpets.  At one point I also set up my routers WLAN with a different SSID, password and channel not used by UniFi.  I got devices connected to that, then removed them from the app and tried reconnection to the UniFi APs.  Eventually, I got them to go.

I noticed that my Router would say the MAC address was connected to the WLAN even when the no connected blue light was flashing on the device.  A bit odd.

Also unless the device was discovered as a second generation device it would never connect properly and join the network (even though it was discovered and registered).

There's definitely a flaw in the limpet-like nature of these devices connection.  I guess you get what you pay for.  Although having said that my other Chinese smart home devices gave me no issues at all.

"...I guess you get what you pay for.  Although having said that my other Chinese smart home devices gave me no issues at all..."

Yes, I think you are right. It has been more over a year, and the guys at SONOFF did nothing to resolve this problem. Could you refer us which other (Chinese ?) switches/devices You are using and having no problems with? 

Thanks, Mario.

Login or Signup to post a comment