Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

78 people have this problem

Did a trace and believe the problem is with Sonoff firmware.

Jan 24 16:56:47 dnsmasq-dhcp[277]: not giving name localhost to the DHCP lease of nnn.nnn.n.nnn because the name exists in /etc/hosts with address
Jan 24 16:57:24 dnsmasq-dhcp[277]: not giving name localhost to the DHCP lease of nnn.nnn.n.nnn because the name exists in /etc/hosts with address
Jan 24 16:58:22 dnsmasq-dhcp[277]: not giving name localhost to the DHCP lease of nnn.nnn.n.nnn because the name exists in /etc/hosts with address

This seem to be very similar issue to my old Samsung smart TV. It try to present host name as "localhost" to router. The router firmware does not like that as "localhost" which is ip is usually used for loop back test in IP world.

Correct me if my understanding is wrong.

The only thing my sonoff switch will connect to is my ATT Pace modem - and I tested it with 2 different models of those and it worked with both.       As soon as I try to put my home setup back in place - using a decent wifi access point, it fails to connect even with same ssid and password.  I went and bought 2 different wifi routers and neither worked. Google Wifi (returned it) and  ASUS AC3200 -  all other 20+ devices in my house worked like a champ in every scenario but these sonoff switches are just a pain.  

Able is on the right track. I bought 6 of the "new" touch 1ch switches (all white), they beep when setting in pairing mode. at first I wired 5 of them, replacing the old light switches, then tried pairing, the pairing process worked but would not connect to my router ASUS RT-AC5300 the remaining switch I just wired to a plug, this would allow me to power the switch off and an again. when I finally got the test switch working I replaced a wall switch with this one and repeated the process until all the switches were replaced, leaving me with the last switch which would not connect, even when tried against a generic Draytek router. I eventually took this switch with me to work to try on another wifi router (SonicWALL), this also failed to connect,  that is when I read this post, opened insider, (which I should have thought of earlier), and noticed the channel the SonicWALL was on was 6 I changed this to ch 7 re paired the switch and first time it connected. I tried the same at home, but found the airwaves saturated with wifi signals and one of my neighbours has a wifi router using channel 3 and 7 which I think is interfering with the pair process. My problem now is, how do I block out the other wifi signals aside from building a Faraday cage, and I cannot go around the neighbourhood asking people to switch off their routes while mess around with Sonoff devices.

Inssider is a free wifi analysis too which will show you all wifi signals based on strength and channel covered.

Yes same here and with a first gen 4 channel as well. Took at least 20 attempts before I could get it to pair but will not connect to my WiFi despite having been connected to a different AP in the past.

Still no fix. Sonoff support to hard code mac address at router with fix IP. Still, no good luck for me.

Not sure if flashing to other firmware will have this issue fix?

How would you discover the Mac address of it won't connect to the router?

download insider and when you place the sonoff in pair mode it will show up as itead and then display the mac address

Yes that's right.

I have experienced similar problems-- out of five units (All single channel 3 BASIC and 2 RF versions)

TWO units work perfectly!

THREE can only be registered using "AP Mode" but then will NOT connect with my TP-LINK Archer C9 router. I have an ongoing conversation with ITEAD but their command of English seems to be too poor to understand what I tell them and they keep sending me "boilerplate" answers.

I can register and then connect if I use my old Netgear Router but this is unacceptable as it is too slow and does not do simultaneous 2.4 and 5 gHz .(Yes- in case you ask I have tried turning off 5gHz but no improvement)

I can also register and connect using a spare phone tethered to my main phone but this is useless as I'm officially not permitted to use tethering on my current contract.

As suggested above I have tried running "Inssider" and it shows the ITHEAD temporary AP when in AP mode-- i used that to find the MAC addresses and then tried binding those addresses to dedicated IP addresses on my router- no change!

It seems strange that TWO of these devices work faultlessly(both run 1.6.0 firmware) but the others don't?

Manager to find Mac address and create pendant link to IP address but no improvement here either.

May be a stupid question but even if Itead release a new firmware that fixes the problem we won't be able to install it if we can't get the device connected to WiFi.

try changing the channel on router to channel 7 try the connection again, if it connects you can change the router channel back to auto it should reconnect, I tried this on my router and 5 of the devices reconnected when the router channel was changed to 7 then back to auto.

I still have the problem of isolating my wifi from the neighbours

Tried that-- Neither the BASIC or RF model will connect with my TP-LINK Archer C9 router although they will register using the alternate "AP Mode"

Finally gave up and decided to switch to another brand call Smart Home (Android app name: Smart Life).

Gotten it from eBay. Paired with my ASUS router beautifully.

External hardware is same physical size as Sonoff. Electronics build inside is of much better quality, at lease the Wi-Fi module is completely shield in metal box.

Only down side is do not have additional pins connection like Sonoff, so those who wish to flash their own firmware will be disappointed.

Gave up with Sonoff product and support.

do you have the ebay link, if sonoff is as unreliable as they are, and all support say is "your router can only handle 15 devices" then I maight consider replacing these switches, I'm not interested in flashing light switches. I just don't see the point,

Try this :

Believe router now a day all can handle at least 254 devices (minus .0 and .1 which is used by router itself).

Login or Signup to post a comment