Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

78 people have this problem

Didn’t work 洛 so raised a ticket.

Hi guys.

I think I have found the solution, or at least now all the equipment works for me, the S20 as the 4chpro.

The same has nothing to do but I will contribute my bit and explain all the steps you take.

At some point I started to work and it seems to be stable now.

I think the main problem is with the product's Wi-Fi chip and that it is affected by the saturation, (excess of the neighbors' Wi-Fi). Wi-Fi is like radio stations and we have 14 channels or frequencies, if your router uses channel 6 and your neighbor also does not work well.



- First of all I made a default reset of the entire router.

- I downloaded the software to the mobile "wifi analicer" (free for android) where you can easily see all the Wi-Fi of your neighbors as well as in which channels you are transmitting.

(Example image of wifi analicer)

- I have configured in my case:

          channel: 7

          Band Width: 40Mhz

          Mode: Mix (802.11b + 802.11g + 802.11n)


- Then I deleted the ch4pro and s20 devices from the ewelink app, and I tried to synchronize again and everything was very fast.


I hope I have been able to help somebody, to apologize my English is not good and I am using the google translator.



1 person likes this
Hi I just tried the suggestion but now nothing is online, oh deep joy lol
Got my two devices back, but the 4ch Pro is still being an arse and not working!

OK sorted it today, put my iPhone in Airplane mode and made sure I was on 2.4Ghz, used the Touch Mode rather than AP, and it worked.

I have same issue aswell 2 of the switches worked until I upgraded the router. The other 3 I have work fine. Checked router and they don't show up. I even added another new switch last night and it worked fine.

Have exactly the same issue. As I have only one Sonoff so far. can only explain follwoing symptom and setup I had.

Boardband->ASUS RT68->Xiaomi repeater2 (repeater mode)->Sonoff

First setup was sucessfully complete. 1 day later, found there is a new FW verison 1.6.0 indicated at mobile app. Update it as work fine with above setup.

Decided have Sonoff connect directly to ASUS RT68, reset Sonoff, start pairing, sucessfully complete (at time cannot complete), Sonoff appear in the app but offline status.

Check Sonoff is slow LED blink, ie it has not been sucessfully connect to my ASUS router.

Try varies configuartion, change ASUS RT68 to Dlink 850L, old DLINK pocket router etc. It appears that Sonoff can start pairing but never goes online and it never connect back to network.

Strange enough, if I use it back with Xiaomi repeater 2. It pairs and online sucessfully. Try a fwe times and everytime is good, It seem to me the Sonoff FW seem to "remember" my old setup with Xiaomi repeater 2 and refuse to connect to anyone router after that.

PS. I changed my Xiaomi repeater 2 to roaming mode (ie same SSID as my ASUS router). Situation become tricky depending on my Sonoff location (guess it depend on weather Sonoff connect via Xiaomi repeater or directly to ASUS).

Looks like some firmware issue to me. Have put off the rest of my project due to this unclear issue.

Added info:

I can see IP assigned using MIHome app on my mobile, seeing that a IP is assigned to Sonoff.

But strange enough, this IP does not appeared in DHCP table of my ASUS router. Both my mobile phone and Xiaomi repeater 2 did register a IP at my ASUS router !

My guess;

Sonoff is using soe kind of no standard mac address and the router seem dislike it and unable to register Sonoff into router network.

For some reason, Xiaomi repeater 2 does care about it so I can connect to it without issue.

Yes I agree I connected to the switch with my phone and looked at the ip address and it's I can't find away of changing it. I have done a ticket with itead, but just got the standard reply with the same answer which none where any help.

Same experience-- I've bought 2 wifi only and 4 wifi+RF switches. My normal router is a fairly new TP-LINK Archer C9 and using that I can get the two Wifi only units to work OK but not the combined WiFi+RF units (although they work fine with an RF dongle) I've tried all sorts of suggested changes to the Router settings such as different DNS settings, Bound IP/MAC pairings, altered IP range and so on to no effect. I then tried using an old netgear router (non-ac) and it connected immediately but then refused to work with my newer router even though the SSID/password on the 2.4gHz channel were deliberately the same (All my other devices work with BOTH routers but the TP-Link has 802.11ac which is of course faster for the PC and tablet.) I've raised a ticket with ITEAD but like others- so far just "boilerplate" answers. I'm also convinced that SonOff are doing something strange with the WiFi firmware??

I don't know if this is going to be helpful to anyone. But I was having a similar problem with two sonoff basic smart switches I purchased. One had no problem connecting to my network and working as it should. The second, would pair successfully to the app and then just show offline (while slowly blinking one blink)

What worked for me was logging into my router and changing the broadcast setting from 40mhz to 80mhz and it instantly paired and is now online (and working with my alexa) 

Also, I have a dual band router (from at&t) so when first pairing I had to shut off the 5ghz broadcast network so only the 2.4ghz was broadcasting, pair my switches and then re-enable the 5ghz setting on my router.

I'm sorry if my description is poor because I'm rather new at this. I just thought I'd drop in and maybe help someone out.  (oh, also, I enabled the "guest" mode on my router (and renamed it something like Smart Device Network') and added a password to it.

(btw my firmware is up to date with the 1.6.0)



80Mhz is for 5GHz channel. Anyway, tried your sugesstion but not sucessful. At time, Sonoff will pair but refuse to go online as connect to WiFi seem failed (slow blinkun green light).

Strange enough, setting up with my Xiaomi repeater 2 is a sucess everytime !

I tried with Xiaomi repeater ver 1, same failing result as connect directly to router.

I tried following router without sucess:



Dlink pocket router (single 2.4G band only)

Sucess everytime:

Xiaomi repeater v2

Launch a ticket to manufacturer. Reply/Suggestion is equal to none!

Would suggest those who want to use this device for a project, test it before purchase in bulk.

My apologizes, I men't I switched my 2.4ghz from 20MHz to 40MHz.

Did that with my ASUS RT68U, tried 20Mhx/40Mhz/Auto option. All did not work well.

At time, it found the devices, pair completed but Sonoff remain slow blinking LED and Andriod app will indicate device is offline.

For some reason, Sonoff just refuse to connect with new SSID.

I tried also by fixing 2.4G channel, no help either.

However, repair to my SSID on Xiaomi repeater v2 is successful every time.

Login or Signup to post a comment