Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 


78 people have this problem

Hi,
i've seen the thread is very very old, but newest entry is only 17 days ahead.

So i've got also the problems with the Sonoff T1 (3gang UK Version) to connect to my new
Edimax RA21S Accesspoint. I had previous the Edimax 6808 V.2 which work pretty well, also with T1.

Sonoff Basic, 4CH, Wemos D1 Mini, ESP8266-1, ESP32 aso.,  all are working well.

Only the T1 won't connect.


I found now out why.
Its the Wifi "preamble". It can be set to "Long" or "Short"(default).
Set it to LONG and the T1 can connect.
Well some AC can't be configured this details, but if, try it.
It should be:
LONG preamble
20MHz Bandwith 
WPA2 mixed (sometimes only AES work?!)
DTIM Period 3 (mostly its 1 as default)
Beacon interval 100
CTS Protection disabled
WMM disabled

and i also found (i don't realy know why this matter), but if  5GHz has the same SSID
it won't connect. Dont ask me why.


Hope that helps a bit out of a 3 year old (long)  thread.

all the best


Thank you, Franky!

Registered here only to say that!

I disabled "Short Preamble" and "WMM Mode" in my OpenWrt and my TH16 finally connected!

Other settings looked ok:

DTIM Interval - 2

Mode - N

Width - 20MHz

RTS/CTS Threshold - off

I too have this problem now. The POW used to work properly, but in a new router no WEB or older encryption was available. It didn't want to pair. I took it to an old router with WB, and pair with sustained connection in 1 try. No firmware upgrade for the POW available. Again tothe new network: won't pair in 1000 ways,also not with AES.

 

same issue with a sonoff sc right now, and I'm afraid to try with other devices, but I really need to reconfigure my wifi networks, please help!

Hi every, I had the same problem. My first box have died with time, so my operator launch a new one, exactly the same.

At this point, all my devieces in Ewelink app was "Not connected". 

I succeed to connect a new deviece, it was recognized, but the statut when i want to use it was "Not connected".


To solve this problem, I basicly rename my Wifi network , and reconect each deveice one by one. I don't understand exactly what was the problem, but this solution work to me.


I hope that can help you


Referring to my comment of 9 days ago, I took the device back to the old router, having WEB security for the Wifi. Again pairing and connection maintained without a problem. I think, the POW R1 can't use modern Wifi....

I have a TH16 been in use for a couple of years. Went offline yesterday.


Spent the last 4 hours trying to repair it. Had to pour me a large glass of scotch!!


Tried every option, AP, simple pairing, 5Ghz off, reboot routers. (AP mode access denied with 12345678).

Tried that on 3 different routers.


Various options in the routers, security, channels, etc etc

Run out of options other than buying a new one.


Possibly the wifi module is broken.





test

Hello Christopher Denye!


Did the TH16 went off by itself? 

Any changes made or devices added on your Network lately? 


Have you tried your defective TH16 on another network? 

Any other sonoff devices on your actual network? are they working fine ? 


Let me know if I can help !

Regards,

Alex

Sonoff Basic... same problem after pairing cannot connect to wifi...

My solution was create new wifi with name "test" and without password... then all works correctly (my firmware was very old 2.6.0) so then I updated my SONOFF to 3.5.0.

Then I remove device from app... and again add it by standard way to my standard wifi with password.


Probably problem was in SPACE character in WIFI name or something with security standard...who know... :)


Now all works correctly

I have the same problem, except the unit is now 2 hours away

i solved using a tplink wifi extender, in order to create a new separate network. Ho risolto  problemi di connessione dl sonoff 4ch pro r2 usando un ripetitore tplink, per creare una rete separata

John, try to use different phone. I can't connect my Sonoff devices using OnePlus 7pro but it works with old Nexus 5x.
Ps. Or find the way to flash it with Tasmota software ;). It won't work with Ewelink, but is working with HA very well.

Hi, this very very long tread reports from hundreds or maybe thousands of users, having trouble connecting Sonoof devices to (mainly) newer routers and or new networks. I went through all suggestions and ideas and tried it on my new TP-link AX 50 wifi 6 Router, with an updated TH 10 from Sonoff.


I ended up spending nearly 5 (five) hours testing all kinds of suggestions from here. Nothing worked.


My conclusion is that the TH10 from Sonoff is not designed to work with newer devices and modern WiFi. Some users report that some Sonoof devices might work, while others do not - from the same batch (where users might have bought several devices at the same time). That seems to be some quality issue with the devices. 


Besides, as most new routers are capable of utilizing both 2,4 and 5 GHz, it seems stubborn that Sonoff keeps focusing on only one of these (2,4) and not making it possible for the Sonoff devices to at least negotiate with devices that have both turned on, as that is what most users will do today. Or at least have the Sonoff device acknowledge the existence of WiFi with both bands turned on, and then try to connect to the 2,4 GHz part of the router. I’m not a WiFi engineer, but think that it might be possible to do! 


Evidence: I have myself installed a WiFi device (from Panasonic - see image) on a Panasonic heater pump to allow for remote WiFi-linked control. And that device did connect nicely and smoothly to the very same TP-LInk router, that the Sonoff device refused to connect to.


Anyhow, I have taken off my Sonoff TH and will give it away for someone else to experiment with, and I am buying an (EU) alternative, which has more options - and is a little bit pricier. 

IMG2010.jpeg
(1.06 MB)
Login or Signup to post a comment