Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

78 people have this problem

Thank to these posts I could change my router. For me the 2-channel sonoff switches connected automatically to the new router. The 1-channel routers could not be connected, only after they were deleted from the app while connected to the old router. One switch was deleted when the new router was active, so it was not set to factory settings. That is why it could not be connected to the new router. Reconnecting (and deleting) with the old router was not successful. The only solution was to create a new account on a new phone, connecting and deleting and then connecting to the old account onto the old phone while the new router was active during the whole process. During pairing messages said that it was not successful, but ignoring them the process was successful. For me only the compatible mode worked in all cases.


I received a new router from the ISP, but since then it no longer connect. first it was a problem with pairing. turning off mobile data fixed the issue, but now it register ok, but it doesent get an IP address assigned. I see in the router loging into the router but appears connected without any IP.

I tried to asigning a fix IP address to the MAC of the switch but withouth any luck.

I deleted and re-paired several times. no luck at all.

Any suggestions?

Hi guys. I’ve had 1 sonoff switch for a while. Decided to add a second. Had the same issues as you guys and have been scouring through this thread looking for solutions. In the end i deleted both devices and stared again by pairing multiple devices at once. It found them both instantly with no messing with my router. I then re paired with Alexa and it works perfectly. Simple answer. Delete all devices and Just start again. Hope this helps.

 If the Sonoff problem does not pair, check on the eWeLink app that the selected pairing mode is consistent with the blinking frequency of the LED on the device: ● If the LED flashes alternately twice fast and once slow, you must use the Quick Pairing mode (default).

It seems I found the solution.

This is for the case when devices pair but do not connect to wifi then.

First of all check for already known troubles - must be no special characters in SSID or password, no 5GHz network, 2.4GHz must be b/g/n etc.


1. remove unconnected devices from your main account in ewelink.

2. use alternative device (I used iPad instead of iPhone for this) and install ewelink there.

3. register new account. if you have no free email you can use any service for temporary mailbox like etc.

4. add the device to the account using quick pairing mode. then check and update the firmware if necessary.

5. remove the device from the account. it should begin blink like ready for quick pairing mode

6. return to your main device/ewelink account. pair the device in compatibility mode. no need to unplug/plug, just keep the button pressed until it begin blink rapidly.



I had this issue with a new ZB Bridge but was able to get it connected by temporarily disabling the 5GHz channel on my router.

Once it was connected and added in full I re-enabled the 5GHz channel and the ZB Hub has worked fine ever since.

I ran into the same issue, I had two problems in my setup. 1- the network I was using was on 2.4 and 5.8 GHz. Once a physically isolated network created for the SONoff the devices connected perfectly. 2-the other bug I had was that the SONoff was reminding it's last wifi connected on even after a reset to default. I had to create a network with the same SSID and Password previously connected, then unpair the SONoff. After that the pairing process was working as described in the documentation. Hope it helps!
Helo all, i have solution of this problem. You must change wifi setings on your router, in 2,4ghz radio set "Legacy" mode check b/g protect then pair and connect sonoff switch to this WLAN and update FW. Next set your router to "auto" mode b/g protect must by checked. This solution i tested on Asus AC58U and AC59U V2.

I have the same problem with T0EU2C-TX. Had tried everything, and after successfull pairing, the device is not connecting to the router. The led is blinking slowlu (1/sec) and nothing is happening. 

As my experience goes I had similar problems.  Repeated attempts all  endned up as failures. All I did was switched to my tablet after logging out of eWelink application on my phone. It linked & connected to the router without a problem. 

It might even be a problem with the router. Some of my Sonoff devices simply would not connect top my main TP-Link router. When I connected a Zyxel travel router to the TP-Link as an access point it connected on first attempt. It is maintaining VERY steady connection now. BTW I am supplying 9V power to the router over POE near the cable modem.  Can't figure out why that both are so close together but works with one but not with the other. 


That could a problem. I have top TPlink Archer 11000 router. Funny storry, TH16 connected without an issue.  T0EU2C-TX and TH10 had an issue

It looks like problem was solved with old LG Nexus phone... unbeliveble

Get the best captain america quotes here and read the best attributes of the captain Marvel here. captain america quotes

Set smart scenes to control devices by temp. & hum: working with sonoff temperature & humidity sensor (am2301, ds18b20), sonoff th10/th16 can detect the real-time temperature & humidity of the environment and set up a temperature/humidity condition to control connected home appliance, even the ones connected with other sonoff products, such as sonoff, sonoff rf, sonoff gba emulator ios

had the same issue with netgear r7000 and L1 led strip. i tried a lot of stuff including changing SSID, disabling 5ghz band, disabling nat/qos/whatever. 

it must be something with a router 'cuz LED controller goes online without issues with android, iphone and even laptop hotspot

finally, the solution that worked for me:

1. disable 2.4ghz radio on router (or power-off router)

2. create wifi hotspot on smartphone with exactly same SSID and password as router's 2.4ghz network. just make sure you're not using the same smartphone for hotspot and pairing

3. pair device using different smartphone, wait until device goes online. i used compatibility mode for pairing (btw, had to disconnect led strip from controller to enable it)

4. disable hotspot and enable router 2.4ghz band

right after that i got an error on controller (blinking twice per second) but after ~5 min controller went online, and so far everything is ok

Login or Signup to post a comment