Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

74 people have this problem

Steve Christie: I reverted to tablet when my phone would simply not pair.  I ahev never had a problem with my tablet connecting to the internet. I have a 4G sim + a fibre optic 50 mbps connection and a 100 mbps  cable modem connection in my house.  Bothe the internet connections are connected to 1200AC dual band routers.  

Pradip Shah

I have no problem with the internet connection in the house, the problem was how many items could be connect to the router at a time. Most normal ac1200 type routers can only connect about a dozen devices at a time. My android tablets would connect, but they are a bit slow to change networks when they lose a network. The switches don't seem to tell them to revert back to the main network once the settings have been updated. So the tablets (my ones at least) didn't immediately notice that the local network the switch had been broadcasting was gone. 

Much like a laptop, if you watch the network indicator on your laptop and turn your router off, it could be over a min before the network indicator shows the network missing. Phones seem to notice that quicker, probably because they are mobile and more used to changing networks.

I've also had the switches take 10 mins to work after they have been programmed. Normally they get programmed and work fine in a few seconds whilst you have the app open. But i have had occasions when they don't seem to connect, only to suddenly start working 10 mins later.  

1 person likes this

I have 3 phase power supply in my house. I have 3 POW-R2 devices connected to monitor the voltage AND to ensure that all the 3 phases are working. The 2 networks are connected to 2 different phases.  PON & Modems are powered by different phases so I can always restart the supply to either since the Sonoff switches are connected to the other network.   

Now what I find most strange is that if I have the Lan option switched on and the phone or my tablet connected to the Lan other than the switch I want to control then the command via the Internet takes a long time to have effect or does not work at all. . If the Lan option is off then it is fast.  If the switch I want to control is connected to the same Lan as my phone or tablet the response is ULTRA FAST. 

That is why I have repeatedly requested ITEAD people to make visible the SSID to which the switch is connected or its local IP address. Then I can very quickly switch the Lan my phone or tablet is connected to and get ultra fast switching response.

BTW as I had mentioned earlier I had to add a Zyxel travel router in the network to limit the number of switches connected to each router. 

I've had similar problems changing from my D-Link router to a Huawei DG8041W.

All, yes all my non Sonoff devices connected to the new router once I changed the SSID and Password to that of my old router. They include several phones, Android and IOS, tablets, ipads, cameras, Google Home Mini, Amazon Echo, Laptop, IR transmitter (also ESP based as are the Sonoffs), Chromecasts and Firesticks.

So really why do Sonoff devices not do it too - This really must be sorted out before they can be recommended (I do like them though).

Anyway, mine wouldn't work even after deleting them properly from the old router (it still worked) and trying to reconnect them to the new router with the original SSID/Password. I've been struggling for 3 days so I can't remember what the symptoms were exactly.

Next step was to set up a second "guest" 2.5GHz wifi and connected my phone to that. I then started the process of pairing and it was working fine until I got part way through my devices when it started playing up and I couldn't pair any more. After a lot of effort I found that I could only get up to 7 devices (might have been 8, including my phone) connected and the next one would cause ALL devices already connected to go off-line. by keeping the numbers down I got all devices paired and sure enough, as I turned them on, all was good until number 8, whatever it was (I made sure it wasn't a particular device having a problem. If I had all the devices turned on and reset the router I could watch the Sonoffs connecting in turn until number 8 when all would fail. Turning some off would not let the remaining 7 reconnect without a router reboot. This may be something to do with the router!

So now, in addition to my original SSID/Password, which has all the well behaved devices on, I have 2 "guest" WIFIs with 5 devices on each. All seems well after a day of running. I daren't try to put them back on the original SSID in case it all kicks off again!

One other thing, when i enabled the first guest wifi the router started putting the Sonoffs onto a different IP subnet (?), namely 192.168.2.x, instead of 192.168.0.x where everything else is. I don't know if it mattered but I turned off the DHCP Secondary Address Pool to sort that out.

Hopefully Sonoff will put out new firmware to overcome all these issues but I won't hold my breath.

(8 x S26 sockets, 1 Bridge and 1 Dual switch board for my curtain closer)

Steve Christie: Firstly huge thanks to you mate, if I didn't read your posts I think I would not be able to resolve this issue. I hail from Australia and use Optus for my internet, I have been using the sagemcom router provided but noticed coverage issues around my home so decided to get Netgear d7000v2 router and I have setup the new Netgear router with similar ssid and passwords I had before on the old router thinking and also being lazy so I don't have to re-repair my Sonoff switch. Issue : All other devices got connected except the 5x Sonoff smart switches Solution: after trying everything I came across Steve's post and I have followed his advice. What I have done : 1. I reconnected my old router and through my ewelink app I deleted all my Sonoff switches while connected to network with old router. 2. I then reconnected my new router ,then on my smartphone with android 10, I selected forget network option to all other networks except my 2.4ghz network and also switch off mobile data reason being when pairing the switch if multiple networks are available the ewelink app will get confused will come up with timeout error. Once you follow the above steps it really doesn't matter what brand router it is all you need is 2.4ghz network and it will work. Again all this credit goes to Steve Christie for his valuable information and persistent advice. Thanks

1 person likes this

Upender Parmar

Glad it was of some help mate.

Regards from sunny Suffolk UK.

Graham Richards.

I didn't know how low a number of devices you could have on some of these routers, i thought the limits were on traffic not devices, (They give you a hundred ip's). But i put a 5mp network camera up and my router started to struggle. It was only when i was looking on Amazon for an upgrade that i noticed that some of the manufactures are now stating how many devices their routers will connect to. Some of what you would think would be quite decent routers can only connect up to ten devices, so i can only assume if they are making a point of advertising ten devices, some others must be even less.

I bit the bullet and went with the Linksys WRT 32X. It was an expense, but so far in 3 odd months it hasn't skipped a beat. I don't know what the limit is on it, but i'm up to well over 50 at the moment all in including the 5mp camera.

Steve Christie

I don't think there is a WiFi device limit for regular devices (not reached it yet, anyway), just the Sonoff devices. 

I've always thought the routers you get from the ISP are a bit pants (I used to have a Netgear one but it's old now). Maybe one day I'll invest in a better one. I quite like the new Huawei one (from TalkTalk UK) as it lets me name each MAC address so I can tell what is connected at a glance.

1 person likes this

Graham Richards

If you look on Amazon now, a lot of the routers actually tell you how many devices can connect to it. Sometimes for routers that you would think were quite powerful, it can be as low as ten devices. 

Now I must look into this router where I can actually name the device with each assigned MAC address to keep a track of which devices are connected. At the moment I am using "Wireless Network Watcher" from Nir Sopher to do this. 

Pradip. I use Deco M9 and works great. Easy set up and Device name assignment to MAC Address. Can also use as Smart Hub to allow a other option to switch lights etc. I always assign IP Addresses to my Sonoff kit and have no problems in their use.

Last week when I have changed my router to TP-Link DECO X60 then I also face the same issue with sonoff POW.  But yesterday I have fixed the issue. I have installed the old version of the eWeLink app then instead of using the SSID from DECO router, I  have created a mobile hotspot on my old mobile and then they get paired successfully using quick pairing mode. Then I saw some firmware upgrade message and I immediately upgraded to the latest version. Then I am able to pair them with my original router.

Read your post with interest. My Deco 9 pairs with Sonoff easily but you must turn off the 5G on the router first. My mobile phone will always go to 5g signal if available. The SSID is the same for both 5g and 2.4 on the router but the Sonoff only uses 2.4g and will not see the mobile on 5g when trying to set up and pair. By switching off the 5g you force both devices on to the 2.4 frequency. My units all work flawlessly now, when power is lost temporarily and returns all units return to operation. My other router is a Totolink and my Sonoff devices will not work with this unit.

Thanks Robert.

Actually,  I have turned off 5Ghz in the Deco App and then tried to pair Sonoff POW but it was not able to pair. My all other Sonoff basic, Mini, Pow R2, fan02 all were connected using the same router. Once I have upgraded the firmware then only I was able to connect POW with the DECO.

Just reconnect the original (old) wifi router, pair the device to it again, then delete it from the application (this will reset them to the factory settings) and then they will go to pair with the new wifi router. This solution has always worked for me.

1 person likes this
Login or Signup to post a comment