Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 


63 people have this problem

Brian Tristam Williams :  I too had similar problems. Some wer sorted when I used my Tablet instead of the phone but some still remained adament.


What I did then was use one of those Android charged powered  pocket sized travel router like Zyxel or TP link.  Switched to that in my phone and voila it worked.  Don't ask me why. I use these with POE to extend the range of my router. 


Zyxel  MWR 102.jpg
(3.09 MB)
My Sonoff devices will not pair with my new router. Fortunately my new router has a guest connection, I set this up with the ssid/password of the old router. I see that this problem has existed for years with no solution from ISTEAD. There seems to be no way of removing the initial ssid used.

Years go by and they refuse to even acknowledge this problem.

RichardT.

It isn't really a problem, millions of people use millions of these switches, I've currently got 34 of them running myself.

If you change your router without first deleting your switches from the app whilst the app is connected to them, then the app wont reconnect them onto a new router. I had that exact same problem, which is how i found this site.

The solution is to create a second email address with your ISP and then create a new Sonoff account with that email to log in, ideally on a device that hasn't already got the Sonoff app on it.

On that device, download the sonoff app, use your new email address to create an account and connect the switches as normal. 

If after that you want to reconnect them to your old sonoff account with your old email, first delete them from the new account and then they will be free to reconnect to your old one.

It's a security feature to stop other people hijacking your devices. You can only delete the device if the app is connected to it. If your not, all you are doing is deleting the device from the app, not clearing the device itself.

It is also possible on some routers just to rename your new network exactly the same as what your old network was. But that doesn't always work.  

With all due respect, Steve, you have a habit of jumping on here and telling people that the problems they're experiencing don't exist. "It isn't really a problem..." Actually it is a problem, for many people here, in case you haven't noticed. And yes, we've tried the many solutions proffered by many, and for some, the problem hasn't been solved. So please, offer help if you can, but stop telling people their problems are imaginary.


Brian Tristam Williams.

Look mate, there are millions of these things working perfectly all over the world. You can see by the tiny size of this thread that very few people have had the problems we have had. I am telling you the solution, If you would rather chastise me for trying to help you rather than take the advice good luck.  

I too faced this problem. Funny thing the solution that worked for me may not be possible for all.


A few absolutely refused to connect /keep even after pairing when I tried with my Android 7.1.2  phone. Out of frustration I tried with my Android 8.0 table. Voila paired and connected in under 30 seconds !!! Now ALL these are available from either device. Just need to login with that device.

The Sonoff devices have caused me real hassle, when I changed my router. Every thing else was no problem eg WIFI printer / camera/ extender/ orvibo/ smartlife / LG tv / Humax video / Moto phone. Why are the Sonoff/ITEAD so difficult?

Philip Johnston.

I had he same problem when i first came here looking for a solution i think about page eight. I didn't find one so i figured it out.

Your switches are not locked, they are just unreachable by the app because when you originally connected them, it programmed them to respond to your old router. 

I suspect you did the same as me when you found out they didn't work, and that is deleted them from the app  expecting to just be able to reconnect them. The problem is that the app wasn't connected to the switches, so they don't know they have been deleted. 

The solution is a couple of posts up. Create a new account with a new email and you should be fine. I use alexa to control all mine, but if you only control them with a phone it's best to uninstall the app from your phone and reinstall it first, just so as to eliminate the risk of your phone automatically logging you back in to the app with the wrong credentials in future.

Philip Johnston.

One other thing. I have found it more reliable to pair your switches to the app on a phone as opposed to a tablet.

For some reason phones seem to be able to switch networks much quicker than tablets.

What happens when you pair a switch, is that your phone starts off connected to the internet. the app then tells your phone to go off looking for the switch that you have activated the local network on by pushing the button. Once it's found the switch, the switch cuts off the local network and your phone automatically reconnects to the internet. 

I've got 3 android tablets and only one of them automatically reconnects to the internet, the others just sit there with no network connected whilst the app timer counts down to zero. Then they say failed to connect.

You can see it happening if you watch your network symbol at the top of the screen.

This happens normally and is not directly related to your problem, but if it's happening as well as your problem it makes it really confusing.

Hi Steve I tried your solution, deleted devices using the old ssid, deleted app from my phone, got new ewelink account. Plugged in devices, they went straight to quick pairing mode ( seem to indicate a full reset ) Tried to pair using the new ssid, wouldn't pair, then went to compatible mode that seemed to go OK. But after WIFI re-re-connected, I got a slow flash (once every 2 seconds ) meaning no WIFI.


Then resorted back to original /old ssid/account and compatible mode to re-instate original set-up.

Hi Philip.

Couple of questions.

Were they actually working before you deleted them on your old ssid?

Did they work when you reconnected them to your old ssid after you had failed to get them to work on the new one?

Depending on the firmware in the switches, you may need to press the button two times.

If you power up and get a slow flash, push and hold the button once until rapid flash.

Once you get rapid flash, push and hold the button again until you get rapid 3 flashes and a gap.

Then try.

The important thing is if they work on your old ssid, to delete them and make sure they go back to slow flash whilst you have the app open. Also make sure that you take auto connect off any other ssid's that maybe on your phone, and make sure if possible that your old home network is removed from your phone and the new one is auto connect.

What maybe happening is that once the app tells your phone to go off and look for the switch, once it finds the switch and then goes to look for your home network again to continue setup, it may be looking for the old ssid instead of your new one because in the settings on your phone that network is auto connect and your new one might not be.

What i mean is get rid of auto connect for every network on your phone (Including Mobile) apart from your new ssid. That way the phone should only be able to reconnect to the network you want. It all happens quite fast, and it doesn't really give you time to fluff about with networks whilst you are trying to connect the switch.

Yes they were working fine on the old ssid, hence the apparent full reset. with a slow flash, and a quick pair flash on re-powering. after device deletion.


And Yes they reconnected to the old ssid after all my faffing about


Yes I have already found out all about button pushing, that is how you put the device into compatible mode etc.


I have been  making sure the phone is using the correct WIFI that I want


Just got a message from Norton to say that ewelink are doing data mining, may well take a Clarkson spanner (4 lbs hanner ) to these devices.

Hi again Philip.

Don't know what data they could mine, but they are Chinese. Not the flavour of the month at the moment.

I doubt thats whats stopping you connecting. For me it was just a case of persevering and being methodical.

I've got loads of these things, plus light bulbs, some of the Wessistein plug top switches. And i was really ticked off when mine packed up as well. 

I don't do gaming, but i have so many gadgets connect to my router that it couldn't cope. So i upgraded to a Linksys WRT32X gaming router just to get the bandwidth. But what i did do was use my old router as an extension off of my new one and put it in my barn, and all the switches in range of that didn't need reprogramming at all.

As i said in a post earlier and got shot down for it, this only seems to be a problem for a few of us. These things are so popular, that if it was a major failing the internet would be screaming about it. 

The only advice i can give is to persevere, once you get one working it all falls into place.

The other option that i would have tried if needed, is to take them round a mates and get him to create an account and connect them there and delete them and bring them home again. But i didn't need to do that.    

When ever I am worried that an application is mining data but I still HAVE to use it I simply revert to an old factory reset phone without a sim or contact list and only a blank, meaning not used for anything else, email account.  Does become a bit cumbersome but my data is safe. 

Login or Signup to post a comment