Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 


63 people have this problem

@andrejs

Try to create the same wi-fi network (same SID and same password, also, same security type) to your new route. Then, make sure that your devices are connected to the old router.

Turn-off the old router, turn-on the new router that already has the same wi-fi configuration.

This should work since the divices will look for the SID.

It worked for me.

I hope this can help you.

If anyone still have a problem, simply unplug turn off at wall switch, plug in, keep holding the switch and turn on to access boot loader. Then after 30 seconds let go and use your phone to connect. Worked for me. Thanks.

Hello guys! I could resolve this issue even with AES-security enabled... it was just a small detail. Please do the following:


  1. Delete your switch device if it is still present on your eWeLink app
  2. Force quit the eWeLink app
  3. Press and hold the button in your Sonoff switch between 5-7 seconds. The LED should start fast blinking 3 times and repeat
  4. Press and hold the button in your Sonoff switch again between 5-7 seconds. The LED should start fast blinking one time and repeat continuously
  5. Go to your WiFi settings on your smartphone
  6. Choose and connect to the WiFi that begins with 'ITEAD-100000xxxx' from your network list. This is your Sonoff device
  7. Enter default password '12345678'
  8. Launch your eWeLink app
  9. Tap on the + sign at the bottom
  10. Tap on 'Compatible pairing mode' at the bottom of the screen (this step is the most important)
  11. Tap on 'Next' button
  12. Enter your new WiFi network credentials
  13. Follow the instructions in the screen

This should solve the problem :) Repeat the same procedure for each switch you want to move to your new Arris modem.

Good luck!
Cristian

I had the same problem with a number of BASIC switches. Strangely when I shifted from my phone (Android 7.1.2)  to my tablet  (Android 8.0.0) the problem disappeared !!!

Hi I had a similar problem on some of my POW and T1 switches, this is how I solved the problem:

(I broke it down to changes on your phone , switch and tablet (hot-spot))


Phone: 

  • Remove all non working switches from ewelink app


Tablet: 

  • Setup old phone/tablet with 3g connectivity
  • Setup mobile hot-spot with new SSID name- the name has to be simple (no upper case characters, no symbols... i used test as my SSID
  • set password for SSIDto same simple format ie. 12345678 or passwordabc
Phone: 

  • connect to the tablet hotspot from the phone that will setup the new switch
  • disable mobile connectivity from your phone
Switch:
  • put the switch in compatible mode (press to connect button 5 seconds, release and press again for another 5 seconds  (light will be flashing fast non-stop)
Phone:
  • add new device in ewelink app by selecting compatibility mode (bottom of screen)
  • phone should detect switch and install

Once the  installation is done test the switch and update any firmware if needed 
Now remove switch from ewelink app and replicate above steps with  your 'normal' SSID

Hope you are sorted now :-)


1 person likes this
After being the 8th person commenting on this initial thread 2 years ago and having another 2 sonoff 5v inching devices fail today (PSF-B01 devices) after changing the WiFi SSID and password and still having the original failed device from 2 years ago, I can categorically say the ONLY way to recover these devices to a working state is to flash them with Tasmoto firmware. It's the first time I've used Tasmota as I've been a devoted user of ewelink app. Ok, so they no longer associate with ewelink but I'm so impressed with Tasmota that I honestly say why bother with ewelink? I'm an Alexa user and only control them through Alexa. Flash them with Tasmota, set them to emulate Belkin WiMo and they're directly discoverable in Alexa app. No need for any 3rd party cloud app to configure them. I'm extremely impressed with how easy it was to set them up I'm Tasmota. As previously stated, after changing SSID, I can no longer get them to re connect to ANY wireless network be it 2.4ghz, unsecured, tethered, previous SSID, no password, original wireless network, you name it. They have borked themselves. They will accept the new SSID and password and then register with ewelink but then NEVER connect with the new wireless network. No matter what I've tried. Suggest whatever you want to me to try but I'm telling you, I've tried it all. I have many other sonoff devices and had no troubles pairing them with ewelink app but these sonoff 5v inching devices just fail after changing their SSID more than a couple of times. Never had it with S20, L1, B1, mini or the newer S20 or the 12v boards. If you use Alexa to control your devices, you MUST consider using Tasmota firmware. I wish I'd tried this 2 years ago.

Gozzie0

I've never flashed any of my iteads and have managed to get them working fine.

The problem is when people change their router and don't remove the switches before hand.

Then when you try to connect them to your new router, they won't work.

The simple way that i do it is just create a second Sonoff account with a different email address' (just create one with your ISP). Then set them up as normal using this account. once they are working you can just leave them on this account or delete them whilst they are connected and then switch back to your original account and connect them as normal to that. I've got about 18 switches working at the moment and after having the same problem as everyone else, that was how i fixed it. 

Once you figure it out it's quite simple. It's also best to pair them with a phone and not a tablet, as phones can change from the iteads wifi to your home wifi faster than tables do. 

Steve, as I said, I've tried all of that before. Any way, you shouldn't have to remove them from an ewelink account just to reconnect then to a different wireless network. That's just bad coding. Even having to create a different email address is just sheer madness. What utter crap advice. I have over 30 sonoff devices and I've only had issues with these three 5v inching boards. All my other devices moved over to a new SSID without any trouble or trickery. I've tried every method mentioned on this thread since it first started over 2 years ago and nothing works except flashing them with Tasmota (or probably any other firmware come to that). If you've been paying any attention to my comments, there devices pair and register but then NEVER reconnect to my wireless or ANY wireless network after successfully registering.

Gozzie0'

I've got some of the 5/12v boards, and they have been the same. create a new account and they work fine. I also as it happens control them all with Alexa, i never use a phone to control them, just to add them.

I can't say I've been paying attention to your comments, i just get emails now and again from posters and just picked up your one today.

No one is stopping you flashing them with whatever you want, all i was offering you was a simple solution that works, and save you having to do that. 

I don't even see the issue as a problem anymore. What is actually causing it in the first place is the boards security, it's not going to let you change networks with the same account without first deleting it via your original network. Once you get your head around that it's not an issue.

1, Delete the original app on your phone.

2, Get a new email address from your ISP

3, Re download the Sonoff app and create a new sonoff account with that email.

4, Connect them via the phone, just as you would a brand new one out the box.

5, Once they work, delete them from this account whilst they are connected to it.

6, Log out of this new account , and re log in to your original Sonoff account with your original email and reconnect them as normal.

BINGO !!!

If you control them with Alexa, you may find that when you tell alexa to discover devices, and then try to control them. She may say that there are two devices with that name which one do you want?

Ignore that. Go to your Alexa app,  Down to smart home, then devices, then down to the bottom of the page and click forget all. Then either click Discover next to forget or just tell one of your echo's to discover devices, that will then repopulate this list with all your devices.

Most important when finished.

1, Sit down and chill out.

2, Have a beer and consider yourself triumphant.

;)

Steve, trust me. Everything you've suggested I've tried. It just doesn't work whether they've been used with Alexa or not.

1 person likes this

Gozzie0

Well our unlucky then mate, because it works for everyone else. This isn't the only place I've discussed it.

I was having the same problem but I sorted it as follows... 1. Power down the sonoff device. 2. Delete the device from your account. 3. Clear the cache and data from the app. 4. Power up the device and wait 30 seconds 5. Hold down button on device until it starts flashing. DO NOT continue to hold button after this point else it goes into legacy mode. 6. Start the app, log in and add device. All of my difficult devices worked first time this way... let me know if it works for you.
Might be dumb luck but I had a method work 2 out of 2 times today. I used the method it states to use IOS. I put my sonoff into compatibility mode. Chose the ITEAD**** number. Tossed in the pass word. And attempted to sign in. This did not work...but this made my phone ask if I wanted to connect even without internet. I accepted this and then tossed in the correct wifi info and bam connected. Though I had to jump out of the app and click my wifi again to get it to "reconnect to router" it actually went through. I tried for 2 hours in every mode I could and with all kinds of settings/restarting/different devices I could.
NECESITO AYUDA, POR FAVOR. Tengo el problema que el dispositivo se traba en el estado de "recuperando información del dispositivo". Son 3 minutos y se deconecta del movil. GRACIAS

Sorry Steve Christie, we're not unlucky, it seems you're lucky. Your method doesn't work for me either. I now have 6 Ewelink accounts with different email addresses, and I've tried on 2 Android and 1 iOS device, and no luck.


The device connects to my WiFi router (confirmed in the router software), but it can't seem to reach the mothership. Just keeps flashing twice every 2 seconds.


I also tried Neil Walker's and Ed Marion's solutions, same thing. My device has the correct WiFi credentials, and it actually does connect to the WiFi (although it pretends not to, the router confirms that it is connected).


Thanks for the tips anyway.

Login or Signup to post a comment