Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 


63 people have this problem

As some others reported pairing went o.k but the sonoff  TH10 unit would not connect to the wifi, Stuart Shaw suggested a method on this page which included turning of the router security setting, i did that and my  TH10 worked as it should !!.

I realised then it was a security issue I rechecked my setup of the ewelink on my android phone and found that the router wifi password on ewelink had an uppercase letter at the start(damn predictive text) whereas my wifi password is all lowercase .

I changed that password on ewelink to be all lower case and all is working , my thanks to STUART SHAW for pointing the way

I have about 15-20 Sonoff products and just recently bought some new ones. Never had a problem before... but now - definitely impossible for me to get the new ones working.  Since the old ones are behind a lot of switches everywhere in the house - I feel that is not an option to try to  re-configure them. The old ones are actually working very good! This is why I humbly ask for some support. 


The products I am trying to get working now are Sonoff S26 and Sonoff Mini. However, I run IOS and Google Wifi. 


I have tried to keep the connection to "Itead-XXX" by clicking on it as one proposed, I haven't found where to disable the security settings at the Google Wifi app. Nor at the phone. It loggs in beautiful at my wifi as usual.


But - using compatible mode, I can connect to the product, it finds it, states the brandname, then Registering for 1 sec to get to "add the room name/My device". It does not get green. Blinks green once every 2 second. Then at the Ewelink app, it states "Offline". Forever... :)


Please guide me, Gents, before I loose my mind! :-)


BR /Ola


"Michael Besse


Yes 3.1 i've seen it. 

Yes if you can connect to your iTeads you can change them. the problem has been when people have deleted them in the app whilst not connected to them. IE if their router has broken. 

When you connect to an Itead for the first time, it's your phone thats talking to it direct, not your home wifi. The phone or tablet then tells the itead what wifi it should connect to. The problem for people who have changed their wifi router, is that the phone telsl the itead to connect to wifi that no longer exists. What people are not noticing is that their phone changes wifi half way through the setup process, and talks to the iteads wifi network direct. If the preferred wifi network on your phone is still the old one that no longer exists the phone will still tell the itead to connect to it. "


Ola Hansson

A quick way but not the most convenient, is to just register another email address with your ISP and then register another account with Ewelink using the new email. You have to push the pair button, but a new account will find them straight away. 

I just registered another email address that i use for nothing else. 

Hello, I had the same problem of pairing. Then I tried with a hotspot from other Android phone, it paired well. Again I deleted the device and tried with original WIFI , it worked. Earlier I tried all methods, it was going upto finding the switch but not pairing with not Android as well Apple phone. But the above method of hotspot worked for me.

I had the same problem, tried everything. It would seem to pair, let me select the network and device name but would always end up flashing every two seconds and never connecting. I wish they just had a factory reset.


I contacted Itead three ways and just got the usual list of things to do which I'd done myself already. I suspect they just think I am using the same password. I bought a replacement and it worked first time which worked first time. My conclusion based on what I read is that if you don't delete the device from the application while it is online on the original network it will not connect to a new network properly, something remains set wrongly from the first install.


My solution - I installed using tuyaSmart which  seemed to work though I didn't try it I just went right back to the eWeLink app and it paired right away. 


1 person likes this

Richard - how did you get a Sonoff device to connect with the tuyaSmart app?  I though only Sonoff devices would pair with the ewelink app?  I have a Sonoff  5V device with the same symptoms you were getting.


1 person likes this

I just followed the Tuya instructions that match the compatibility pairing including the password of 12345678. I didn't actually turn it on and off just went back to the eWeLink app and it installed like new. 


1 person likes this

Solved: I've experienced this same issue. I bought two Sonoff devices and both were not connecting with my router TP-Link AD7200.

I was about to give up when I got an idea.

Solution:

I took a second cellphone and I used the hot spot function to route a wi-fi network. I configured the cellphone wi-fi with the same SSID as my tp-link router.

I disabled the main router and enabled the cellphone. I could pair quickly using the compatible pairing mode with the cellphone.

Then, I turned the Sonoff off, disabled the cellphone wi-fi routing and enabled my tp-link router.

As the SSID and password were the same, it connected and worked!

i had the same issue , today i have the breakthrough , just not use special characters in the password just user numbers and alphabets . my all devices are sync now  

tengo un problema al conectar un interruptor ya que no se vincula en la app es mas no pasa nada, alguien sabe como arreglar eso.

ya llevo 2 dias intentando conectar y ya estoy super fastidiado

Same problem. Pairs but fails to connect to any wifi, router or hotspot. Anyone can explain how to pair to tuyaSmart? It looks like a good trick. Regards Doron

I just ran the tuya software and did what it said to do to the sonoff unit.

But devices list in tuyasmart don't include sonoff. I tried other wifi devices and it fails...

Hi,


Since upgrading firmware to 3.4.0 :


All devices are disconnected from aps. I ve one in 2.0.0 Firmware : all is OK.

I erased all devices from my account. Pairing is OK, but can't connect to WIFI.

I use a simple SSID, simple password. I use WPA2-PSK/AES encryption.

All SONOFF (2 CHANNELS) are blinking 1 time per 3 seconds.


Like DORON, tryed tuyasmart => non response in automatic detection or other manual choices.


Also, tryes to pairing et connecting devices on another AP (Smartphone) => devices stay in the same blinking mode.


Ideas ?


Regards.





i have some problem. 3 different routers all 2.4G and there is problem that sonoff products (I have about 20 different products) dont want to connect to new router. some of them are all time disconnecting. I was trying all here is written but it didn help. I dont know what to do. i think there is some coding error or bug in sonoffs' wifi module.

Login or Signup to post a comment