Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 

74 people have this problem

I have the same issue, I have nearly 20 Sonoff devices and after changing my WiFi network setup have had a lot of trouble getting my devices to reconnect. I am now down to the last 3 devices, all of these are the 4 ch New Smart / G4 devices. I have 4 of these, and 1 of them connected without issue. On the last 3 I have tried everything suggested above and more. I can connect them to my old WiFi first go every time, I delete them from the app while working, but no matter what I try they won’t connect to my new WiFi network. I have now ordered new ones to replace them, even though they are fully serviceable when used with my old network, the time I have wasted far out weighs the cost.

1 person likes this

I have tried everything you guys have tried and found the solution that worked for me. From what i saw on the wireless network when you added a new device through the app, ITEAD-***** would appear on the network as connecting which means the device was communicting during pairing. What happened to me was during that time the device was registering, i noticed that my network would auto reconnect like it was supposed too. but what was really happening was the registration process was not completed.So as many of you out there ,device said it was offline and i would try over and over deleting device and starting over.What you have to do is when you see the device network connecting , keep your network from auto connecting by tapping on the device network and keep it online just for a brief ammount of time.When you see your device turn full green ,you know its connected now and is a good time to update the firmware. I am not a very tech savy person but hope this will help out.

1 person likes this

ah, funny enough, after one day of attempts with different modems getting results similar to the majority read above,  I found that  disabling  the wireless security keys fixes the problem instantly. That causes indeed another problem... there should be some modem setting to make the network hidden, or point-to point with the Sonoff only and not all the world outside.... Does anyone have suggestions for this? Thanks

Don Smith probably has the answer for most. Unlike him I think I’m slightly tech savvy. I never even noticed my phone reconnecting to my router half way through the set up process. I disabled the the auto join/auto connect option on my phones Wi-Fi setting. First attempt it worked. Sonoff are back in the good books. 


It's not a problem. Once you have it connected without security enabled, delete it again whilst connected to it and reconnect with your security setting enabled again. The problem for most people is that they are deleting the iTeads from the app after they have changed their router. So the iTead doesn't know it's been deleted because it was not connected at the time.  

1 person likes this

Al Mc

I did explain this in my post on page eight of this thread. 

1 person likes this
Steve Christie, sorry, must of missed your post. VFG
I had tried every suggestion in this thread plus some. A few days ago itead released a firmware update. I connected to my old WiFi network, installed the update. Then connected to my new WiFi network first go, no need do do anything special, didn’t even delete from old network or app.

Michael Besse

Yes 3.1 i've seen it. 

Yes if you can connect to your iTeads you can change them. the problem has been when people have deleted them in the app whilst not connected to them. IE if their router has broken. 

When you connect to an Itead for the first time, it's your phone thats talking to it direct, not your home wifi. The phone or tablet then tells the itead what wifi it should connect to. The problem for people who have changed their wifi router, is that the phone telsl the itead to connect to wifi that no longer exists. What people are not noticing is that their phone changes wifi half way through the setup process, and talks to the iteads wifi network direct. If the preferred wifi network on your phone is still the old one that no longer exists the phone will still tell the itead to connect to it. 

Steve Christie, You were right! They both work now. Many thanks!! Gm

After buying five "BLue 50 SX1" devices on Ebay I had trouble connecting them initially - Which as a network engineer is never a good look :-)

They're not intuitive but I found the following will get these working:

Firstly, disable the 5Ghz side of your wireless network - You'll need your router manufacturers instructions on this. This should leave the 2.4ghz network running (check that you have it!) - These devices will only connect via 2.4ghz networks.

Secondly - Open up your wireless security (ugh, I hate this part!) Disable any security on your wireless network (including making sure your SSID is not hidden) and then login to that open network using your chosen device (phone etc) that will run the eWeLink app. I was using a Sony Android phone for this so cannot comment on IOS.

Thirdly - press and hold the button on the plugs until flashing etc, open up the app, add a device in 'quick pairing' mode and it should start to find it. Once it adds it, rename it, add any others you have and test them all to ensure they're working.

Fourth - Assuming this worked for you, re-enable the network password on your wireless network. You then need to re-attach your phone to that network using the secure password, then go round and add the devices in 'quick pairing' mode again (They will be found this time I hope!) - Once they've been attached again I returned my SSID to 'non-visible' as before and they continued to work OK.

And after writing all of this I've just realised I need to now re-enable the 5ghz portion of my network...Back shortly!

I have a 2.4 and 5 GHz router. And it did not work, using 2.4, obvious. I used the hint of switching from WEP2 to WEP, that's it, and it worked. thank you.

I had the same problem and sharing what I did to fix the issue hoping this works for others as well. 

The Sonoff 4ch Pro R2 I bought from Amazon came with an older firmware which did not connect to any of my wifi SSIDs. Then after mingling with it, I figured, out of the box and for the first time connecting to a wifi network, I had to change the security mode of my wifi network to "No Security" or WEP and then do a manual connection on the eWelink app. Once my 4Ch Pro R2 was connected to the network, I updated the firmware and then changed my router back to WPA2 PSK security option. and after restarting 4CH PRO R2, it is still able to connect to wifi.

I was having the same problem but I sorted it as follows... 1. Power down the sonoff device. 2. Delete the device from your account. 3. Clear the cache and data from the app. 4. Power up the device and wait 30 seconds 5. Hold down button on device until it starts flashing. DO NOT continue to hold button after this point else it goes into legacy mode. 6. Start the app, log in and add device. All of my difficult devices worked first time this way... let me know if it works for you.
I have the same problem. I have one device connected ok but two others won't after pairing successfully. Same sonoff basic but the firmware of the two which won't connect is completely different.
Login or Signup to post a comment