Start a new topic

Problem with zero centigrade temperature reading on TH10

On firmware 2.0.1 my temperature sensor would not show any temperature below 1C. At zero degrees it showed '00?C 00F' and then the sensor readouts would vanish.

Firmware 2.0.2 has partly fixed the problem so that negative temperatures will now display, but at zero it goes crazy and won't display (sensor not detected).

I think this must be a 'divide-by-zero' problem in the software. Please fix in firmware 2.0.3 release.

4 people have this problem

I have still this problem. Is there any progress? My current firmware is 2.0.4 on TH16.

1 person likes this

I had the same problem with temp+humidity and also temp. sensor.

Problem is solved with firmware 2.0.3


Following up on this;

My problem was with a temperature+humidity sensor. I tried using a temperature-only sensor and it has no problem, reading correctly at all temperatures.

A friend then tried my temperature+humidity sensor with his Sonoff TH10 and got the exact same problem at 0C. It is clearly the temperature+humidity sensor causing the problem.

Problem still occurs as the Temperature/Humidity probe passes through zero in either direction.  It briefly displays 00C and then looses connection with the sensor.  Once the temperature enters positive or negative territory, it reconnects after a time interval of variable length.

Same problem here, with firmware 2.04. Loose sensor on 0 degrees.
sonoff th problem.In the temperature between -1 to +1 failure of the sensor of temperature and humidity sensor. .Tried to 3 pieces, the same result. Firmware 2.0.4
Login or Signup to post a comment