Start a new topic

Cannot pair wifi smart switch

I just bought six Sonoff wifi switches but I can't get them to work. When I try and pair with the Sonoff I get the "incorrect password" message. I am using 12345678. Or it accepts the password and connects to the Sonoff itead wifi for a few seconds and then disconnects.

I have tried with two of the switches and get the same problem. I have looked at the itead guide and FAQs. I have raised a help ticket but am not getting a response. Can anyone help or give me advice?

19 people have this problem

Il DNS lo devo cambiare sul mio router ?

Ho un sonoff basic registrato correttamente al server tramite il mio web pocket. Ora volevo registrarlo nel router ma mi da continuamente errore. Sembra voglia funzionare solamente con il web pocket. Cosa posso fare ?

With a lot of patience and after a lot of fiddling, I have managed to get my 3 Sonoff S20 plugs and 1 Sonoff smart switch working, thanks to some advice from this forum. These are the steps I followed. It did help taking the smart switch close to the router. I have an Android Phone.

1. Set my phone to Aeroplane mode and turned on my WiFi;

2. Paired my Sonoff device directly through the phone, outside of the eWeLink App. Username: ITEAD.... and Password: 12345678. I waited till the device said "Connected, No Internet";

3. Opened my eWeLink App;

4. Long pressed the pairing button till it fast-blinked;

5. Added a device In the eWeLink App and selected the pairing as per the type of blink - in my case I had to use "Compatible pairing mode (AP)";

6. The app finds the ITEAD device, connects with the server and then registers the device. Note: I had to do this step several times in some cases. Sometimes it goes straight through. Have a little patience and try it a few times.

7. Once registered, it takes around a minute after which the green light is steady. 

Hope this helps. I must admit I was getting a bit frustrated, but decided to persevere and it paid off.

Good luck!

1 person likes this

We at D-link customer service believes in customer satisfaction and our first priority is to treat their problem like our own. We are having team of dedicated and well-qualified problem resolving personal assistance team so, that user's doesn't face such issues in future.

So I was having the same issue with a 4 channel switch, I could get it to pair but not connect with the router or internet after changing my WiFi network around.

I saw a comment about the Sonoff devices getting "locked" to a particular router above somewhere and it turns out correct.

I have a mesh system and an outdoor AP but once I'd turned everything off except the particular router it was connected to previously it connected first attempt and has been rock solid for a few days now even after a couple of power cycles with the other routers back on.

A right pain in the arse and it needs sorting but at least it's working again.

Thank to whoever it was that mentioned it.

I registered an account just so I can help others on getting a Sonoff paired.

After trying for hours and using AP mode, pairing from fresh power up, trying to pair to WiFi without special characters in, pairing to a mobile phone hot spot, etc. etc.  The ONLY thing that worked STRAIGHT away, was to put the phone into airplane mode, then only activating the wifi to connect with home router, then running the app to pair, and it works!!

1 person likes this


Irwin.coelho thanks so much for posting that procedure. I have tried it but these units are so hit and miss. I have 2 that I bought from Gearbest which I have not been able to successfully connect however I just got one today from another store and it worked first go and has been behaving all day. I'm wondering if some of these units are dodgy or old versions? Weirdly the one I got today has no Sonoff branding on the actual unit or on the box yet it works!

Irwin.coelho - just in regards to your steps above the only way I can get the iTead wifi to show is to long press the unit's button. Then it takes forever to obtain an IP address. You have said to long press the button after connecting to the iTead wifi though? Could you clarify those steps?

Thanks so much for your help.

Ok this is weird and may be an anomaly but I just managed to get the two s20's that were not pairing to work. The only difference this time was I used a power extension lead. I can't imagine how this may have helped but the first worked and so I tried the second straight after it and it paired as well. Both paired immediately without me having to connect to the iTead wifi etc. I have noticed that the design of these units are upside down for Australian users at least as the main part of the unit pushes in against the on/off switch of the wall power point. The extension cord helps to prevent this but again I can't see how that would help pairing. Anyway if you are at the end of your wits trying to get these work, it can;t hurt!!!


I did just see a message on the app saying they were upgrading the servers please wait don't know of that effects you guys?

Well this is getting weirder. I tried plugging in one my newly paired units directly into a wall socket and it would just blink and not connect to the server. I then plugged the same unit into an extension cord attached to a wall socket and it connected! I'll do a few more tests tomorrow to see if this is repeatable, however odd it seems.

I am having the same problem as all of you. Unless I have missed it, has anyone brought up the fact that the Sonoff does not work with 5MHz Wifi? My current WiFi is 5MHz and I noticed that there is a note on the setup screen that states Sonoff is a "2.4MHz system only" or something to that effect. I am about to setup my old WiFi router (2.4MHz) and test it out.

I'll connect when I have something more to add.

Read the thread through before you do that, the 5ghz issue is well known

Dopo ripetuti tentativi sono arrivato alla conclusione che:

  1. in presenza di un device mai registrato, quindi nuovo, l'accoppiamento è immediato e avviene al primo tentativo
  2. se il device è stato registrato su qualche rete, pur preventivamente cancellandolo, l'accoppiamento è molto difficoltoso, bisogna provare e riprovare parecchie volte affinché l'operazione si concluda con successo.
Probabilmente, anche dopo la cancellazione, nei server rimane qualche traccia che impedisce il normale accoppiamento.

Switching to Airplane mode also worked for me. Connected and paired quick quick!

Grazie Hans, ma anche in airplane mode il pairing é sempre difficoltoso
Login or Signup to post a comment