Start a new topic

Cannot pair wifi smart switch

I just bought six Sonoff wifi switches but I can't get them to work. When I try and pair with the Sonoff I get the "incorrect password" message. I am using 12345678. Or it accepts the password and connects to the Sonoff itead wifi for a few seconds and then disconnects.


I have tried with two of the switches and get the same problem. I have looked at the itead guide and FAQs. I have raised a help ticket but am not getting a response. Can anyone help or give me advice?



14 people have this problem

Hello guys,


I Have 4 sonoff switch and 2 sonoff Th switch on my routeur and all is all right since 1 year (approximatively).

For using my Xiaomi mi robot vacuum, I need to change WEP protection to WPA protection.

I did it and the 4 sonoff switch works good but impossible to reconnect my 2 sonoff TH....


What can i do? I try lot of manipulation and nothing works...

Thanks in advance.

I have downloaded iOS 11 before the native release on my iPhone. and I also having trouble of after installing iOS 11 Wi-Fi not working my iPhone. But on Google I found a solution to solve the problem and got rid of the problem easily.

- 1. Disable and Re-enable Wi-Fi Trigger

- 2. Reboot Your iDevice (iPhone)

- 3. Forget Wi-Fi Network and Rejoin

- 4. Reboot your Wired / Wireless Router/modem

- 5. Delete VPN App and test Wi-Fi again

And more information here - https://www.howtoisolve.com/fix-wi-fi-not-working-ios-11/

Hi All 

I think I found a way to pair a Smart Sonoff 'touch' switch and it also works for the Sonoff TH10 switch that I had trouble unable to pair up and configure in the normal manner.


I noticed that when you power up the unit, and then hold the button to put into pairing mode, the LED flashes in its normal pairing mode for that type of device, however - continue to hold the button until the LED starts to flash fast continually (with no pauses) - this can take 10-30 seconds. Then you will notice that on your smartphone/ipad/android, that the "ITEAD....xxxxx"  SSID HAS APPEARED!.


then use the pairing function of the 'AP' or non-touch pairing mode to configure the device.

this worked in both cases with these two types of devices after I had exhausted all other options mentioned in this thread above.


I hope this helps for you!

SONOFF switches also works with me for approx. I tried 10 times for pairing and then accepted the password 12345678.

Much patience is needed. :)

Thanks for the previous posts.

I've the same problem, first time pairing worked like a charm, having another SONOFF in my network, unfortunately suddenly stop to work, so I removed the switch from the App but this time I couldn't pair anymore. I've explored all the different workarounds over here... (other phone, connecting thought the PC, assigning a static IP, everything and nothing worked). I think the firmware/memory got some corruption that's why the device can't offer any IP. Is there any way to reset to defaults / flash again this little paperweight? Thanks for the help.

For re-pair that sonoff you may do th folowing: 1.remove the sonoff from the app. 2.put the phone on airplane mode 3. Activate the wifi on the phone 4. Pair the device as instructed 5. Good luck

Thank you Gal, I've doing it the Airplane mode trick, but the ITEAD-xxx SONOFF's hotspot fail offering an IP to the phone, so isn't possible further that point that the phone/app interact with the device, I've also try assigning a 10.10.7.x IP address but it fails too. I've tested it in three different phones (android and iphone)and a tablet with android, each of those with the same result.


I'm pretty sure is a device problem, so I was looking forward to inject this firmware: https://github.com/arendst/Sonoff-Tasmota


Anyway I'll keep an eye if there is a new update from the other guys affected by the same issue.


Thanks,

Diego.


 I may not be a computer 'buff ' but I'm not stupid either but the sonoff range is F@@@ing useless the instructions I'm following word for word still can't get it (son off dual) to link .


Support ???forget it there is none 


Just says make sure in pairing mode , check correct password ....nothing... got them from Amazon ...their going back DONT BUY they work for on or two days , go off line for no reason and you can't get them back ,,,be warned ....useless 


1 person likes this
I got mine from ebay and they were cheap.  After reading through this forum and hearing everyone elses opinions, I must say that these devices are flaky at best.  I have 3 of them and I've managed to get one to work paired to my android phone and also one to work on one of my home routers.  That said, all 3 do not work when trying to connect to my UBNT access point.  I event went as far as to go buy a $30 access point for testing and they all failed to connect to it also.  I'd agree with the above comment - I wouldn't buy them again or recommend them to anyone.  Its important to note that the concept is excellent, but where a product has little or no support and works when it wants to or you have to try 2537253727 times in 263652828 different ways and it "might work"??  Its not worth the heartache or the time to try.  Just from a log point of view - the logs on my AP's don't event show the devices trying to connect so clearly theres a problem that needs to be looked at there.  For those who do buy - good luck with it

 

I had the nightmare not being able to connect the second switch but then I saw a comment on the youtube video about switching airplane mode on and it worked straight away.

Puting my android phone in plane mode and then activate WiFi solved the issue for me also.

I was unable to pair at first. After reading Lacko's and Victar´s comments, I checked and the wifi network was not showing up. So I kept the setup button pressed until I heard two beeps (which should mean that the configuration had been reset) and voilá! The wifi network showed up and the app recognized the device.


Thanks, guys!

 

Gal Boaz
said 10 months ago

 

Ok guys, i think i have something: After not abling to pair the device with my phone for many times, i entered the phone into airplane mode and than activated ONLY the wifi and guess what? It works like magic! The app paired the sonoff in few seconds...



worked for me too.

thanks mate.

I have the same problems once it was changed to another WiFi it stooped working ..it seems may be data error ... pairing well but doesn't connect to any WiFi not even the first one.

Hello, I paired two of the sonoff wi-fi smart switches. But one of them doesnt work correctly. So I removed this switch from the app and try to pair it again. The App just said: „incorrect password“! After I‘ve tried again and again and again, I try the following (and it dos work for me!!): I disconnect the device completly from electricity. Then plug in again, let the green LED flash one time and then I press the Button for 10 seconds, I released it and press it again for 5 seconds so it will flashing that fast for the pairing. Now the password works and successfully I can pair it again!! Ich schreibe so schlecht in englisch, daher nochmal fast genauso schlecht auf deutsch: Switch vom Strom trennen, kurz warten und Strom wieder einschalten. Dann sofort nach dem ERSTEN Aufblinken der grünen LED den Taster drücken! Ich habe den Taster dann für circa 10 Sekunden gedrückt gehalten. Da sich dann an dem Blinken nichts änderte, habe ich den Taster kurz losgelassen und dann nochmal für circa 5 Sekunden gedrückt gehalten. Dies hatte zur Folge, dass die grüne LED in diesen schnellen Blinkzustand wechselte, der ja dafür da ist, dass man das Pairing erneut vornehmen kann. Sodann konnte ich mich in das WLAN des Schalters einwählen mit dem Standard Passwort von 12345678!!
Login or Signup to post a comment