Start a new topic

Cannot pair wifi smart switch

I just bought six Sonoff wifi switches but I can't get them to work. When I try and pair with the Sonoff I get the "incorrect password" message. I am using 12345678. Or it accepts the password and connects to the Sonoff itead wifi for a few seconds and then disconnects.


I have tried with two of the switches and get the same problem. I have looked at the itead guide and FAQs. I have raised a help ticket but am not getting a response. Can anyone help or give me advice?



16 people have this problem

I had the same problem. I spent 3 weeks trying. One evening, I disabled the antivirus on my phone and restarted the phone and the problem was resolved. I then restarted the antivirus. I would also recommend switching off any VPN software while doing the pairing as well

Puting my android phone in plane mode and then activate WiFi solved the issue for me also.

You have a iPhone or android? With android, you do not connect directly to the itead-wifi.

If you have iPhone: the itead-wifi is only for pairing. The ewelink-app sends the name+pwd of your wifi to the sonoff device using the itead-wifi for a few seconds. When this is done, the itead-wifi is no longer used.


Switching to Airplane mode also worked for me. Connected and paired quick quick!


Gal Boaz, Thanks - changing to flight mode solved the problem. After I did that, I could add the device. But there were other problems like sonoff going offline after a single operation (switch on). But upgrading the firmware solved that as well. Now my sonoff works like breeze! Thanks a lot!!
Hey Gal Boaz, I tried Airplane mode but it didn't work. I was able to see the network after doing this but unable to pair my device. What phone are you using and what iOS are you running?

 

iam the same case, i buy serven switch buy not conect in to wifi, i Has done everything guided but Still can not conect to wifi, who have video  guide conect switch to wifi please sent to me, thanks

Great!!

 I've been struggling to connect to my switches for ages after purchasing 3 of them. Tried everything in multiple forums, etc.


Finally used my child's Andriod phone (I have an iPhone) and it worked perfectly.

I have downloaded iOS 11 before the native release on my iPhone. and I also having trouble of after installing iOS 11 Wi-Fi not working my iPhone. But on Google I found a solution to solve the problem and got rid of the problem easily.

- 1. Disable and Re-enable Wi-Fi Trigger

- 2. Reboot Your iDevice (iPhone)

- 3. Forget Wi-Fi Network and Rejoin

- 4. Reboot your Wired / Wireless Router/modem

- 5. Delete VPN App and test Wi-Fi again

And more information here - https://www.howtoisolve.com/fix-wi-fi-not-working-ios-11/

Grazie Hans, ma anche in airplane mode il pairing é sempre difficoltoso

I had trouble pairing & finally  put the phone & TH16 within a few feet of the router & it finally paired.

So I was having the same issue with a 4 channel switch, I could get it to pair but not connect with the router or internet after changing my WiFi network around.

I saw a comment about the Sonoff devices getting "locked" to a particular router above somewhere and it turns out correct.

I have a mesh system and an outdoor AP but once I'd turned everything off except the particular router it was connected to previously it connected first attempt and has been rock solid for a few days now even after a couple of power cycles with the other routers back on.

A right pain in the arse and it needs sorting but at least it's working again.

Thank to whoever it was that mentioned it.

Im having the same issue here. The sonoff dual worked correctly, but with the standard sonoff i'm not able to connect to wifi for pairing using the 12345678 password Any updates?
If you are using a modern router THAT AUTOMATICALLY sets the wifi connection using 2g of 5g, YOU MUST log into the router, goto wifi settings AND TURN OFF 5g. Then and only then will you be able to connect your device. I strongly suggest you disable smart wifi and convert back to basic eg. Router 2g and router 5g wifi ssd’s for years of trouble free use.
Login or Signup to post a comment