Start a new topic
Answered

Problems pairing RF remote controller with Sonoff RF

Hi,


Could someone help me, I have a Sonoff RF it pairs correctly with WiFi and I can use it with the APP.

I cannot put it in pairing mode with RF controller. Tried with 2 clicks on set button, but the red light never turns on as it says on the manual.


Made a little video of my trying to get it to pair

https://youtu.be/5ZkQcTnnHK0




Best Answer

I too have the same problem... and last name. Did you find a solution? My ticket is still open with no answer from ITEAD.


2 people have this question

For me it stopped working after updating to 3.0.0.

What is your sonof rf software version?


1 person likes this
I have the same problem. Can't pair my autogate remote with RF433. Anyone manage to get this solve ?

Hi,


if module does not work as he should, you should first look at solder joints, i finded this is major problem. 


As you can see on the picture, one of the pads on IC was not soldered. Module now works ok.


For soldering always use leaded tin. ROHS sucks!

image

Hi,

I found then for star pairing (without opening), I have to press 10 seconds the Sonoff button to get into pairing mode, then press two times quickly and finally press then remote RF until a red blink is seen.


It is more clearly explained in RF pairing to remote.

Hi,

i had same problems with pairing. Sonoff instructions werent useful.

 

I spent few hours to finely get some results.

 

Pressing the black button on the device didnt work for me in any way, so i opened (be carefull, mains 230VAC can kill you) the device and pressed square button on RF reciever for a few seconds, till red led (integrated in green led) lites. Then i pressed button on transmitter and holded it.Red LED started to blink, first slowly, than fast. At that point, red led starts to blink fast every time i squeeze the button on transmitter, but the device does nothing. Now i pressed black button on the device 2 times, as fast as i could, then i waited till red led blinked once and pushed button on the transmitter. I heard relay clicked.and red led blinking. Damn thing finally started to work!!! Everytime when i started this procedure, i pressed black button on the device three times to erase previous record.

Do not disconnect the device during procedure.

Do not open the device if you dont know what you are doing - it can kill you!!!

I hope i did help somebody.


I would like to thank you all  for the information. 

I don't have to add any further knowledge to subject. I can only say that I tried to pair my cheap RF Rgb led strip controllers and I was able to pair some! 

Hi, everyone.

Before I've paired my sonoff rf with ewelink I could always pair it with remote. After 2 clicks on set button red light was on for a short period and there was no problem with pairing. Yesterday I've noticed that when the sonoff is paired with ewelink and connected to wifi this method (2 clicks) doesn't work. What's interesting memory cleaning (3 clicks) works OK.

I've discovered that you need to power off the device (pull out the plug) for a few seconds. Then before it connects to wifi try method with 2 clicks. It always work in my case. I shouldn't be like that but it is some kind of solution.

Hello everybody. The problem are the remote controls. The sonoff modules are OK. Don´t waste your time waiting for the red led indications because the green light is much more stronger and red led is imperceptible. If you remove the cover and look directly the led you can see the diminute red point flashing inside the led,

 

I had RF problem with 4 Sonoff RF modules and after test several remote controls all modules are working fine with te same good control.

Thanks for the update ! 

I don't know, but I suspect that the receiver has more than one chipset that allows it to decode various chipset protocols. I would need to research this. But right now my Sonoff remote problem is solved - it appears quite limited in its ability to receive.
Very interesting. I see the one that I couldn't pair was a HCS530 or something. Just a question though - how are, for example, garages motors able to pick each up all the 433Mhz regardless of the chip?

OK, I pretty sure I've found the problem pairing remotes. After researching remotes I discovered that although they transmit at 433MHz, they have different chipsets which have different transmission protocols. 


The remote chipset that works with the sonoff is 1527. I have two remotes which I have successfully paired - HS 1527 and EV 1527. If you open the remote and look for the IC chip, it will have markings and there should be a 1527 on the chip for it to work. See photo attached.


(There may be others that are compatible. I was sold 2 remotes with "PT-2260", which did not work)


Hope that's useful .......

Yes, as far as I know it's the latest firmware. I'm pretty sure I checked when I was doing the pairing. 


I'm using both "Sonoff RF" devices to control outside lights (BBQ and Porch). Remote from house and web app from outside (from car). Both are now mounted - one inside a wall cavity behind indoor switch and the other in a junction box on an outside wall. Both working ok, although remote range could be a little better.

Ah - that's quite unsettling. 


I've got interest in a few Slampher / remote control units for security (specially those that don't want to make use of an app or Smartphone). 


Guessing the latest firmware as well?

Hi Grant, I thought that any 433MHz remote would be able to be paired, but I tried a a number and had success with one (but not those supplied). I suspect there are different communication protocols, but have not researched this yet. (I'll keep this blog posted if I come up with anything). The one that worked had four buttons, and I could pair with any of the four. As a result I have both Sonoff RF devices paired with the same remote and use two of the four buttons.


I haven't tried it but I can't see why one button should not be able to control multiple Sonoff (and other) paired units. One is a transmitter (the remote) and the other a receiver (the Sonoff). I'll give it a try a and post with results.

Login or Signup to post a comment