Start a new topic

SONOFF device always offline

I've ordered 3 SONOFF and tried to associate them with my eWeLink account.

One of them always appears offline and I don't know what to do to solve that.

It's necessarly a problem with this device (or my account) as the other ones work well.

This device is well detected on my local network, but the LED keep blinking twice and repeat.

Maybe it's linked to the firmware upgrade that failed before.

34 people have this problem

Hello DI'd u find a solution ?

3 people like this
Dear sir,
  I have purchased your device as per above PO, i have uninstalled app and  device also, all are not workins its showing always showing offline kindly let me know. what it the problems.


My sonoff TH was working perfectly. But, since one week, keep getting offline/unavailable...

3 people like this

So seems many user here and there can't get there device back online. Where is the support ? Mine keep getting offline since few days. When it's about to sell there product Itead is there, but when consumer need support nobody's there !!!!

I've buy almost 10 sonoff to control my electric warmer because seems to be a good products... I worked 2/3 weeks and...then... server offline... Thx itead !!!!!

2 people like this
Check if fw version is reported. ItEads keep telling me to 'follow instrucions'. They are dumb.

1 person likes this

Firmware version is 2.0.3

Last evening I tried to remove the devie from the app ewelink and restarted the setup adding it as a new device. Seems to have solve the issu. My device is online since that moment.... we'll see if it's still working in few days

When fw version is not reported It looks like device go crazy. Oddly, there no way to update fw manually. As far as I know

1 person likes this
My sonoff worked for about 4 weeks then it show off line. I tried to delete app and then added device still not worked. When I added device, it show that password 12345678 is wrong.
(77.7 KB)

1 person likes this

I had a problem setting mine up, because the iphone was capitalizing the first letter of my wifi password.  It would say success, but my devices never came on line.  Double check you password field when setting up a device.  I had to add a dummy letter, let the iphone capitalize it, type the rest of my password, then delete the capital.

Bought sonoff installed it as per instructions ...then says ' off line ' tried three times to install says device elreadt installed ... told to power unit down , wait ,then power up and all should be ok but still 'off line' what am I doing wrong ?????

1 person likes this
lots of questions but no answers.  I have  2 switches that say offline.  isn't there something to do get them to function?  Watched the videos on You Tube.  They make it look so easy, I follow what they are doing but mine remain OFFLINE.  HELP please.


1 person likes this

1.Try to make your cellphone as a hotspot(wifi source) to connect device.

2. Please feedback this issue on ewelink "feedback".

3. Try to ping our EU), US).

4.I will answer you in fourm,have better make a ticket on our website:

To make my phone a hot spot it has to use the limited data plan from my carrier. Would prefer to use my internet access I have. Tried to pair the two switches I have and they still remain offline. Questions. 1. If I somehow put the switch on the wrong mode is there a way to check that and make sure it is in the correct mode? 2. I have two switches on my phone from an another company (they work). Would their software interfere with your software?
i did the ping thing all is ok.
The big thing at the CES gathering this year was Home Automation.  I am trying to get into it but purchased itead stuff and it doesn't work and itead doesn't seem to have a way to make it work.  Don't you folks see the future business there are millions of things to turn on and off.  Someone there should be very concerned that the stuff you sell doesn't work.  The only solution I am getting is.  Oh well, sorry we want it to work but we don't know how to get it to work.


2 people like this
Login or Signup to post a comment