Start a new topic

SONOFF device always offline

I've ordered 3 SONOFF and tried to associate them with my eWeLink account.

One of them always appears offline and I don't know what to do to solve that.


It's necessarly a problem with this device (or my account) as the other ones work well.


This device is well detected on my local network, but the LED keep blinking twice and repeat.


Maybe it's linked to the firmware upgrade that failed before.


33 people have this problem

I have the same problem. All of my 11 th16 went offline. Nothing helps, I don't know what to do

1 person likes this
Hello, I have the same problem to a new one TH16.
After some troubleshooting, TH16 is trying to connect server 52.28.157.61 port 8081, but this server doesn't respond to that port. Maybe service is down at server.
Server is replying to ping.



2 people like this
Just received 4 Sonoff th 10s. All of them appear offline. 2 fast led blinks every second. I tried all the suggested fixes (connect through phone hotspot, connect through another router, change dns servers etc). No luck! I was never able to make them work. I just received them yesterday. I hope the support team is reading!
Hello, I have a same problem with Sonoff TH10, I have 3 pcs and all of them show DEVICE OFFLINE, the rest of my sonoff product work just fine, only this 3 show this offline ???

 

I signed up to this forum just to add to the people having issues.  I purchased Sonoff POW and tried both methods of getting online - using the cell phone, and two different routers.  Nothing is working.  So I figured I got a bad unit and a new POW from ebay arrived and the same thing is happening.  Pairing goes great (using IOS) and then nothing but flashing twice blue led.  I really hope someone is watching this thread and will fix it.  Otherwise they are going back.  If I had local access (without cloud) I would keep them, but being forced to use the cloud makes these items worthless when service goes down. 

Thank you.

THE SOLUTION IS:

 

Substitude IP address of eu-disp.coolkit.cc to 52.29.61.50

 

Right now for some reason current eu-disp.coolkit.cc IP doesn't accept connection to 8081 port, but the old one - does. You can check it by:

current:

telnet 52.28.157.61 8081


old:

telnet 52.29.61.50 8081


SOLUTION

Here is an example how to make a substitution in Mikrotik router:

Open Winbox

Get to "IP > DNS" menu

Click on "Static"

Click on "+" (add static DNS entry)


Name: eu-disp.coolkit.cc

Regexp: <leave empty>

Address: 52.29.61.50

TTL: <leave by default [1d 00:00:00]>


Click on "OK"

Close the DNS Static subwindow

Click on "Apply"


Profit! Now your POW is online!


2 people like this

 

I am two days ago trying to connect the sonoff pow and nothing, connects to the router but does not access the server. The other sonoff basic devices that I have normal function. The worst part is that there is nothing from the tour.

Thank you Ivan for the information and you are correct (tested with telnet) - unfortunately my cheap airport extreme does not allow this functionality.  I can just hope that they fix the server someday.

Do you know how to make this change in the Linksys E900 router?

 

Ivan, I sent your solution to ewelink fb acc. It seems that they are willing to solve the problem too

Good news.....my POW just turned solid BLUE and is working and showing online on my phone!  Thank you all for helping and have a great holiday season.


Goods news too... ITED set me mail:We have do some change on our server,can the device be online? please try. -------- Yes I check it and confirmed that my SonofTH16 is ONLINE and working perfectly!!!!
Finally working, now is everything OK :)

 


1 person likes this
Make sure you are connecting to 2.4GHz not 5GHz. I kept adding new device to a 5 GHz Band and then it would add device and show offline status. After I deleted the device then re-added the device to a 2.4GHZ band it worked right away. Hope this helps.

i have the same error, can anyone explain to me how can i do? i have 5 sonoff and anyone is working, app show network error, i don't understand solution explain by ivan, please help me

Login or Signup to post a comment