Start a new topic

SONOFF device always offline

I've ordered 3 SONOFF and tried to associate them with my eWeLink account.

One of them always appears offline and I don't know what to do to solve that.

It's necessarly a problem with this device (or my account) as the other ones work well.

This device is well detected on my local network, but the LED keep blinking twice and repeat.

Maybe it's linked to the firmware upgrade that failed before.

34 people have this problem

Hope i bought only one, because it's doesn't working.

always offline.

i give up

1 person likes this
This device is great. I was having trouble pairing. When both sides are connected, the device does not want to pairing. When I disconnect the wires at the output side, the device was immediately paired with the application and then I connect the wires to the output side. Now everything works great.
I found the solution to my problem was the routers firewall. When dropping the firewall I was able to complete the setup in minutes and would show up online. When firewall is up the signal was lost. So I'm going to find a way to get MAC address or give a static ip so I can port forward each device. So far I have 3 devices and looking to add more. The one that gave me the same problem as you guys is Sonoff POW. The other 2 switches worked fine.

1 person likes this
I had the same issue. Simple fix. Unplug unit for 8 to 10 seconds. Plug back in. Your app will now recognize unit.

I had the same problem went through the whole process of linking again and it hasn't happened since (keep my fingers crossed!) 

But if it goes offline when you cannott access the unit , say your on holiday returning and you have the unit set to turn on the heating for your return and cannot then the system is useless unit is better than a unit that does not work !!! but as I said since re boot its worked fine  

I needed to change the configured router so followed their procedure. Device was detected and configured. Responded as it was supposed to. Then when I powered off the router and moved it to a different location, actually closer to the Sonoff devices, I am connected to the internet at full speed, the device keeps "double blinking" which apparently means it has connected to the router but can't log on to my account. Why?


I had a similar issue. Reconfigured numerous times, but with no joy. One last thing I tried was removing my Wifi extender. Fortunately my device is close enough to my router to connect. This seems to have worked, however it could just have been a coincidence. I wish there was a way to control the devices directly without an internet connection. Also, will preset timers keep working if connection is lost?

I hope we can get this solved otherwise I'll have to go back to TP link.

I have the same problem, Only eith Sonoff POW, I have 3 and all is offline! All my other TH10/16 basis... all is ok. Problem is only with POW. Please fix it.

1 person likes this
Trying to connect a POW and TH16 just now and although able to connect them to he ewelink app they won't go online.   Led flashes twice - then repeats, suggests it is not connecting to the server.   I strangely did manage to connect a Sonoff DIY device at the same time without any problem.

Is the server down - is the server status reported anywhere.


Also had a problem today trying to get a Sonoff POW and TH16 to work - both register with the APP but won't go online.   LED blinks twice - is there a problem with the server?    Strangely I managed to get a Sonoff DIY to register and work fine.

Would be useful if the server status could be displayed somewhere.



I bought 3 devices (two Sonoff smart switch and Sonoff TH16). After a week,

Sonoff smart switches are ok.

Sonoff TH16 is not working now - my app Ewelink tells me that it is offline. TH16 blinks quickly twice every 1s.

Informations about Sonoff TH16:


ESP_40C883 - it is name in my router

I tried many times to reconnect device (readd) - but app Ewelink still tells it is offline.

I found in my application Ewelink that firmware in TH16 is unknown.

Sonoff TH16 is connected with my router (it gives me feedbacks - ping)

I found out that I should try to connect and try ping to this server - - it works and gives me feedback.


1 person likes this

Well, it seems so one from Sonoff is monitoring this thread. Maybe we should all go give their products bad reviews on Amazon. That should make them sit up and take notice. The product is great value and some are truly unique, but if they are not dependable I'll have to look for other solutions.

1 person likes this

Same for me, Sonoff Pow worked for 10 days and from yesterday it is offline and i could not bring it back. Tried to restart it, deleted and added again from application, it is always offline. It pairs with the router but for some reason can not connect to the server. Another one in the same room is working fine, so I believe that unit is faulted, and that the quality of Sonoff devices is poor.

1 person likes this
What to do?

1 person likes this

I can not believe ... Sonoff team!? Where are you?

Тhis is absolutely frivolous!!!

you are a school company or something else???

This is not serious!!!

3 people like this
Login or Signup to post a comment