Start a new topic

SONOFF device always offline

I've ordered 3 SONOFF and tried to associate them with my eWeLink account.

One of them always appears offline and I don't know what to do to solve that.

It's necessarly a problem with this device (or my account) as the other ones work well.

This device is well detected on my local network, but the LED keep blinking twice and repeat.

Maybe it's linked to the firmware upgrade that failed before.

33 people have this problem

I can not believe ... Sonoff team!? Where are you?

Тhis is absolutely frivolous!!!

you are a school company or something else???

This is not serious!!!

3 people like this

My sonoff TH was working perfectly. But, since one week, keep getting offline/unavailable...

3 people like this
Hello DI'd u find a solution ?

3 people like this
Hello, I have the same problem to a new one TH16.
After some troubleshooting, TH16 is trying to connect server port 8081, but this server doesn't respond to that port. Maybe service is down at server.
Server is replying to ping.

2 people like this

So seems many user here and there can't get there device back online. Where is the support ? Mine keep getting offline since few days. When it's about to sell there product Itead is there, but when consumer need support nobody's there !!!!

I've buy almost 10 sonoff to control my electric warmer because seems to be a good products... I worked 2/3 weeks and...then... server offline... Thx itead !!!!!

2 people like this



Substitude IP address of to


Right now for some reason current IP doesn't accept connection to 8081 port, but the old one - does. You can check it by:


telnet 8081


telnet 8081


Here is an example how to make a substitution in Mikrotik router:

Open Winbox

Get to "IP > DNS" menu

Click on "Static"

Click on "+" (add static DNS entry)


Regexp: <leave empty>


TTL: <leave by default [1d 00:00:00]>

Click on "OK"

Close the DNS Static subwindow

Click on "Apply"

Profit! Now your POW is online!

2 people like this
i did the ping thing all is ok.
The big thing at the CES gathering this year was Home Automation.  I am trying to get into it but purchased itead stuff and it doesn't work and itead doesn't seem to have a way to make it work.  Don't you folks see the future business there are millions of things to turn on and off.  Someone there should be very concerned that the stuff you sell doesn't work.  The only solution I am getting is.  Oh well, sorry we want it to work but we don't know how to get it to work.


2 people like this
lots of questions but no answers.  I have  2 switches that say offline.  isn't there something to do get them to function?  Watched the videos on You Tube.  They make it look so easy, I follow what they are doing but mine remain OFFLINE.  HELP please.


1 person likes this
I have the same problem. All of my 11 th16 went offline. Nothing helps, I don't know what to do

1 person likes this

Hope i bought only one, because it's doesn't working.

always offline.

i give up

1 person likes this
Bought sonoff installed it as per instructions ...then says ' off line ' tried three times to install says device elreadt installed ... told to power unit down , wait ,then power up and all should be ok but still 'off line' what am I doing wrong ?????

1 person likes this
My sonoff worked for about 4 weeks then it show off line. I tried to delete app and then added device still not worked. When I added device, it show that password 12345678 is wrong.
(77.7 KB)

1 person likes this
I found the solution to my problem was the routers firewall. When dropping the firewall I was able to complete the setup in minutes and would show up online. When firewall is up the signal was lost. So I'm going to find a way to get MAC address or give a static ip so I can port forward each device. So far I have 3 devices and looking to add more. The one that gave me the same problem as you guys is Sonoff POW. The other 2 switches worked fine.

1 person likes this

I have the same problem, Only eith Sonoff POW, I have 3 and all is offline! All my other TH10/16 basis... all is ok. Problem is only with POW. Please fix it.

1 person likes this


I bought 3 devices (two Sonoff smart switch and Sonoff TH16). After a week,

Sonoff smart switches are ok.

Sonoff TH16 is not working now - my app Ewelink tells me that it is offline. TH16 blinks quickly twice every 1s.

Informations about Sonoff TH16:


ESP_40C883 - it is name in my router

I tried many times to reconnect device (readd) - but app Ewelink still tells it is offline.

I found in my application Ewelink that firmware in TH16 is unknown.

Sonoff TH16 is connected with my router (it gives me feedbacks - ping)

I found out that I should try to connect and try ping to this server - - it works and gives me feedback.


1 person likes this
Login or Signup to post a comment